Jump to content

Google is indexing members profile pictures and backgrounds


Himadri Goswami
 Share

Recommended Posts

You have to place the images in it’s own storage location first. You can set that in the ACP:
System → Files → Storage Location. 

Not really sure if it’s worth it though. Either your site or specific sections (like forums, profile pages and so on) are public or not. And you have the permission settings to control that. But when you set it to public, it’s public. If you need more privacy protection for your user, I don’t think blocking specific images from search engine indexing will get you very far. 

Link to comment
Share on other sites

On 3/20/2016 at 6:07 PM, opentype said:

You have to place the images in it’s own storage location first. You can set that in the ACP:
System → Files → Storage Location. 

Not really sure if it’s worth it though. Either your site or specific sections (like forums, profile pages and so on) are public or not. And you have the permission settings to control that. But when you set it to public, it’s public. If you need more privacy protection for your user, I don’t think blocking specific images from search engine indexing will get you very far. 

Ok, I tried this.  It works fine absolutely fine when used local file system.  I created a new file location for profiles, and they go there with an url   /uploads/profiles.  Problem comes when I am using this with amazon s3 and cloudfront, the files doesnot move to mybucket/profiles. Instead it goes to a common folder with other images. Then, I tried defining a new s3 upload location for profiles by creating a subfolder within the existing s3 bucket as mybucket/profiles. Now the images moved to desired folder. But my profile images were all broken. Upon inspecting the link to images, I found that it still points to the old url, where images are not there . 

So, my profile pictures are now at mybucket/profiles and correct cdn link should be cdn.domain.com/profiles/monthlyxxxx/image.jpg 

The above link loads the profile image when checked in a new browser.

But my profiles are still pointed to cdn.domian.com/monthlyxxxx/images.jpg, where images are no more. And this leads to broken image.

 

Finally couldn't  achieve this and got back to the local file system. 

Link to comment
Share on other sites

  • 2 weeks later...
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...