Jump to content

Internal Server Error 500 after enabling XCache


Recommended Posts

Hello guys, running IBP and I am having an issue everytime I enable XCache in my settings. I follow the instructions and download the new constants.php file, which I then upload to the root folder of my IPB install.

Once I do this, I click the Continue button and I get the Internal Server Error 500 message. The only way to regain access to the system is by uploading the latest constant.php file I had before enabling XCache.

XCache is installed on my server, BTW.

What could be the issue?

PS: I leave the Data Storage Method as File System. Do I need to change it to MySQL Database prior to enabling XCache?

I get the following error message in the error_log file:

[14-Mar-2016 00:21:11 UTC] PHP Fatal error:  Uncaught exception 'ErrorException' with message 'xcache_isset(): XCache var cache was not initialized properly. Check php log for actual reason' in /home/xxxxxxx/public_html/comunidad/system/Data/Cache/Xcache.php:85
Stack trace:
#0 [internal function]: IPS\IPS::errorHandler(2, 'xcache_isset():...', '/home/ab38956/p...', 85, Array)
#1 /home/xxxxxxx/public_html/comunidad/system/Data/Cache/Xcache.php(85): xcache_isset('c20ee804fc_sett...')
#2 /home/xxxxxxx/public_html/comunidad/system/Data/AbstractData.php(115): IPS\Data\Cache\_Xcache->exists('settings')
#3 /home/xxxxxxx/public_html/comunidad/system/Data/Store.php(173): IPS\Data\_AbstractData->__isset('settings')
#4 /home/xxxxxxx/public_html/comunidad/system/Settings/Settings.php(133): IPS\Data\_Store->__isset('settings')
#5 /home/xxxxxxx/public_html/comunidad/system/Settings/Settings.php(88): IPS\_Settings->loadFromDb()
#6 /home/xxxxxxx/public_html/comunidad/system/Dispatcher/Standard.php(299): IPS\_Settings->__get('task_use_cron')
#7 [internal function]: IPS\Dispatcher\_Standard->__destruct()
#8 {main}
  thrown in /home/xxxxxxx/public_html/comunidad/system/Data/Cache/Xcache.php on line 85


Link to comment
Share on other sites

I thing I did notice is that inside the constants.php file, I have the following:

define( 'CACHE_CONFIG', '[]' );

Is this supposed to be like this even when you have XCache selected? Or is there supposed to be a directory there instead of [ ]?

Link to comment
Share on other sites

2 hours ago, MADMAN32395 said:

Have you read the error as described in the log you posted? 500 is a server error. Typically a setup issue.

I did some poking around and according to someone at cPanel, he indicated that having a PHP 5 Handler set to suPHP, does not work with XCache or any OPCode caching. My PHP 5 Handler is currently set to suPHP.

I checked my WHM settings and I can set my PHP 5 Handler to one of the following:

suPHP, DSO, CGI or none.

Which one should I use as my PHP 5 Handler if I want to be able to use XCache with IPB

I'm afraid of choosing one and rendering my setup unusable.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...