Jump to content

iAwards


-RAW-

Recommended Posts

  • 1 month later...
SELECT count(*) FROM `SNIP_awards_awards` AS `awards_awards` WHERE award_cat_id = IS NULL
IPS\Db\Exception: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'IS NULL' at line 1 (1064)
#0 system/Db/Select.php(373): IPS\_Db->preparedQuery('/*IPS\\Helpers\\T...', Array, true)
#1 system/Db/Select.php(436): IPS\Db\_Select->runQuery()
#2 system/Db/Select.php(355): IPS\Db\_Select->rewind()
#3 system/Helpers/Table/Db.php(308): IPS\Db\_Select->first()
#4 system/Helpers/Table/Table.php(484): IPS\Helpers\Table\_Db->getRows(Array)
#5 applications/awards/modules/front/awards/awards.php(82): IPS\Helpers\Table\_Table->__toString()
#6 system/Dispatcher/Controller.php(96): IPS\awards\modules\front\awards\_awards->manage()
#7 applications/awards/modules/front/awards/awards.php(25): IPS\Dispatcher\_Controller->execute()
#8 system/Dispatcher/Dispatcher.php(152): IPS\awards\modules\front\awards\_awards->execute()
#9 index.php(13): IPS\_Dispatcher->run()
#10 {main}

Can't give or remove and the rules system does work but not showing up on people's account

Link to comment
Share on other sites

3 hours ago, EmpireKickass said:

SELECT count(*) FROM `SNIP_awards_awards` AS `awards_awards` WHERE award_cat_id = IS NULL
IPS\Db\Exception: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'IS NULL' at line 1 (1064)
#0 system/Db/Select.php(373): IPS\_Db->preparedQuery('/*IPS\\Helpers\\T...', Array, true)
#1 system/Db/Select.php(436): IPS\Db\_Select->runQuery()
#2 system/Db/Select.php(355): IPS\Db\_Select->rewind()
#3 system/Helpers/Table/Db.php(308): IPS\Db\_Select->first()
#4 system/Helpers/Table/Table.php(484): IPS\Helpers\Table\_Db->getRows(Array)
#5 applications/awards/modules/front/awards/awards.php(82): IPS\Helpers\Table\_Table->__toString()
#6 system/Dispatcher/Controller.php(96): IPS\awards\modules\front\awards\_awards->manage()
#7 applications/awards/modules/front/awards/awards.php(25): IPS\Dispatcher\_Controller->execute()
#8 system/Dispatcher/Dispatcher.php(152): IPS\awards\modules\front\awards\_awards->execute()
#9 index.php(13): IPS\_Dispatcher->run()
#10 {main}

Can't give or remove and the rules system does work but not showing up on people's account

You might have to employ a fix that was given 10 or 20 pages ago, or something, but… again, the app has worked for me for years.

Link to comment
Share on other sites

Are you sure you're calling up the right award category in your rule?  I would check that because (I'm not a programming guru or anything) it appears that something is happening where the award category id isn't being found I assume ie NULL.  Maybe something changed with the Rules app and the category needs to be updated in a rule you created?

hth

Link to comment
Share on other sites

  • 1 month later...

Hello, there is an group permission error with the iawards plugin. When setting up permissions and whatnot and save it comes back as an error and so only way to deal with this at the moment is to disable iawards then setup the permissions save then enable. That being said the iawards permissions tab is broken to the point that can't be saved.

So you need to check over that.. 

Link to comment
Share on other sites

  • 5 weeks later...
  • 2 weeks later...
  • 3 weeks later...

Hello! I'm trying to display the award description on users' profile and hover pane, instead of time awarded and reason. So I've changed the template like this:

<!--<span class="ipsType_light ipsType_noBreak" style="cursor:default;" title="{datetime="$award->date" norelative="true"}">{lang="award_awarded"}{datetime="$award->date"}{{if settings.award_settings_show_giver}}, {lang="by"} {$giver->link()|raw}{{endif}}</span>-->
	<hr class="awardsHr">
	{$award->desc|raw}
	<!--{{if $award->reason}}
	{$award->reason|raw}
	{{else}}
	<em>{lang="award_title_reason_awarded_no_reason"}</em>
	{{endif}}-->

While the time awarded and reason is hidden, the description won't display. Is there something I'm doing wrong?

testawarddescription.thumb.png.d94d323c83f34e585a3e8b9f455a59f2.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...