Jump to content

Expire PM Attachments (Support)


Michael.J
 Share

Recommended Posts

Removes old PM attachments with the ability to send a warning PM X days before removal.

Features v1:

  • Set how many days after sending before attachments are removed.
  • Set how many days before removal will a PM warning be sent.
  • Restrict the removal to attachments above a specific file size.
  • Exclude selected groups from having their attachments removed.
  • Send an optional warning PM before removal detailing attachment details and removal date.

 

 

Link to comment
Share on other sites

  • 4 months later...
  • 1 year later...
  • 1 year later...
  • 4 weeks later...
  • 1 month later...

Error from the log: DateInterval::__construct(): Unknown or bad format (PD)

I see what's wrong.  Removal time frame, Warning time frame, and Size Trigger are all 0 in my settings.  Which is weird because I thought I changed those settings upon installation. 

1333303325_ExpirePM.thumb.JPG.4ccf578bf5f4995082fb03be8e89d095.JPG

Link to comment
Share on other sites

Hi @Mike John  saw this in the system log

DateInterval::__construct(): Unknown or bad format (PD)

#0 /home/nginx/domains/mycommunity.com/public/plugins/expirepmattachments/tasks/expireAttachments.php(60): DateInterval->__construct('PD')
#1 /home/nginx/domains/mycommunity.com/public/system/Task/Task.php(255): IPS\pluginTasks\_expireAttachments->execute()
#2 /home/nginx/domains/mycommunity.com/public/system/Task/Task.php(224): IPS\_Task->run()
#3 /home/nginx/domains/mycommunity.com/public/applications/core/interface/task/task.php(62): IPS\_Task->runAndLog()
#4 {main}

 

Link to comment
Share on other sites

  • 2 weeks later...
On 5/20/2019 at 1:34 AM, Joel R said:

I see what's wrong.  Removal time frame, Warning time frame, and Size Trigger are all 0 in my settings.  Which is weird because I thought I changed those settings upon installation. 

Did the settings "stick" after you set them again?

On 5/27/2019 at 11:01 PM, Joel R said:

  saw this in the system log

Do you have ftp access to your files? I actually had a similar issue with the birthday greeter some time ago. I've got a test patch you can try until the next version is released.

Link to comment
Share on other sites

  • 4 weeks later...
On 6/10/2019 at 11:08 PM, Mike John said:

Did the settings "stick" after you set them again?

Do you have ftp access to your files? I actually had a similar issue with the birthday greeter some time ago. I've got a test patch you can try until the next version is released.

Hi @Mike John

I continue to have errors on the plugin.  I believe the settings do not save.  

 

Link to comment
Share on other sites

  • 1 month later...
  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...