Jump to content

Upgrade to Version 4.1.4.1 returns NO_STEP


Oren Arizoni
 Share

Recommended Posts

Hey,

I am trying to upgrade my forum to the latest Version: 4.1.4.1, I have uploaded all the files needed, on the forum I press 'Continue' and then  I am getting an error:

NO_STEP - applications/core/sources/Setup/Upgrade.php::line 210

elseif ( !method_exists( $this, "step{$step}" ) )
{
     throw new \BadMethodCallException( 'NO_STEP' );
}

without the upgrade, the forum works just fine.

Link to comment
Share on other sites

1 hour ago, MADMAN32395 said:

have you tried reuploading the the suite from the client suite? just to make sure you have all the files.

what do you mean reuploading the suite from client suite?

you download the upgrade zip, unzip upload the files via ftp to the server and hit continue in the admin.

So i have to setup the theme of the forum to the original one before doing any upgrade? I heard people saying something about it? i have no clue.

Link to comment
Share on other sites

if the theme is a different name or not done on default. you shouldnt lose your theme. but never hurts to back your themes up.

 

but yes, https://www.invisionpower.com/clients/index.php the client suite, click on your website under purchases, then download the entire package again, and reupload. then run the updater at yoursite.com/admin/upgrade/

Link to comment
Share on other sites

22 minutes ago, MADMAN32395 said:

if the theme is a different name or not done on default. you shouldnt lose your theme. but never hurts to back your themes up.

 

but yes, https://www.invisionpower.com/clients/index.php the client suite, click on your website under purchases, then download the entire package again, and reupload. then run the updater at yoursite.com/admin/upgrade/

Yes, theme was built based on the original (created by the forum) so shouldn't be any problem there.

I might re-install it from the beginning then.. will it continue to run off the db that I already have? or will it wipe it?

Link to comment
Share on other sites

1 minute ago, Oren Arizoni said:

Yes, theme was built based on the original (created by the forum) so shouldn't be any problem there.

I might re-install it from the beginning then.. will it continue to run off the db that I already have? or will it wipe it?

nope, doing that shouldnt touch your database; I would recommend backing up going between version numbers. if not, go right ahead regardless.

 

 

unless you are looking for 100% fresh start, meaning nuke both forums and database. but im sure you are talking about just the files in FTP?

Edited by MADMAN32395
Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...