Jump to content

Moving a site from apache to nginx (centminmod)


h-y-b-r-i-d
 Share

Recommended Posts

Hey there, hoping to get some help from the centminmod/nginx users here.

I just moved from apache, centminmod is setup, seems all good. I have copied all files across, leaving the htaccess and the DB is uploaded also. However, i am getting a 500 error (domain in sig) and at the moment im not entirely sure why. Are there any other hidden IPS settings I need to change over or something?

Edited by DealTrakr
Link to comment
Share on other sites

7 minutes ago, DealTrakr said:

This is my rules. Yet everything but the root page and a few others (activity) fails.


  location / {
 
  try_files $uri $uri/ /index.php?$args;

 

Try this - it's what worked for me.. it's what I had in mine for my FURL's

       

       try_files  $uri $uri/ /index.php;

I think for pages I had to add this in also below the above.

    location ~^(/page/).*(\.php)$ {
        try_files  $uri $uri/ /index.php;
    }

 

Edited by T. D. Perry
Link to comment
Share on other sites

25 minutes ago, DealTrakr said:

Thanks, unfortunately it hasn't worked. Not sure its a issue there as some pages work and im not getting a 500 error. Seems something in the database maybe.

 

https://www.dealtrakr.com/discover/

If that's the page you are referring to, clear your browser cache.  :p
If you are using HSTS you may need to clear it also.

Only place I get an error is Deals and Retailers (Pages?)

56539e20287f9_ScreenShot2015-11-23at5.15

Edited by T. D. Perry
Link to comment
Share on other sites

37 minutes ago, DealTrakr said:

Sorry I dont follow Tracy.

Head checker is getting the errors I get.

500 http://headerchecker.com/?uri=https%3A%2F%2Fwww.dealtrakr.com%2Ftopic%2F12-charging-for-carrier-bags-england-law-change-2015%2F

I thing your probably seeng the old server, due to DNS.

https://www.whatsmydns.net/#A/dealtrakr.com

IP 104.25.51.4

You apparently are also using CloudFlare (which you didn't mention - did you flush your cache there?

Tracys-Mac-mini:~ tracy$ ping -c3 dealtrakr.com
PING dealtrakr.com (104.25.51.4): 56 data bytes
64 bytes from 104.25.51.4: icmp_seq=0 ttl=59 time=36.467 ms
64 bytes from 104.25.51.4: icmp_seq=1 ttl=59 time=37.204 ms
64 bytes from 104.25.51.4: icmp_seq=2 ttl=59 time=34.268 ms
Tracys-Mac-mini:~ tracy$ curl -I dealtrakr.com
HTTP/1.1 301 Moved Permanently
Date: Tue, 24 Nov 2015 00:07:37 GMT
Connection: keep-alive
Set-Cookie: __cfduid=df8e079a2b3fc6be973e14a7871fa21b41448323657; expires=Wed, 23-Nov-16 00:07:37 GMT; path=/; domain=.dealtrakr.com; HttpOnly
Location: https://www.dealtrakr.com/
X-Content-Type-Options: nosniff
Server: cloudflare-nginx
CF-RAY: 24a0dfe849a537d4-ATL

 

Link to comment
Share on other sites

When I made the thread listed above, I moved from Apache 3.4.8 db and files.  I did the upgrade from 3.4.8 to 4.1.3.2 on Centmin Mod.  I'm using the vhost file in my thread and everything (I have all the apps) is working fine on my local testing machine.  Even pages I made work.  eva2000 (developer of CENTMIN MOD) even looked over the vhost file listed in my thread and worked with me getting the vhost file in order.

Here is a reference link to the discussion on the Centmin Mod forum:  https://community.centminmod.com/threads/ipb-v4-1-x-files.4922/

Additional Note:  I didn't actually install 3.4.8 on CENTMIN and then upgrade.  I uploaded the 3.4.8 database, uploaded the 4.1.3.2 files, uploaded the necessary 3.4.8 files and folders, and ran the upgrade.  I never had a working, or attempted to have a working version of 3.4.8 on CENTMIN MOD.

Edited by Bluto
Link to comment
Share on other sites

 

3 minutes ago, DealTrakr said:

Updated curl and recompiled php and all good, thanks for the help all.

Regarding urls I have this only and it works will all apps.

 try_files        $uri $uri/ /index.php;

I thought I had mine licked with a similar... but ran into issues in the ACP specifically (the front end was pretty much fine except for pages).

Link to comment
Share on other sites

4 hours ago, DealTrakr said:

Bluto,thanks for the help. The only thing i think that is essential is: And I have that added. Regardless the problem exists with Friendly URLs turned off.

 


try_files    $uri $uri/ /index.php;

 

I believe that is included in this location:

    location / {

        # block common exploits, sql injections etc
        include /usr/local/nginx/conf/block.conf;

        # Enables directory listings when index file not found
        # autoindex  on;

        # Shows file listing times as local time
        autoindex_localtime on;

        try_files    $uri $uri/ /index.php;

    }

 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...