Jump to content

Community

teraßyte

(TB) Bump Up Topics

Recommended Posts

Have you considered an ACP module where you could cron all kind of bumps ? 
It would be very very useful for an admin to control bumps through a cron. This way I could have a list of, for example, 10 or 20 topisc that I want to bump during the week.

I could even charge users for bumping their topics, specially in my community that some topics are just classifieds. 

 

PS: I love this mod, it's very useful for my community since post owners can bump their topics without adding pointless posts

Edited by gabs007

Share this post


Link to post
Share on other sites
On 6/8/2016 at 9:38 PM, RobertD said:

issue on 4.1.13 with template not existing

152db0c8a3d24863a634655b6a97ca6e.png

Try re-installing the plugin. Sounds like the template was not recached properly.

 

On 12/8/2016 at 7:25 PM, gabs007 said:

Have you considered an ACP module where you could cron all kind of bumps ? 
It would be very very useful for an admin to control bumps through a cron. This way I could have a list of, for example, 10 or 20 topisc that I want to bump during the week.

I could even charge users for bumping their topics, specially in my community that some topics are just classifieds. 

 

PS: I love this mod, it's very useful for my community since post owners can bump their topics without adding pointless posts

Nope, I never considered it. You are the first one to even mention this kind of feature. I'll add it to my list of possible features, but unless more people show interest in it I won't likely add it.

Share this post


Link to post
Share on other sites

I just updated my IPS, but this seemed to be happening before.  I click the Unread content stream, read the first post, click the Next Unread Topic at the bottom.  A "Bumped" post shows up, I scroll to the bottom click the Next Unread Topic read that topin, then when I go to Next Unread Topic it's the same topic from the previous pagfe that was bumped.  This happens again and again.  It doesn't seem to register that I read it.  I am positive it has not been bumped again and again.

I just tried to uninstall and got this error:

IPS\Db\Exception: Can't DROP 'tb_but_use'; check that column/key exists (1091)
#0 /home/admin/domains/squarewheelscycling.com/public_html/system/Db/Db.php(1762): IPS\_Db->query('ALTER TABLE `co...')
#1 /home/admin/domains/squarewheelscycling.com/public_html/plugins/tbbumpuptopics/uninstall.php(18): IPS\_Db->dropColumn('core_groups', Array)
#2 /home/admin/domains/squarewheelscycling.com/public_html/system/Plugin/Plugin.php(471): require_once('/home/admin/dom...')
#3 /home/admin/domains/squarewheelscycling.com/public_html/system/Node/Controller.php(1198): IPS\_Plugin->delete()
#4 [internal function]: IPS\Node\_Controller->delete()
#5 /home/admin/domains/squarewheelscycling.com/public_html/system/Dispatcher/Controller.php(85): call_user_func(Array)
#6 /home/admin/domains/squarewheelscycling.com/public_html/system/Node/Controller.php(63): IPS\Dispatcher\_Controller->execute()
#7 /home/admin/domains/squarewheelscycling.com/public_html/applications/core/modules/admin/applications/plugins.php(39): IPS\Node\_Controller->execute()
#8 /home/admin/domains/squarewheelscycling.com/public_html/system/Dispatcher/Dispatcher.php(129): IPS\core\modules\admin\applications\_plugins->execute()
#9 /home/admin/domains/squarewheelscycling.com/public_html/amadeus/index.php(13): IPS\_Dispatcher->run()
#10 {main}

 

Can you please help me uninstall it?

Thanks!

Share this post


Link to post
Share on other sites

Hi, when I try to uninstall the plugin I get this error:

Quote

EX1091 Something went wrong. Please try again.

Details:

IPS\Db\Exception: Can't DROP 'tb_but_use'; check that column/key exists (1091)
#0 /home/chronill/public_html/system/Db/Db.php(1895): IPS\_Db->query('ALTER TABLE `co...')
#1 /home/chronill/public_html/plugins/tbbumpuptopics/uninstall.php(18): IPS\_Db->dropColumn('core_groups', Array)
#2 /home/chronill/public_html/system/Plugin/Plugin.php(477): require_once('/home/chronill/...')
#3 /home/chronill/public_html/system/Node/Controller.php(1205): IPS\_Plugin->delete()
#4 /home/chronill/public_html/system/Dispatcher/Controller.php(86): IPS\Node\_Controller->delete()
#5 /home/chronill/public_html/system/Node/Controller.php(63): IPS\Dispatcher\_Controller->execute()
#6 /home/chronill/public_html/applications/core/modules/admin/applications/plugins.php(39): IPS\Node\_Controller->execute()
#7 /home/chronill/public_html/system/Dispatcher/Dispatcher.php(129): IPS\core\modules\admin\applications\_plugins->execute()
#8 /home/chronill/public_html/admin/index.php(14): IPS\_Dispatcher->run()
#9 {main}

Do you think this is directly to do with the plugin or something else (maybe a core bug)?

Share this post


Link to post
Share on other sites
14 hours ago, Simon Woods said:

Hi, when I try to uninstall the plugin I get this error:

Details:


IPS\Db\Exception: Can't DROP 'tb_but_use'; check that column/key exists (1091)
#0 /home/chronill/public_html/system/Db/Db.php(1895): IPS\_Db->query('ALTER TABLE `co...')
#1 /home/chronill/public_html/plugins/tbbumpuptopics/uninstall.php(18): IPS\_Db->dropColumn('core_groups', Array)
#2 /home/chronill/public_html/system/Plugin/Plugin.php(477): require_once('/home/chronill/...')
#3 /home/chronill/public_html/system/Node/Controller.php(1205): IPS\_Plugin->delete()
#4 /home/chronill/public_html/system/Dispatcher/Controller.php(86): IPS\Node\_Controller->delete()
#5 /home/chronill/public_html/system/Node/Controller.php(63): IPS\Dispatcher\_Controller->execute()
#6 /home/chronill/public_html/applications/core/modules/admin/applications/plugins.php(39): IPS\Node\_Controller->execute()
#7 /home/chronill/public_html/system/Dispatcher/Dispatcher.php(129): IPS\core\modules\admin\applications\_plugins->execute()
#8 /home/chronill/public_html/admin/index.php(14): IPS\_Dispatcher->run()
#9 {main}

Do you think this is directly to do with the plugin or something else (maybe a core bug)?

I think I know what the issue is. I'm currently out, I'll check when I'm back home in a few hours.

Share this post


Link to post
Share on other sites

NEW 3.0.3 version is out:

Quote
  • Fixed the error message not display correctly the number of days/hours remaining
  • Fixed the uninstall process not handling correctly some columns

 

@Simon Woods Update the plugin to this new version and then try to uninstall it again, it should work properly after the update.

Edited by teraßyte

Share this post


Link to post
Share on other sites

Cron bumping of selected topics idea is truly very good and interesting.

Anyway even if that does not get added. I like to thank teraßyte for supporting and updating this mod throughout all this time. I use it since 3.1.x days and absolutely love it. Hope you will update this to 4.2 in the future :)

Share this post


Link to post
Share on other sites
8 minutes ago, Red Slammer said:

Is it possible to add an option where the bump timer only applies to the specific topic that was bumped and not all the topics created by that user?

It is possible, but that would require to save a LOT more data to keep track of the time for EACH single topic. I could maybe work around it by rewriting how the hook works to use less data, but unless it is a widely requested feature I won't consider it (at least for now).

Share this post


Link to post
Share on other sites
On 6/19/2017 at 10:11 PM, GoDuBois said:

I am still hoping for a topic to go to an  "unread" bumped topic and also show it in the recent topics/Replies.

 

 

Is this possible? I'm willing to pay $50 for the edit.. Let me know please.

Share this post


Link to post
Share on other sites

On IPB 4.2.2 when i try edit groups get error:

OutOfRangeException:  (0)
#0 /var/www/tibiaking/forum/system/Node/Model.php(1048): IPS\Patterns\_ActiveRecord::load(316)
#1 /var/www/tibiaking/forum/system/Node/Model.php(1065): IPS\Node\_Model->parent()
#2 /var/www/tibiaking/forum/system/Content/ClubContainer.php(276): IPS\Node\_Model->parents()
#3 /var/www/tibiaking/forum/system/Helpers/Form/Node.php(224): IPS\forums\_Forum->parents()
#4 /var/www/tibiaking/forum/system/Helpers/Form/FormAbstract.php(264): IPS\Helpers\Form\_Node->html()
#5 /var/www/tibiaking/forum/system/Helpers/Form/Form.php(415): IPS\Helpers\Form\_FormAbstract->rowHtml(Object(IPS\Helpers\Form))
#6 /var/www/tibiaking/forum/system/Theme/Theme.php(809) : eval()'d code(324): IPS\Helpers\_Form->__toString()
#7 /var/www/tibiaking/forum/system/Theme/SandboxedTemplate.php(56): IPS\Theme\class_core_admin_global->block('303c9915d563ce0...', Object(IPS\Helpers\Form))
#8 /var/www/tibiaking/forum/applications/core/modules/admin/members/groups.php(218): IPS\Theme\_SandboxedTemplate->__call('block', Array)
#9 /var/www/tibiaking/forum/system/Dispatcher/Controller.php(85): IPS\core\modules\admin\members\_groups->form()
#10 /var/www/tibiaking/forum/applications/core/modules/admin/members/groups.php(34): IPS\Dispatcher\_Controller->execute()
#11 /var/www/tibiaking/forum/system/Dispatcher/Dispatcher.php(146): IPS\core\modules\admin\members\_groups->execute()
#12 /var/www/tibiaking/forum/admin/index.php(13): IPS\_Dispatcher->run()
#13 {main}

 

Share this post


Link to post
Share on other sites

Working for me in 4.2.3.

@Matk try disabling all other plugins and applications and then try it.  I had the same issue, but it ended up being another application.  I ended up finding the bad application by enabling them one by one.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...