Jump to content

Autoloader and Traits


CodingJungle
 Share

Go to solution Solved by Mark,

Recommended Posts

Since 4.1 is pushing a minimum of php 5.4, can we get the autoloader to work with traits?

 

/* is it a trait? */
if ( function_exists('trait_exists') and trait_exists( "{$namespace}\\{$class}", FALSE ) )
{
	return;
}

add this to the init.php after the interface_exists check on line 274, allows traits to be loaded and used :) (and for whatever reason, if they are still able to use php 5.3 with 4.1, then it wont error out looking for a non existent function ) :)

Edited by CodingJungle
Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...