Jump to content
Holiday Closure, Nov 26 & 27 ×

Community

Recommended Posts

  • Replies 412
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

New version submitted and is awaiting review/approval.

About This File This plugin will display the country flag of user in several places of the entire suite, including third-party resources. It uses the Geolocation to grab the country when a n

hello i have the same version 4.5.2 problem. Member country 1.3.3   I cannot change the flags remain the same as the ones I used when I registered. I put the flag of France I want to change

Posted Images

I just installed this on 4.5.2 through the marketplace. I can't get the "Display country flags only in" setting to work. I currently have it enabled only in commerce but my flag is showing everywhere. Here are the settings i have enabled before launching it for every user. 

 

1173027128_ScreenShot2020-09-18at8_54_54AM.thumb.png.088e2cafddd3eecf34f1e31614999aef.png

 

84754104_ScreenShot2020-09-18at8_54_45AM.thumb.png.e866bd44320745bf75e11f6b877b0daa.png

Link to post
Share on other sites
32 minutes ago, Chris027 said:

I just installed this on 4.5.2 through the marketplace. I can't get the "Display country flags only in" setting to work. I currently have it enabled only in commerce but my flag is showing everywhere. Here are the settings i have enabled before launching it for every user. 

I have submitted a fix for this. Follow the file to get notified when IPS review and approve the new version. 👍

Link to post
Share on other sites

I attempted to merge two members today.  Discovered a potential problem with Members country.  Some of the error message below:

 

UPDATE `IPS_memberscountry_members` memberscountry_members  SET `mc_member_id`=28872 WHERE mc_member_id=13641
IPS\Db\Exception: Duplicate entry '28872' for key 'PRIMARY' (1062)
#0 /home/public_html/system/Db/Db.php(1161): IPS\_Db->preparedQuery('/*database...', Array)
#1 /home/public_html/applications/memberscountry/extensions/core/MemberSync/Flags.php(35): IPS\_Db->update('`IPS_memberscou...', '`mc_member_id`=...', 'WHERE mc_member...')

 

Link to post
Share on other sites

@Adriano Faria

I have a problem with the country flag icon alignment:

27b5d03e4bc6d4bf3d5e2d2f117339ee.png

The Alignment is fine when I have wide size of forum window, but when I reduce it to what you see on the screenshot the flag is moving a bit to the bottom. Do you know how to fix that or I have to contact with theme author?

Link to post
Share on other sites

Damn this 4.5. Hate it. 

Anyway, I am noticing that the flags are appearing for some users but not all (which was never the case in 4.4). Is this part of the fix that we are waiting for IPS to approve? 

Link to post
Share on other sites
14 hours ago, Xeite said:

@Adriano Faria

I have a problem with the country flag icon alignment:

27b5d03e4bc6d4bf3d5e2d2f117339ee.png

The Alignment is fine when I have wide size of forum window, but when I reduce it to what you see on the screenshot the flag is moving a bit to the bottom. Do you know how to fix that or I have to contact with theme author?

You better try support with the designer. I only support default and not modified theme and as far I can see, the flags are there; the problem is how you are displaying them.

1 hour ago, FZ said:

Damn this 4.5. Hate it. 

Anyway, I am noticing that the flags are appearing for some users but not all (which was never the case in 4.4). Is this part of the fix that we are waiting for IPS to approve? 

Still not decided what to do and it is related to the changes required to the new marketplace:

https://invisioncommunity.com/forums/topic/422365-members-country/?do=findComment&comment=2824210

https://invisioncommunity.com/forums/topic/422365-members-country/?do=findComment&comment=2828526

Link to post
Share on other sites
45 minutes ago, Adriano Faria said:

Still not decided what to do and it is related to the changes required to the new marketplace:

OK. Personally I am so frustrated with 4.5 right now I am thinking of jumping to a different ship. 😞 

Link to post
Share on other sites
2 minutes ago, FZ said:

OK. Personally I am so frustrated with 4.5 right now I am thinking of jumping to a different ship. 😞 

Don’t do it because of this plugin. I’ll improve it. 😉

————————-

What's New in Version 1.3.2

  • Fix the setting to display flags only in specific apps.
  • Fix error when merging members
Link to post
Share on other sites
1 minute ago, Adriano Faria said:

Don’t do it because of this plugin. I’ll improve it. 😉

Not your plugin at all (although it would be nice if things don't change so dramatically with a point upgrade that it causes us webmasters to lose 2 days figuring stuff out). 

I just think that the overall aesthetic of 4.5 is horrible enough to abandon it. Honestly, it reminds me of Windows 3.1. 

Link to post
Share on other sites

An amazing feature that would save me tons of time would be to see the country flag in the New registration admin notification email. 
 

Here’s why: For every user that signs up, we have to check the profile page for spam. Several times per day spammers complete their profiles with spam. To do this, we click the link in the new registration email. 
 

We’ve noticed 99% of this profile spam is from a handful of countries. If we saw the flag in our email, it would be one additional data point we could use to determine if a manual check is necessary. 

Link to post
Share on other sites
1 minute ago, svit said:

As someone else mentioned, we too don't get countries saved as per members' choices, instead, other countries are getting assigned, which makes the app unusable for us, unfortunately. If you could have a look at it would be appreciated.

 

On 10/8/2020 at 1:16 PM, Adriano Faria said:

I will take a look when I have to update this app again. 3 versions in a week or so. Pretty tired of this resource.

Thank you.

 

Link to post
Share on other sites
12 minutes ago, svit said:

As someone else mentioned, we too don't get countries saved as per members' choices, instead, other countries are getting assigned, which makes the app unusable for us, unfortunately. If you could have a look at it would be appreciated.

I don't know if this helps or not, but I find that no matter what country is assigned/changed, it will revert back to the country of the registration IP address.  We haven't allowed registration when using an active VPN for some time, but some older members had used one. I manually changed their registration IP to the appropriate country to correct.

Link to post
Share on other sites

hello i have the same version 4.5.2 problem. Member country 1.3.3

  I cannot change the flags remain the same as the ones I used when I registered.

I put the flag of France I want to change it in Canada it stays in France

i just paid for the app it doesn't work. Thank you . cordially

Edited by francesca2015
Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy