Jump to content
Announcing Achievements! ×

Community

Member's Country


Adriano Faria

Recommended Posts

2 things: 

1: Geolocation won’t work for you because your license is expired. There’s a note in the file description about that. This a Client’s perk.

2:

22 hours ago, Sethhh. said:

I reinstalled it with the last version.

You reinstalled it, so that means you uninstalled it and that will remove the column from members table, which will make the flags go away.

So there’s nothing I can do as you uninstalled the plugin and reinstalled it again. 

22 hours ago, Sethhh. said:

With all these, members profiles are not auto-updated with the country flag.

Again, you show as a MEMBER. You need to be in CLIENT group to use IPS Geolocation. Doubt? Ask to IPS via support ticket. 

Edited by Adriano Faria
Link to comment
Share on other sites

  • 1 month later...
  • Replies 444
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

New version submitted and is awaiting review/approval.

About This File This plugin will display the country flag of user in several places of the entire suite, including third-party resources. It uses the Geolocation to grab the country when a n

What's New in Version 1.0.5: Removed requirement from member perform a login to the country be recognized. Now country will be recognized when the member is online.

Posted Images

Hello Adriano,

Today I just updated your plugin I met some big problems. For example:

Link to comment
Share on other sites

11 minutes ago, Sethhh. said:

Hello Adriano,

Today I just updated your plugin I met some big problems. For example:

What makes you think it is my plugin? Just because you updated it? My plugin has absolutely nothing to do with profile, categories or clubs URLs.

1: I can't reproduce on my dev board and in my online board:

 

2: I can't reproduce in a 4.3.6 client board: https://community.brickpicker.com/forums/

I suggest you to clear cache from the browser and board by using the ACP tool.

Link to comment
Share on other sites

1 hour ago, Adriano Faria said:

So @Sethhh., I see your board is working. What was the problem?

PHP 7.3 is not compatible with Invision Community 4.3.6. We need to stay with PHP 7.2 till the release of Invision Community 4.4 which will be compatible with PHP 7.3.

They named me mad when I said that the problem is from IPBoard but they sent me to you. Sorry!

Link to comment
Share on other sites

  • 3 weeks later...

@Adriano Faria Sorry or the false message before... Just wanted to make sure we weren't reporting something that was resolved in your latest update,

We've installed the latest update and still have the same issue. Where only 1 or 2 users get their location picked up and have the flags visible. We've tested this on our live site and our development environment, and while a user or two gets their flag set, vast majority do not. We thought it could have been our customization, however that wouldn't explain why some users do get set.

I see there is the option to allow users to assign a country with a field, but when we re-created our Location field in the profiles (we had removed it), we couldn't see any way in which updating that field translated to the country flag being set. 

Link to comment
Share on other sites

It was tested in my dev board, my online board and in the client’s board who reported the issue. It is working. I wouldn’t release a version that doesn’t work. 

I will record a video in a couple of hours.

Plus:

16 minutes ago, coert_g said:

I see there is the option to allow users to assign a country with a field, but when we re-created our Location field in the profiles (we had removed it), we couldn't see any way in which updating that field translated to the country flag being set. 

Location field in profile? There was a mod that used a custom profile field. This one here has absolutely nothing to do with it. 

Make sure you are referring to my plugin. 

Link to comment
Share on other sites

18 hours ago, Adriano Faria said:

It was tested in my dev board, my online board and in the client’s board who reported the issue. It is working. I wouldn’t release a version that doesn’t work. 

I will record a video in a couple of hours.

Plus:

Location field in profile? There was a mod that used a custom profile field. This one here has absolutely nothing to do with it. 

Make sure you are referring to my plugin. 

I don't question that your plugin works, I'm just looking for insight as to why we may be having problems running it. It's definitely the Members Country plugin that we're referring to.

image.thumb.png.6dc99e4324ef1a0805c6c11ce8c78dc9.png
From your file documentation in the marketplace.

We can't find any area where a user can pick a country from the account settings as specified. We assumed that must be tied to a profile field, maybe it's not. Our newly registered test accounts seem to get the country correctly set, but existing users, only some get it when they log in.

EDIT: Overnight the issue seems to have resolved itself. We think this was probably due to our own server issues. Thanks for your assistance.

Edited by coert_g
Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

Hello @Adriano Faria

After manual set of country from the account settings, there is no possibility to return to autodetection for these member. Autodetection will only work again if the entries in DB for this member are assigned a default value NULL (not 0). 

It might be more logical to add an autodetection itemsetting to the country select setting in the account settings, or another way to reset value country in DB (not manual selected and not 0)

Edited by MIXOH
Link to comment
Share on other sites

What's New in Version 1.2.2:

  • Fix a template error in the popup of members from specific country
  • Add a field to allow the country to be automatically picked after member choose to not display their country (post above)
    • New option will appear when you choose -- DON'T WANT TO SHOW MY COUNTRY --

yJsSDdz.png

Edited by Adriano Faria
Link to comment
Share on other sites

Your test:

- Plugin enabled:

tR1bkn6.png

- URL that's in your error: http://localhost/440/index.php?/profile/1-adriano/content/&type=calendar_event&sortby=event_reviews&sortdirection=desc

Works fine to me:

2C9AXSY.png

 

Member Content -> Calendar Events -> order by reviews.

Get more info and come back if they still says it's a Members Country issue. I don't see how.

Link to comment
Share on other sites

Just now, Adriano Faria said:

Member Content -> Calendar Events -> order by reviews.

Get more info and come back if they still says it's a Members Country issue. I don't see how.

Quote

Hello,

The issue appears to, on the surface, be caused by one of the third party plugins you have installed. Based on the stacktrace in the error, I would guess the "Members Country" plugin (because this plugin owns hook 1039, which is where the error is triggered from), however it is difficult to be sure.

Thanks,
Brandon Farber
Technical Support / Development

They said "are not sure". I will try to check more.

Link to comment
Share on other sites

  • 3 weeks later...
  • 7 months later...

Adriano,

I'm not able to translate the word "Country" on my community. And I think, I was never able to translate it before 😞 

image.thumb.png.c50735d992130336f0236fc2bcda7b47.png

I'm trying to translate the words, it says, the changes saved, but after updating the page the fields are empty again 😞 

Please help to check, thanks,

 

 

Link to comment
Share on other sites

3 hours ago, alexxis said:

I'm trying to translate the words, it says, the changes saved, but after updating the page the fields are empty again

You have duplicated rows in the word table 'core_sys_lang_words'. Either reinstall the plugin with control of extra language strings in the database in the table core_sys_lang_words or manually delete the extra duplicate rows with the value 'word_plugin' = null. There are only 12 words (rows)

Edited by MIXOH
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy