Jump to content

Community

4.1 editor icons


CA3LE
 Share

Recommended Posts

I just upgraded to 4.1  ... first of all, it went smooth on my large forum, coming from IPS 4.0.

One thing I noticed is that the editor icons aren't displaying properly.

562fd11fe9877_ScreenShot2015-10-27at1.31 562fd010dcf66_ScreenShot2015-10-27at1.27 562fcfe48865e_ScreenShot2015-10-27at1.24

They're all shifted over, if I click the link icon it shows emoticons... etc.  Always just once space off from being correct.  Can you provide a little patch?  From what I can tell it's not my issue because I reverted to default and it's still doing the same thing.  I also tried rearranging them hoping that might reset it or something but again, same issue.

Edited by CA3LE
added another image
Link to comment
Share on other sites

1 hour ago, Hulu said:

Have you tried to Restore Default Configuration?

Yes

1 hour ago, CA3LE said:

... I reverted to default and it's still doing the same thing...

There is also an issue on the adminCP when I create a new forum.

562fe782167f1_ScreenShot2015-10-27at3.05

When I click description it turns into a file upload field.

562fe7802306d_ScreenShot2015-10-27at3.05

 

Link to comment
Share on other sites

Just for grins and giggles (if you are self hosted on a VPS/dedi) see if you can restart the PHP processor and HTTP server.  Sometimes I've seen a caching issue occur if using any OPcode caching or memcached on servers.

In addition try using the ACP -> Support -> Something isn't working correctly option to see if it will rebuild the CSS/templates then restart.

Edited by T. D. Perry
Link to comment
Share on other sites

20 minutes ago, Hulu said:

It's things like this that make me not want to upgrade my official site right now.

Well, other than it "kinking" some of my style stuff (which was easy enough to fix) I haven't had any issues.  I also don't use the built in editor icons, but a theme I got from the support site for it.  The listed issue doesn't effect mine.

Link to comment
Share on other sites

2 hours ago, Tracy Perry said:

Just for grins and giggles (if you are self hosted on a VPS/dedi) see if you can restart the PHP processor and HTTP server.  Sometimes I've seen a caching issue occur if using any OPcode caching or memcached on servers.

In addition try using the ACP -> Support -> Something isn't working correctly option to see if it will rebuild the CSS/templates then restart.

Tried restarting the server and that didn't make a difference. Had already gone through the ACP > Support steps and no luck there. 

Link to comment
Share on other sites

9 minutes ago, Dolfan23b said:

Tried restarting the server and that didn't make a difference. Had already gone through the ACP > Support steps and no luck there. 

Have you tried installing a new style for the editor, choosing it and saving and then going back to the default (doesn't solve the issue of why it's happening but may fix it).  I have other styles installed and all of mine work correctly (the ones I installed and the default ones).

When you say "restart the server" is it just the HTTP server?  If so, does it run the PHP processor itself (I use nginx/php-fpm and have to start each individually).

Edited by T. D. Perry
Link to comment
Share on other sites

2 minutes ago, Tracy Perry said:

Have you tried installing a new style for the editor, choosing it and saving and then going back to the default (doesn't solve the issue of why it's happening but may fix it).  I have other styles installed and all of mine work correctly (the ones I installed and the default ones).

Just tried changing the Moono skin and that worked perfectly. In fact I think my users would prefer that one as it seems to remember that you did or did not use the source button for your last post. Between the people pissed about losing BBCode functionality (e.g. being able to type in the code directly into the editor without having to use a mouse to do something) and now this editor acting wonky I'm not sure how much more they're going to take of 4.x. 

I may try and go back to the default skin once I've played around with the Moono skin a bit. 

Link to comment
Share on other sites

2 hours ago, Dolfan23b said:

Just tried changing the Moono skin and that worked perfectly. In fact I think my users would prefer that one as it seems to remember that you did or did not use the source button for your last post. Between the people pissed about losing BBCode functionality (e.g. being able to type in the code directly into the editor without having to use a mouse to do something) and now this editor acting wonky I'm not sure how much more they're going to take of 4.x. 

I may try and go back to the default skin once I've played around with the Moono skin a bit. 

How exactly do you change the CKEditor theme on IPS4?

Nevermind, found it.

Edited by Xelphos
Link to comment
Share on other sites

10 hours ago, Tracy Perry said:

Well, other than it "kinking" some of my style stuff (which was easy enough to fix) I haven't had any issues.  I also don't use the built in editor icons, but a theme I got from the support site for it.  The listed issue doesn't effect mine.

I may do a test on my local machine with my sites database first and see how that goes.

Link to comment
Share on other sites

13 hours ago, Tracy Perry said:

Just for grins and giggles (if you are self hosted on a VPS/dedi) see if you can restart the PHP processor and HTTP server.  Sometimes I've seen a caching issue occur if using any OPcode caching or memcached on servers.

In addition try using the ACP -> Support -> Something isn't working correctly option to see if it will rebuild the CSS/templates then restart.

I did that... which has worked for me in the past.  It said,

Quote

Sometimes badly cached data can cause problems. We have cleared all cached data, please check and see if your problem has been resolved.

... I went to check it and now the forum is Error 500.  I put a ticket into Invision.  Any ideas?

Link to comment
Share on other sites

1 hour ago, eGullet said:

I wish this was a Q&A forum so we could mark a "best answer"! -- It's not a cache on your web server's end, it's on the users' ends (unfortunately). They need clear their browser's cache. 

I'm certain now that you're right.  ... but now my forum's down because I ran the "Something isn't working correctly." tool.  Been waiting for 3 1/2 hours now for a response on my support ticket. :(  -- opened a forum post around the same time >> https://community.invisionpower.com/topic/422042-error-500-after-running-something-isnt-working-correctly/ 

Link to comment
Share on other sites

30 minutes ago, eGullet said:

Are you self-hosted? You could check your database tables, if you have access to phpMyAdmin or something similar.

Didn't see any "in use" tables or anything odd, ran a repair on all tables with phpmyadmin anyways... same error 500.

Link to comment
Share on other sites

2 hours ago, CA3LE said:

Thanks for the help.  Hopefully they get it resolved soon for me.

Did this turn out to be a style issue for you?  Create a default style and use it and see if it resolves the issue.  If so, then you need to contact the author of your style and see if they have an update.  Apparently styles not being in a 4.1 format can cause some issues.

The other thing that I found when I didi the upgrade (I'm self hosted) is that I downloaded the full package and installed it and ran the upgrade and had a similar 500 error issue.  Turns out I forgot to chown the files back to the correct user/usergroup for the HTTP server (was in a hurry because I had to be at an office within a few minutes for an emergency call).  Once I did that, I had no problems.

Edited by T. D. Perry
Link to comment
Share on other sites

56 minutes ago, Tracy Perry said:

Did this turn out to be a style issue for you?  Create a default style and use it and see if it resolves the issue.  If so, then you need to contact the author of your style and see if they have an update.  Apparently styles not being in a 4.1 format can cause some issues.

The other thing that I found when I didi the upgrade (I'm self hosted) is that I downloaded the full package and installed it and ran the upgrade and had a similar 500 error issue.  Turns out I forgot to chown the files back to the correct user/usergroup for the HTTP server (was in a hurry because I had to be at an office within a few minutes for an emergency call).  Once I did that, I had no problems.

Thanks for the response Tracy,

I've already tried using a default theme and have no plugins or add-ons.  It was also working fine prior to executing "Something isn't working correctly."   Here's an update to that ticket that explains further.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy