Jump to content

UTF-8 convertor error

Recommended Posts


I have a IPB3.4.8 community and I ran the UTF-8 convertor.
All is ok with the convertor, but after there is this error on all pages : 


I tried utf8mb4 et utf8 but with the same error.
A few years ago I was on Phpbb and I migrate it to IPB. Maybe this is the reason ?

What should I do ?
Thank you in advance for help




Link to comment
Share on other sites

I retry one more times the convertor and put the line : 

$INFO['sql_charset'] = 'utf8';

After the line 

$INFO['mysql_tbl_type']            =    'MyISAM';

Now there is no error but all special caracters are broken : 


In the database : 


In a database table cell :




Link to comment
Share on other sites

I tried this  : https://community.invisionpower.com/topic/398034-utf-converter-problems/?do=findComment&comment=2465385

After the restore command line, I got this error : ERROR 1062 (23000) at line 8450: Duplicate entry '1 centime epi a rebord' for key 'idx_keyword_unq'

I emptied the ips_search_keywords table and re-do the backup/restore with no problem

Then I ran the UTF-8 Convertor, and all is ok

It is ok now, but I would like to understand why I needed to do these actions ? Why the UTF-8 convertor is not enough ?
Is there a risk if I do that for my online community ? (i am working now offline)


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...