Jump to content

Max filesize for upload


Kjell Iver Johansen
 Share

Recommended Posts

Its per group setting (say if you need detail on where to adjust this)

However you won't be able to exceed what has been defined for php's limits, ie upload_max and max_post , these two you would need to ask your host how to adjust them as there are a few ways of doing it.

:)

Link to comment
Share on other sites

Thanks @AndyF - before I upgraded I had max filesize 250 Mb and that was displayed as it is on this site now.
How do I enable so that is is showing in the editor - as in my first image (like it is on this site)?
I have unlimited upload filesizes on these groups I'm testing with.

And what is (error) -200?

 

Edited by Kjell Iver Johansen
Link to comment
Share on other sites

200 means 'OK' its not an error as such. I'm not sure why its - 200 though plus it should not really display a 200 in most cases.

If you have it set to unlimited it may not display any limit. Can you temporarily adjust your group to say 100mb max upload and then see if it displays that ?

Link to comment
Share on other sites

1 hour ago, AndyF said:

 Can you temporarily adjust your group to say 100mb max upload and then see if it displays that ?

Yes it does - but still I have the same error. I have a testsite running with a copy of the site. I do not have the issue there, so it should be possible to track it down in a way. Not sure where to look though.

Link to comment
Share on other sites

50 minutes ago, AndyF said:

Test on the default skin and language packs, either of those could (in theory) cause that if there is something amiss with them.

I'm on the default skin - and also tried with English with the same result. I will have a chat with a developer later this evening and will try to track it down then.

I notice that my testboard have  MySQL version 5.5.45-cll. with PHP version 5.4.45., while my mainboard have   MySQL version 5.5.42-cll. and  PHP version 5.3.29. I will try to get my host to upgrade the other server.

Link to comment
Share on other sites

  • 4 weeks later...
7 hours ago, Kjell Iver Johansen said:

As a sidenote - it disappeared after the last upgrade for me.. You're on the latest version?

Yes, its 4.1.3.2.

Today problem dissapeared, after i changed PHP mode on server from FastCGI (Apache) to CGI. But forum works much slower

Link to comment
Share on other sites

Just some additional info. Some of this was already mentioned but I'll clarify.

There are two PHP variables which control upload sizes, which need to be checked and adjusted if necessary. This is done in the server's php.ini file.

Both of them have to be set to the upper limit you want for the server.

post_max_size
upload_max_filesize

As example, if you want a 100 Megabyte limit:

post_max_size=100M
upload_max_filesize=100M

Note that while the software can restrict that further, it cannot override the upper limits set by those two variables.

Link to comment
Share on other sites

11 hours ago, Mark H said:

There are two PHP variables which control upload sizes, which need to be checked and adjusted if necessary. This is done in the server's php.ini file.

Both of them have to be set to the upper limit you want for the server.

post_max_size
upload_max_filesize

I have 500 Mb for them but it doesn't solve this problem

Link to comment
Share on other sites

12 hours ago, Mark H said:

Just some additional info. Some of this was already mentioned but I'll clarify.

There are two PHP variables which control upload sizes, which need to be checked and adjusted if necessary. This is done in the server's php.ini file.

In addition, if one is using nginx as their HTTP server, there is also a setting in it that can control the size of uploads.

From the top of my head, I think it's the client_max_body_size (have had issues with it on other scripts also).  If  using CentOS/CentMin Mod it's set at 50MB.

Edited by T. D. Perry
Link to comment
Share on other sites

10 minutes ago, AndyF said:

Are you having a time out / blank white page or something else ?

How long are the uploads taking ? I guess it might be max input time but that seems a bit unlikely.

I have the same error,Screenshot_6.jpg.1a72df2f1936daff360fede

Upload time < 1 sec.

 

Now, in CGI php mode, upload works, it takes about 5 sec depending on the file size. but the forum running very slow

 

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...