Jump to content

Upgrade php to 5.4 for IPB v4.0.13.1?


John_C
 Share

Recommended Posts

OK, I'm running IPB v3.4.7 and want to install a test forum with v4.0.13.1 on a sub-domain.

I got errors:

Quote

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /admin/install/index.php on line 13

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /admin/install/index.php on line 13

Parse error: syntax error, unexpected T_STRING in /admin/install/index.php on line 13

So basically I need to install php v5.4, correct?

If I install php 5.4 on my GoDaddy shared hosting, will it break my current forum running v3.4.7 on php 5.2.17? Or will the forum automatically recognize the php upgrade and still work? 

 

 

Link to comment
Share on other sites

17 minutes ago, John_C said:

OK, I'm running IPB v3.4.7 and want to install a test forum with v4.0.13.1 on a sub-domain.

I got errors:

So basically I need to install php v5.4, correct?

If I install php 5.4 on my GoDaddy shared hosting, will it break my current forum running v3.4.7 on php 5.2.17? Or will the forum automatically recognize the php upgrade and still work? 

 

 

like you i have 3.4.8 and 4.0.13.1 and 4.1.x beta 2 all on same server all using 5.5.x of php all works fine for me but before i did change i made backup of all the forum just encase as change the version back to old version if any issue happen but nothing went wrong. 

Link to comment
Share on other sites

2 hours ago, RevengeFNF said:

I always update to the latest software and never broked anything.

I even already tested IPS4 with PHP 7 and everything works fine.

Thanks for the input. I'll update php 5.2.17 to php 5.4 tonight then since it won't break 3.4.7. :) 

Link to comment
Share on other sites

Submit a ticket or call GoDaddy tech support and see if they can't update to at least 5.6. They are usually a reasonable bunch over there..

*EDIT*

Now this strange. @RevengeFNF I didn't even see your post here until after I posted the did a refresh to get rid of the editor... And according to the time stamp you posted 7 hours ahead of me....

Damn Poltergeist in my machine must be playing around...

Edited by Woodsman
Link to comment
Share on other sites

I posted a ticket this morning, but no answer yet. I figure they are not there on the weekends since I got no reply today.

I'm impatient. That's why I tried to ask here. I figured someone would know. :D 

Just need to know if upgrading from php 5.2.17 to php 5.4 will work for both IPB 3.4.7 and 4.0.13.1 without breaking the old stable forum that is live right now. 

Link to comment
Share on other sites

  • 4 weeks later...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...