Jump to content
You're invited! Join our 4.6 Live Event on ZOOM 6/24 ×

Community

Theme Error: This theme file could not be saved


Oren Arizoni
 Share

Recommended Posts

Hey Guys,

I installed the forum, updated it with the latest upgrade (yes, the NO_SET error is still happening) and I made sure the /themes/ folder is writeable.

Now, I create a new theme, give it a name -> save -> and change the colors (designer mode) -> save -> no changes in the website. (I changed to the theme in the bottom of the forum), going back to the skin editor it loads the skin but without the changes... whats going on?

Then I went to the manual css/html editor, did some changes -> Save -> and I get this: This theme file could not be saved 

So what to do now? I can't edit my theme with designer mode or manual editor?

I can see there is a new ID to the theme I created, but I don't see any folder for it in the /themes/ folder ...? 

what now?

Link to comment
Share on other sites

2 hours ago, Oren Arizoni said:

Hey Guys,

I installed the forum, updated it with the latest upgrade (yes, the NO_SET error is still happening) and I made sure the /themes/ folder is writeable.

Now, I create a new theme, give it a name -> save -> and change the colors (designer mode) -> save -> no changes in the website. (I changed to the theme in the bottom of the forum), going back to the skin editor it loads the skin but without the changes... whats going on?

Then I went to the manual css/html editor, did some changes -> Save -> and I get this: This theme file could not be saved 

So what to do now? I can't edit my theme with designer mode or manual editor?

I can see there is a new ID to the theme I created, but I don't see any folder for it in the /themes/ folder ...? 

what now?

i guessing this is in 4.0.x ? yes or 4.1. beta ? as normal when create theme need be first in designer mode then add once done this you should have theme in /themes folder with id number this same id number is in admin cp, if don't see folder try turning off designer mode made sure save any changes via sync all themes or select the theme from drop down allow the sync to run then turn design mode back on this should allow the folder to be made again if have any issue please submit ticket via client area to IPS staff so they see if you have bug or not.

Link to comment
Share on other sites

Hey Pete T,

I'm using 4.0.x.

it seems like what fixed it is re-enabling the designer mode and clicking the advanced sync option in the drop down menu of the theme's options.

but then re-editing the theme (designer mode) and saving the new colors will still bring the issue back. is there some kind of cache ??? why can't it load the theme after every refresh ?

manual work will not work, "This theme file could not be saved"

Edited by Oren Arizoni
Link to comment
Share on other sites

8 hours ago, Oren Arizoni said:

Hey Pete T,

I'm using 4.0.x.

it seems like what fixed it is re-enabling the designer mode and clicking the advanced sync option in the drop down menu of the theme's options.

but then re-editing the theme (designer mode) and saving the new colors will still bring the issue back. is there some kind of cache ??? why can't it load the theme after every refresh ?

manual work will not work, "This theme file could not be saved"

sound like bug to me as when i do all my work every time do any html or css in /themes folder it changed after refresh the browser so i go for ticket to IPS via client area.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy