Jump to content

Community

Collections Support Topic


Recommended Posts

  • Replies 291
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hello @Michael.J Are you updating collections for IPS 4.5?  

Please accept my apologies, I answered your question without thinking further and realising what you really wanted to do.. It was really a busy day. As Nathan said, we'll address this.

Open applications/collections/sources/Category/Category.php and try to find  public static $contentItemClass If you couldn't add  /** * @brief Content Item Class */ public static $con

Posted Images

On 3/5/2020 at 12:08 PM, kmk said:

Hi, where I can find a demo? 

PM sent.

On 3/6/2020 at 7:46 AM, pequeno said:

If I select English language no problem and all works fine. If I select other language Collections doesn´t work correctly. No problem with other plugins or Aplications.

Can you you adding a new language and see if the Collections works in there first?

Link to post
Share on other sites
3 hours ago, pequeno said:

Thank you. Same problem with other language.

SOLVED! With this procedure:

1.- Make a copy of the English system language.

2.- Download a copy of the second language.

3.- Install a new version of English Copy. The new version file is the second language downloaded.

4.- Remove second language.

5.- Rename the English Copy language to second language name.

Now works with second language selected.

Thanks!

 

Link to post
Share on other sites
  • 3 weeks later...

Hello @Mike John When a guest visit an item I obtain this template error:

#0 /home/site/public_html/system/Content/Item.php(4267): IPS\Node\_Model->can('reply', Object(IPS\Member), false)
#1 /home/site/public_html/system/Theme/Theme.php(847) : eval()'d code(256): IPS\Content\_Item->commentForm()
#2 /home/site/public_html/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_collections_front_view->comments(Object(IPS\collections\Item))
#3 /home/site/public_html/system/Theme/Theme.php(847) : eval()'d code(1669): IPS\Theme\_SandboxedTemplate->__call('comments', Array)
#4 /home/site/public_html/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_collections_front_view->view(Object(IPS\collections\Item), Array, 'tab_1', '\n<div class='ip...')
#5 /home/site/public_html/applications/collections/modules/front/collections/item.php(203): IPS\Theme\_SandboxedTemplate->__call('view', Array)
#6 /home/site/public_html/system/Dispatcher/Controller.php(96): IPS\collections\modules\front\collections\_item->manage()
#7 /home/site/public_html/system/Content/Controller.php(50): IPS\Dispatcher\_Controller->execute()
#8 /home/site/public_html/applications/collections/modules/front/collections/item.php(34): IPS\Content\_Controller->execute()
#9 /home/site/public_html/system/Dispatcher/Dispatcher.php(152): IPS\collections\modules\front\collections\_item->execute()
#10 /home/site/public_html/index.php(13): IPS\_Dispatcher->run()
#11 {main}

 

Link to post
Share on other sites
35 minutes ago, pequeno said:

Hello @Mike John When a guest visit an item I obtain this template error:


#0 /home/site/public_html/system/Content/Item.php(4267): IPS\Node\_Model->can('reply', Object(IPS\Member), false)
#1 /home/site/public_html/system/Theme/Theme.php(847) : eval()'d code(256): IPS\Content\_Item->commentForm()
#2 /home/site/public_html/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_collections_front_view->comments(Object(IPS\collections\Item))
#3 /home/site/public_html/system/Theme/Theme.php(847) : eval()'d code(1669): IPS\Theme\_SandboxedTemplate->__call('comments', Array)
#4 /home/site/public_html/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_collections_front_view->view(Object(IPS\collections\Item), Array, 'tab_1', '\n<div class='ip...')
#5 /home/site/public_html/applications/collections/modules/front/collections/item.php(203): IPS\Theme\_SandboxedTemplate->__call('view', Array)
#6 /home/site/public_html/system/Dispatcher/Controller.php(96): IPS\collections\modules\front\collections\_item->manage()
#7 /home/site/public_html/system/Content/Controller.php(50): IPS\Dispatcher\_Controller->execute()
#8 /home/site/public_html/applications/collections/modules/front/collections/item.php(34): IPS\Content\_Controller->execute()
#9 /home/site/public_html/system/Dispatcher/Dispatcher.php(152): IPS\collections\modules\front\collections\_item->execute()
#10 /home/site/public_html/index.php(13): IPS\_Dispatcher->run()
#11 {main}

 

An this error in frontend below the comments.

[[Template collections/front/view/comments is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]

Testing with default template and with default language.

Edited by pequeno
Link to post
Share on other sites
18 hours ago, pequeno said:

Hello @Mike John

In items view (mobile versions) it seems that the floats are not "cleared" correctly, hence the overlap. The HTML hasn't really been coded correctly.

Without reactions

1163522481_woreactions.png.590adeb40a0936698bd2d5fd9b6a01ed.png

With reactions

1859192821_withreactions.png.187aeb31fe7c6da12bf02ba3d2ef6077.png

Hello @Mike John I add this code to my custom.css and solve the problem.

.ipsApp .ipsButton_fullWidth {
    display: block;
    width: 100%;
    text-overflow: ellipsis;
    overflow: hidden;
}

Can you confirm that is a correct solution? Thanks.

Link to post
Share on other sites
On 3/29/2020 at 6:55 AM, pequeno said:

Hello @Mike John When a guest visit an item I obtain this template error:

I've attached a patch you can apply until the next update is released here - https://www.devfuse.com/forums/bugs/collections/comments-and-guests-r280/

On 3/30/2020 at 12:08 AM, pequeno said:

In items view (mobile versions) it seems that the floats are not "cleared" correctly, hence the overlap. The HTML hasn't really been coded correctly.

Noted bug and will be fixed. Your custom solution if working across all browsers, should be fine.

Link to post
Share on other sites
4 hours ago, Mike John said:

I've attached a patch you can apply until the next update is released here - https://www.devfuse.com/forums/bugs/collections/comments-and-guests-r280/

Than you for your support @Mike John,

The correct fix is:

Find

{{if $entry->commentForm() || $entry->locked()

And  replace with

{{if \IPS\Member::loggedIn()->member_id AND $entry->commentForm() || $entry->locked()

Be careful with that "if" that you forgot to put it on. 😉

Edited by pequeno
Link to post
Share on other sites
  • 2 months later...
  • 1 month later...

Hi,
First of all, thanks for the application.

Can we add the person's own collection link to the profile window and/or the profile field next to the post? -by clicking an icon (automobile etc.)


If yes: One of the users' profile areas on my forum is about their cars. (My car: AA BB) Can we go to that person's collection by clicking on this information? 

 

 

Screen Shot 2020-08-03 at 23.50.54.png

 

 

Screen Shot 2020-08-04 at 00.00.07.png

Edited by uA_Y_C_A
Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...
  • 3 weeks later...
On 8/25/2020 at 7:47 PM, pequeno said:

Are you updating collections for IPS 4.5?

On 9/1/2020 at 11:07 PM, haqzore said:

@Michael.J - will you be updating here to allow simpler updating with the new 4.5 ACP process?

IPS Marketplace Revisit*
The IPS Marketplace now requires a change to how some data is stored in applications and plugins. This does not affect how a plugin or app work but does require extra changes. Therefore, some apps or plugins will not be immediately updated in the IPS Marketplace and only available on this site. I will revisit these apps and plugins and make the changes needed to have them updated in the IPS Marketplace as well.

Link to post
Share on other sites

@Michael.J

 

If a guest tries to add an item - with an image - the following error displays:

 

Quote

Sorry, there is a problem

Something went wrong. Please try again.

Error code: EX1048

 

 ACP system log:

 

Quote

INSERT INTO `collections_images` ( `image_type`, `image_default`, `image_item_id`, `image_member_id`, `image_name`, `image_url`, `image_date`, `thumb_location`, `thumb_width`, `thumb_height` ) VALUES ( 1, 0, 22, NULL, 'WebsiteHeader.png', 'monthly_2020_09/WebsiteHeader.png.3bf5c215bab7b4184d09ba98404bef06.png', 1600995813, 'monthly_2020_09/WebsiteHeader.thumb.png.19a6af4b985450749807516c7dd7372a.png', 259, 136 )
IPS\Db\Exception: Column 'image_member_id' cannot be null (1048)
#0 /home/system/Db/Db.php(948): IPS\_Db->preparedQuery('/*amazkgxv_cinc...', Array)
#1 /home/applications/collections/sources/Item/Item.php(754): IPS\_Db->insert('collections_ima...', Array)
#2 /home/system/Content/Item.php(438): IPS\collections\_Item->processAfterCreate(NULL, Array)
#3 /home/system/Content/Item.php(133): IPS\Content\_Item::createFromForm(Array, Object(IPS\collections\Category))
#4 /homeapplications/collections/modules/front/collections/submit.php(134): IPS\Content\_Item::create(Object(IPS\collections\Category))
#5 /system/Dispatcher/Controller.php(90): IPS\collections\modules\front\collections\_submit->submit()
#6 /home/applications/collections/modules/front/collections/submit.php(31): IPS\Dispatcher\_Controller->execute()
#7 /home/system/Dispatcher/Dispatcher.php(152): IPS\collections\modules\front\collections\_submit->execute()
#8 /home/index.php(13): IPS\_Dispatcher->run()
#9 {main}

 

backtrace:

 

Quote

#0 /home/init.php(988): IPS\_Log::log('INSERT INTO `co...', 'uncaught_except...')
#1 [internal function]: IPS\IPS::exceptionHandler(Object(IPS\Db\Exception))
#2 {main}

 

Link to post
Share on other sites
  • 1 month later...

Hi, I have upgraded to Invision Community v4.5.4 from V3 and installed Collections 2.2.0 but I get this error when I try to import from the Garage:

image.png.be482007debb6ba131d5c61932edc672.png

This worked previously a few months ago (with a slightly older version of Invision and Collections).  Is there something I am missing?

Also, just to say, I realise I have not uninstalled the Garage app - am I safe to do this now, or will it delete the data from the Garage?

Thanks, Paul

 

Link to post
Share on other sites
  • 4 weeks later...
On 9/25/2020 at 11:08 AM, haqzore said:

If a guest tries to add an item - with an image - the following error displays:

Logged a bug report for this.

On 9/25/2020 at 11:22 AM, haqzore said:

As you can see on the attached screenshot, it would be better for it to use the "single" version of the word because I only have 1 item in the app. It is currently using the Plural it seems?

Fixed to plural but will include a condition to support only 1 item next update.

On 11/4/2020 at 1:39 AM, Paul_S said:

Hi, I have upgraded to Invision Community v4.5.4 from V3 and installed Collections 2.2.0 but I get this error when I try to import from the Garage:

Do you have ftp access to your ipb files? I have a patch you can apply to import.

Do not uninstall the Garage until you have confirmed everything is imported and I'd still create a backup as a precaution.

Link to post
Share on other sites
  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy