Jump to content
You're invited! Join our 4.6 Live Event on ZOOM 6/24 ×

Community

Member Notes


Adriano Faria

Recommended Posts

8 hours ago, Gabriel Torres said:

Regarding my issue #1 above, you are incorrect. The template membernotes > widgets > memberNotes uses the word "By" as follows:

1. Let me explain this to you how this works. I can reuse any language on my templates and this won't bring any problem to the translations. What I can't do is have on my lang.php the same lang_key from other app. This is what causes the translating issue and this doesn't happen on this app. I only has note_by. If you are unsure or wants to make sure, request support to IPS.

Ah, I see what you mean. The lang is hardcoded. The right is by, not By; that's why it isn't translateable. I thought you were saying it was duplicated. Change it to by (lowercase) and you're done. I'll fix it in new version.

2. I will take a look today.

Edited by Adriano Faria
Link to comment
Share on other sites

8 hours ago, Gabriel Torres said:

Regarding issue #2, I still don't see the "note counter" on posts or on the hover card. I have "can view notes" enabled for my usergroup. If you could take a look at that using the credentials I supplies I'd appreciate. Here is a link to a topic where you can check this out, as the topic starter has several notes and the counter should have been there.

http://forum.clubedohardware.com.br/topic/1140038-sugest%C3%A3o-teste-de-fontes-mais-vendidas-atualmente/

That's the condition to this appears on posts:

{{if \IPS\Member::loggedIn()->group['g_viewnotes'] AND $comment->author()->member_notes > 0}}

Same condition with a tiny variable difference is used on miniprofile.

For some reason, this and all other users has notes by the counter is equal to 0. See:

Capturar.png

Not sure why this happened on your end, since the the old members.member_notes is ported to core_members.member_notes when upgrading the board from 3.4 to IPS4. This is untouched when upgrading the app.

A quick query on your board shows that all members has 0 notes:

Capturar.png

Give some time to make a tool to recount and update your members total notes.

Link to comment
Share on other sites

1 hour ago, Adriano Faria said:

Give some time to make a tool to recount and update your members total notes.

Just ran a tool and it's ok now:

Capturar.png

Same for miniprofile:

Capturar.png

:thumbsup:

A propósito, use isso para formatar o campos de perfil no mesmo padrão de posts e lembretes: https://community.invisionpower.com/files/file/7840-profile-fields-style-on-post-bit/

Link to comment
Share on other sites

  • 2 months later...
4 hours ago, Luis Manson said:

Adriano, can we have control to disable the option to send the user a copy?

What's New in Version 2.0.2:

  • Added setting to admin decide if wants moderators to have the ability to send PM to the members. Default to YES.
  • Widget Latest Notes reworked due to a report (permission)

Screenshot_14.png

@Bill Edwards, the widget was totally make from the scratch. Just to let you know, if you want to give this a try.

Link to comment
Share on other sites

  • 4 months later...

I have a couple of issues if you are able to assist please??

Firstly when a note is sent to a member it arrives to them as a PM. However, when they reply to that PM it isn't sent back, the note originator doesn't get the reply, but the member believes it's been sent.

Secondly adding a note generates an error:-

UnderflowException: lang_not_exists__mailsub__membernotes_notification_member_note (0)
#0 /home/atfotfin/public_html/system/Email/Email.php(323): IPS\_Lang->get('mailsub__member...')
#1 /home/atfotfin/public_html/system/Email/Email.php(559): IPS\_Email->compileSubject(Object(IPS\Member), Object(IPS\Lang))
#2 /home/atfotfin/public_html/system/Notification/Notification.php(484): IPS\_Email->mergeAndSend(Array, NULL, NULL, Array, Object(IPS\Lang))
#3 /home/atfotfin/public_html/system/Notification/Notification.php(465): IPS\_Notification->sendEmails(Array, Array)
#4 /home/atfotfin/public_html/applications/membernotes/modules/front/notes/notes.php(162): IPS\_Notification->send()
#5 [internal function]: IPS\membernotes\modules\front\notes\_notes->add()
#6 /home/atfotfin/public_html/system/Dispatcher/Controller.php(85): call_user_func(Array)
#7 /home/atfotfin/public_html/system/Dispatcher/Dispatcher.php(129): IPS\Dispatcher\_Controller->execute()
#8 /home/atfotfin/public_html/index.php(13): IPS\_Dispatcher->run()
#9 {main}

Many thanks

Bill

Link to comment
Share on other sites

4 hours ago, Bill Edwards said:

Firstly when a note is sent to a member it arrives to them as a PM. However, when they reply to that PM it isn't sent back, the note originator doesn't get the reply, but the member believes it's been sent.

That's because the PM has only one member on it: the one that received the note:

Capturar.png

I didn't add the "moderator" who issued the noted to avoid discussion, etc.

Now, the fact is allows to reply is how IPS4 works. Read more:

This is one of those thiings that may be nice to you but can't be to others. I probably will add a new setting to admin choose if wants the moderator to be included on PM.

-------------------------------------

Regarding the error, mine just sent fine. When that error happens? When submitting the note? When the member who received the note logs in

Link to comment
Share on other sites

Thanks for an explanation of the first bit. I've turned off the ability to send by PM. I recently had a huge row with a member who swore blind he had replied to my "PM" with an explanation, which I didn't receive.

 

1 hour ago, Adriano Faria said:

When that error happens?

On sending the note.

Link to comment
Share on other sites

Hello,

When reading system logs, i've seen many occurences of OutOfRangeException for your plugin.

#0 /system/Dispatcher/Front.php(466): IPS\_Widget::load(Object(IPS\membernotes\Application), 'memberNotes', 'XXXXXXX', Array, NULL, 'horizontal')
#1 /system/Dispatcher/Dispatcher.php(131): IPS\Dispatcher\_Front->finish()
#2 index.php(13): IPS\_Dispatcher->run()
#3 {main}

Just to inform you ;)

Also IPS support alert on system check to run these queries:

UPDATE `membernotes_notes` SET `note_content`='' WHERE `note_content` IS NULL;
ALTER TABLE `membernotes_notes` CHANGE COLUMN `note_content` `note_content` TEXT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci NOT NULL COMMENT '';

 

Edited by JiigSaaw
SQL queries added
Link to comment
Share on other sites

I'm also getting EX0 errors when I try to look at member notes from the ModCP, with the latest version of IPS:-

OutOfRangeException:  (0)
#0 /home/SITE/public_html/system/Member/Group.php(107): IPS\Patterns\_ActiveRecord::load(NULL, NULL, NULL)
#1 /home/SITE/public_html/applications/membernotes/extensions/core/ModCpMemberManagement/Notes.php(72): IPS\Member\_Group::load(NULL)
#2 [internal function]: IPS\membernotes\extensions\core\ModCpMemberManagement\_Notes->IPS\membernotes\extensions\core\ModCpMemberManagement\{closure}(NULL, Array)
#3 /home/SITE/public_html/system/Helpers/Table/Db.php(383): call_user_func(Object(Closure), NULL, Array)
#4 /home/SITE/public_html/system/Helpers/Table/Table.php(424): IPS\Helpers\Table\_Db->getRows(Array)
#5 /home/SITE/public_html/applications/membernotes/extensions/core/ModCpMemberManagement/Notes.php(107): IPS\Helpers\Table\_Table->__toString()
#6 [internal function]: IPS\membernotes\extensions\core\ModCpMemberManagement\_Notes->manage()
#7 /home/SITE/public_html/applications/core/extensions/core/ModCp/Members.php(81): call_user_func(Array)
#8 [internal function]: IPS\core\extensions\core\ModCp\_Members->manage()
#9 /home/SITE/public_html/applications/core/modules/front/modcp/modcp.php(67): call_user_func(Array)
#10 /home/SITE/public_html/system/Dispatcher/Controller.php(96): IPS\core\modules\front\modcp\_modcp->manage()
#11 /home/SITE/public_html/system/Dispatcher/Dispatcher.php(129): IPS\Dispatcher\_Controller->execute()
#12 /home/SITE/public_html/index.php(13): IPS\_Dispatcher->run()
#13 {main}

 

Link to comment
Share on other sites

3 hours ago, JiigSaaw said:

When reading system logs, i've seen many occurences of OutOfRangeException for your plugin.

Guess I will have to build this app from the scratch. There are things happening here that I can't simply reproduce... maybe due to server settings, PHP or MySQL versions, etc. I have an error happening to @Bill Edwards like that.

2 minutes ago, Tripp_UK said:

I'm also getting EX0 errors when I try to look at member notes from the ModCP, with the latest version of IPS:-

It seems to be not able to load a group info. Have you deleted any group recently and by any change there are members on it yet?

Nevermind. I can reproduce this on my board.

Edited by Adriano Faria
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy