Jump to content

Installing IPS4 -- License Communication Error


Recommended Posts


I've run into the following problem installing IPS4:

"Your license has not been provided. Please supply your license key in order to continue.... There was an error communicating with the IPS License Server...."

I've installed IPS4 previously and successfully but I now receive this message.  I can roll back to v3.47 and upgrade to v3.48 without even being asked for my license key.

When I supply the license key with or without the  "-TESTINSTALL" suffix and simply receive the same error (understandable if it's a "communication" error).

I've tried using previous v4 releases that I know were successful and still encounter this problem.

Does anybody have any suggestions how to resolve this issue because this is now holding up development of our site? All of the pre-install checks are passed, and as I say, I've done this a few times without any problems until now.

Thanks in advance :)

Link to comment
Share on other sites

Am not saying this is the cause but if you have already set up a test url then cannot use another url using same license or -TESTINSTALL (same applies to live site ... cannot use a different url than the one registered without asking IPS to change for you)

I'm aware of this, but this is the only test (repeated on the same sub-domain) and surely if that was the issue then the error would be something other than:

"There was an error communicating with the IPS License Server...?"

Also, wouldn't the upgrade from IPS 3.4.7 > 3.4.8 also fail due to a license issue? And surely I wouldn't have been able to perform this several times already with success?

That's what's confusing me -- that this has been successful already, and it is now failing with the communication error message.

Link to comment
Share on other sites

The error does suggest a comms issue.

Without * any * comms it would not have much effect on the 3x series during upgrade, at worst it would say it could not communicate or the ACP would have a message box about it. It would not stop the upgrade in 3x at all.

The error message you tend to get for re-using the key or URL is something along the lines of "That URL is already registered" (:I forget the actual wording) or "Invalid Key" (if you have a typo)

Are you blocking anything from invisionpower.com ? Specifically remoteservices.invisionpower.com (the IP range for this really)

Link to comment
Share on other sites

I thought that the error displayed for reusing a key inappropriately was something along that line ("already registered" or "invalid").

I've checked and we aren't blocking anything from invisionpower.com.

It's very strange that the upgrade worked up until a couple of days ago. Obviously I've tried restoring the database and files from prior to the last successful upgrade (and I haven't made any changes to the server in that period) but now I receive the message above.The message does suggest that it's a comms issue, but I can't figure where/why.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...