Jump to content

Community

-FP

Cookie Notice

Recommended Posts

Alright, update is up. New styles and color options. By default it matches the suite scheme :D

I removed the option to block the GA cookie... but I could bring it back if people actually used it.

gmhmu2U.jpg

GnzvrJv.jpg

yU9NMlq.jpg

Edited by -FP

Share this post


Link to post
Share on other sites

updated 3.0 version breaks image scaling in Pages SuperGrid plugin :

@opentype says that cookie plugin is broken :

can you fix it @-FP ? previous cookie notice version working just fine.

Edited by Qubabos

Share this post


Link to post
Share on other sites

I will take a look but it doesn't make much sense for what I've seen so far. When the cookie plugin is enabled, the CSS file that has the style for the "SG_record_image" class is not loaded.

Again, it doesn't make sense to me for now because all my plugin is doing is inserting the code they instruct before the </head> element, it's just passing the plugin settings as the parameters. Maybe there's some conflict between both plugins css sheets. It's not fair to just say "it's the other broken" by the other developer, my plugin works just fine on its own, it would probably do the same if you implement the code manually without a plugin. Anyway, I will take a look later.

Edited by -FP

Share this post


Link to post
Share on other sites

FAIL.

I updated the sheet in the resources folder but for some reason left that one I downloaded incorrectly from the plugins github repository in the css folder. (https://github.com/insites/cookieconsent/)

What's weird is that it was working just fine on my live site.

Thanks. I just updated it to fix that @Qubabos

hHACEIA.png

ffUsDRW.png

Edited by -FP

Share this post


Link to post
Share on other sites

@Joey_M Have you tried re-installing the plugin after installing the theme? 

I really don't know what the problem could be. But I will be able to take a look soon, I'm waiting for @ehren. to release the 4.2 update for the theme I use from him.

Edited by -FP

Share this post


Link to post
Share on other sites
On 16/02/2017 at 0:00 AM, Donkerrood said:

Would it be possible to defer the javascript to just before the </body> tag, if this setting is enabled in the theme settings? Right now, this is my only render-blocking javascript with google pagespeed. Thanks!

@-FP Is this possible? I'm desperately trying to increase my sites performance, and this is one the things @Adlago mentioned trying to do.

Share this post


Link to post
Share on other sites
10 hours ago, Joey_M said:

@-FP Is this possible? I'm desperately trying to increase my sites performance, and this is one the things @Adlago mentioned trying to do.

I tried doing that but I can't get it to work if placed before </body>. This is based on the code by Insites and their instructions are to place it before </head>: https://cookieconsent.insites.com/download/

I will keep looking into it but if anyone has a solution just ping me.

Edited by -FP

Share this post


Link to post
Share on other sites

Do you want it to automatically inherit the theme settings for code placement, or do you prefer an override setting in the plugin options?

Edited by -FP

Share this post


Link to post
Share on other sites
3 hours ago, -FP said:

Do you want it to automatically inherit the theme settings for code placement, or do you prefer an override setting in the plugin options?

I agree with @Qubabos, a plugin setting would be better.

Share this post


Link to post
Share on other sites
7 hours ago, -FP said:

Update is up.

2n2aeOw.png

How do I remove the opacity? I don't like it but changing the value up and down makes no difference it seems.

Cache needed clearing.

Thank you for the update.

Edited by Joey_M

Share this post


Link to post
Share on other sites

@-FP with 3.0.4 and today update 3.0.5 disabling me opacity. How to restore this ? Even "Fixed issue changing opacity. Now plugin's CSS cache is cleared after changing settings" doesnt help much. Loaded JavaScript From Developer Site also doesnt help? Cloudflare could be an issue ? Runing with dev mode also no luck here...

Share this post


Link to post
Share on other sites

@Qubabos you can't change the opacity you mean? I tested 3.0.5 in 2 of my live sites and the opacity change is working.

If you want send me over PM access to your ACP, I can take a look.

Edited by -FP

Share this post


Link to post
Share on other sites
3 minutes ago, -FP said:

you can't change the opacity you mean?

change opacity level or even turn this on... Its always off, no matter what value I put in opacity settings. I prefer to not giving an access into ACP :) 

Edited by Qubabos

Share this post


Link to post
Share on other sites
9 minutes ago, -FP said:

What happens if you set it to 1?

Absolutely nothing, whatever I set there it always looks the same. I try from 0.6 to 1.0 with no change at all. 

Share this post


Link to post
Share on other sites
20 minutes ago, Qubabos said:

Absolutely nothing, whatever I set there it always looks the same. I try from 0.6 to 1.0 with no change at all. 

Try uninstalling the plugin, clearing the cache in the ACP support tool and/or browser, and then reinstall.

Edited by -FP

Share this post


Link to post
Share on other sites
30 minutes ago, -FP said:

Try uninstalling the plugin, clearing the cache in the ACP support tool and/or browser, and then reinstall.

Already did that with your mentioned order :) with no luck. I even check all available browsers so right now have no clue what was the issue, maybe cloudflare shrinks this opacity setting. 

Share this post


Link to post
Share on other sites

Well it might be that, no idea I have no experience with cloudflare, and without being able to take a look myself I really don't know how to help you :(

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...