Jump to content

Community

Cookie Notice


-FP

Recommended Posts

7 hours ago, Joey_M said:

@-FP - For some reason my message doesn't show, I changed it within the plugin setting and it just displays the standard one.

It also shows the cookie in the wrong style, I have it set to dark and yet it's light. May I PM you?

Sure, send me your site URL and what version of the suite you're using.

Link to comment
Share on other sites

10 minutes ago, zelgadis said:

In my site the message doesn't show in my custom Theme. It appears only in the default IPS Theme.

I thought I "fixed" that on the last update, it wasn't showing on my third party theme... that can be hard to controll anyway, if the custom theme has some changes or things that may become a conflict compared to the default theme, I can't predict nor controll that, the plugin just inserts stuff in the global template. (I hate javascript)

What's your site URL anyway? I'll take a look.

Edited by -FP
Link to comment
Share on other sites

9 minutes ago, zelgadis said:

I see it shows in one of the custom themes but not on the default one, for testing, could you try to change the message position to bottom instead of top?

In the theme that it doesn't work, did you set its custom settings to include JS inside the <head> or before </body>?

For some reason the javascript is not being loaded in the custom default theme.

Or PM admin access if you wish, it would be easier to look into this.

Edited by -FP
Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...
2 minutes ago, MaNiAc LRSC said:

What could be the reason that the Cookie notice is not being displayed? Plugin is active, IPB 4.1.7

What's your site URL? if it's the one in your signature, well, plugins JS is not being loaded. One reason could be being in designers mode.

Link to comment
Share on other sites

4 minutes ago, MaNiAc LRSC said:

Yes, that's the correct URL.

Designers Mode is off. But sometimes i got a error when switching it off (1S111/1 reset() expects parameter 1 to be array, null given )

I will upgrade my dev site and test it in a few hours when I finish and leave work.

Link to comment
Share on other sites

  • 3 months later...
  • 4 weeks later...

I'm having problems getting the cookie notice to display on our site.  I've installed the plugin - do I need to make any changes to setting anywhere else in the AdminCP?  We're running IPB 4.1.11.1 and our site has a bespoke theme.

I'm not a developer - I have a little bit of coding knowledge but its pretty basic.  Any help would be greatly appreciated.

Link to comment
Share on other sites

3 minutes ago, -FP said:

Hey @Samantha Smith

Could you try clearing the cache with the support tool in the ACP?

If that doesn't work, I can take a look on your site if you send me access to your ACP (With just permission for the themes and plugins sections)

Hi - yep, cleared the cache as the first line of attack when the cookie notice didn't display but it doesn't seem to have made any difference.  I'll send you a PM with the site access details.

Thanks!

Link to comment
Share on other sites

i've make review (5star), but i cannot see atm...

anyway: installed, translated in ita (inserted translation in review), all work fine but just a small request:

continue....PNG

... and continue!

 

so, very long javascript in source, also for admin/user (cookie already accepted - or, anyway, not necessary).

then, in my opinion, is best to put this javascript in js file and, maybe, a simple flag "by usergroup" (anyone can enable just for guest and remove unuseful code for logged member) ^_^

 

thanks in advance if reply,

S.N.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy