Jump to content

[IPS4] Tutorials


Adriano Faria

Recommended Posts

Recent have tutorials installed, I try use Extra Field to create filter with select box field, but I found below issues:

1. Miss Extra Field included in clubs tutorials. 

2. Miss filter widget, if it can be added, please add club support too. 

Link to comment
Share on other sites

21 hours ago, kmk said:

Recent have tutorials installed, I try use Extra Field to create filter with select box field, but I found below issues:

1. Miss Extra Field included in clubs tutorials. 

2. Miss filter widget, if it can be added, please add club support too. 

I'll take a look when I have to update the app.

Just now, kmk said:

I use Video Box to collect videos, could you add ability in tutorials records to call use video from Video Box? 

No, it uses Viemo or Youtube only, as stated.

Link to comment
Share on other sites

21 minutes ago, Adriano Faria said:

No, it uses Viemo or Youtube only, as stated.

Just to avoid misunderstanding, I mean Video Box of @onlyME

Due we already have ours videos collected with ips environment app, would be benefit just "choose videos from Videobox" instead go to YouTube or Vimeo, search again, copy address.. And one by one in case of various videos. 

Link to comment
Share on other sites

  • 4 weeks later...

Maybe I'm doing something wrong. But is the Tutorials plugin counting the number of topics, tutorials that have been created?

I am asking because when I use the sidebar forum widgets, it's not counting the number of tutorials/posts that have been added. It's always 0. I've added quite a few but I can't see anything higher than 0.

Is there a way to count the number of tutorials that have been added? 

Thanks

image.png.61db386bcc474c297d45a108042dc184.png

Link to comment
Share on other sites

I don't know if I'm doing something wrong, but I can't see the thumbnails of Vimeo videos. See attachment

I've added the same video. The left one is from YouTube, the right one from Vimeo. Vimeo preview thumbnail cannot be seen. Both videos can be seen once I click on their icons.

Thanks a lot 

 

image.thumb.png.9ea38e83321a4f81852e266f444c4cc3.png

Link to comment
Share on other sites

30 minutes ago, OptimusBain said:

Maybe I'm doing something wrong. But is the Tutorials plugin counting the number of topics, tutorials that have been created?

I am asking because when I use the sidebar forum widgets, it's not counting the number of tutorials/posts that have been added. It's always 0. I've added quite a few but I can't see anything higher than 0.

Is there a way to count the number of tutorials that have been added? 

Thanks

image.png.61db386bcc474c297d45a108042dc184.png

The article in Tutorials and How-Tos is approved or pending approval? If I recall it shows only approved. 

5 minutes ago, OptimusBain said:

I don't know if I'm doing something wrong, but I can't see the thumbnails of Vimeo videos. See attachment

I've added the same video. The left one is from YouTube, the right one from Vimeo. Vimeo preview thumbnail cannot be seen. Both videos can be seen once I click on their icons.

Thanks a lot 

 

image.thumb.png.9ea38e83321a4f81852e266f444c4cc3.png

I don’t use it daily. Will make some tests and update it, if necessary. 

Link to comment
Share on other sites

5 minutes ago, Adriano Faria said:

The article in Tutorials and How-Tos is approved or pending approval? If I recall it shows only approved. 

I am the only person (administrator) adding tutorials right now, the web site hasn't been launched yet. Tutorials do not have to be approved.

image.thumb.png.8b57c425d177d7a4446e10b2b9842789.png

5 minutes ago, Adriano Faria said:

I don’t use it daily. Will make some tests and update it, if necessary. 

Thanks a lot, that would be great!

Edited by OptimusBain
Link to comment
Share on other sites

  • 2 weeks later...
On 2/11/2021 at 11:48 AM, OptimusBain said:

I don't know if I'm doing something wrong, but I can't see the thumbnails of Vimeo videos. See attachment

I've added the same video. The left one is from YouTube, the right one from Vimeo. Vimeo preview thumbnail cannot be seen. Both videos can be seen once I click on their icons.

Thanks a lot 

 

image.thumb.png.9ea38e83321a4f81852e266f444c4cc3.png

Hello, sorry for the time it took.

I just tested a Vimeo video and it seems ok:

sye1ASM.png

The first one is Youtube and the second Vimeo:

byx2B4H.png

I picked a random video: https://vimeo.com/236511493

Which one did you try (URL)?

 

Link to comment
Share on other sites

  • 4 weeks later...

When adding a link to a tutorial, the link won't be displayed as the default established hyperlink. It will look like any other text so users will probably miss the link.

Throughout the forum, links look ok but not in the tutorials module. How can this be fixed? Thanks a lot

When editing the tutorial, I will see the link underlined in black.

image.png.b93f7e6583b249f74133ef1f0ab01bbb.png

When the tutorial is submitted, that style will be gone

image.png.e6cb14f4861e4e500858de4478bbd63e.png

Edited by OptimusBain
Link to comment
Share on other sites

  • 2 weeks later...
2 hours ago, Adriano Faria said:

I will provide a template edit in a couple of hours.

Open Tutorials -> front -> view ->view template and find;

{{if \count( $article->shareLinks() )}}

Change to:

{{if \count( $article->shareLinks() ) AND $article->container()->sharing}}

It will appear twice. Change both.

2 hours ago, Adriano Faria said:

Definitive fix comes in next version. 

👍

Link to comment
Share on other sites

Quick question about the Tutorials Feed Widget. Is there a setting to change the style of the Tutorial title? At least in Bold text by default. See the attachment. At the bottom sidebar you can see IPS default post widget. The title is in bold. The tutorials is at the top, and the titles are in simple regular style.

Is there a setting to change it that I am missing? Could this be something that could be added to the Tutorials app? Adding the time when the tutorial was added would also be a good idea. The post widget does it by default as well. 

Thanks a lot

 

image.png.a0e4490de3ab9b016cee75b0ec6fb8cc.png  

Link to comment
Share on other sites

  • 4 weeks later...
6 minutes ago, AlphaWulfx said:

can someone tell me if there is a site or demo using this so i can see?

I remember this: https://ggames.com.br/tutorials/

6 minutes ago, AlphaWulfx said:

and do you add your own tutos or is there a database ?

You obviously create your own tutorials. That would be like install Forums app and it becomes with topics. 

Link to comment
Share on other sites

  • 1 month later...
Posted (edited)
On 6/15/2021 at 3:03 AM, OptimusBain said:

Good morning,

I was wondering if this Tutorials is compatible with 4.6. I am using it, so I wanted to make sure that it is before upgrading from 4.5 to 4.6. Thanks a lot

Hello,

It is compatible but a new version will be released to add the Post Anonymously feature from IPS 4.6.

IT ISN'T COMPATIBLE. A NEW VERSION SHOULD BE RELEASED IN NEXT DAYS.

Edited by Adriano Faria
Link to comment
Share on other sites

13 minutes ago, OptimusBain said:

Sorry to bother you. I just updated Tutorials on version 4.6 of the community and it's throwing this error. What is that support tool it is referring to? How could I fix this problem? Thanks a lot

I just sent you the fix via private message. I don't want to post it here because this forum is now open to public so this may help those who use nulled versions.

If anyone else needs the fix, send a PM. Final version should be out soon.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...