Jump to content

Advanced Tags & Prefixes - IPS 4.x


Ryan H.

Recommended Posts

I upgraded to Ipb4.x today and purchased the new version on prefixes. I uninstalled all the out of date extensions after the upgrade. I tried to install the .tar file and this message appears. 

 

bf060274a9d4f3978ae13cd128bd1854.png

Can you help me out with how do I get rid of the old files? I thought clicking uninstall would do the trick. 

Link to comment
Share on other sites

1 hour ago, imightbluff said:

I upgraded to Ipb4.x today and purchased the new version on prefixes. I uninstalled all the out of date extensions after the upgrade. I tried to install the .tar file and this message appears. 

 

bf060274a9d4f3978ae13cd128bd1854.png

Can you help me out with how do I get rid of the old files? I thought clicking uninstall would do the trick. 

Please try contacting IPS support about that one. I don't know all of the details of the app installer.

Link to comment
Share on other sites

1 hour ago, Charlie said:

This is still a support issue for the app.  Have you been able to replicate the problem?

Yes and it keeps showing the same error each time, I am going to reinstall the IPB3.x backup, uninstall the mod completely of the 3.x version, install IPB4.x and try install it again. If that doesn't work, than I have no idea on what is going on lol

Edited by imightbluff
Link to comment
Share on other sites

8 hours ago, imightbluff said:

Yes and it keeps showing the same error each time, I am going to reinstall the IPB3.x backup, uninstall the mod completely of the 3.x version, install IPB4.x and try install it again. If that doesn't work, than I have no idea on what is going on lol

I'm told the problem is you're trying to install a new app, instead of upgrade the existing 3.x one. Below the installed apps should be a section, 'out of date apps', and each one has an upgrade button. Use that. If you uninstall it, you're probably going to lose all of the data.

 

10 hours ago, Charlie said:

This is still a support issue for the app.  Have you been able to replicate the problem?

This is standard functionality of the core IPS app installer and setup process, nothing to do with anything I've created. It would be the same for every other application upgraded from 3.x. How is that an app support issue? Support your customers. They're paying for it.

Edited by Ryan H.
Link to comment
Share on other sites

11 hours ago, Ryan H. said:

I'm told the problem is you're trying to install a new app, instead of upgrade the existing 3.x one. Below the installed apps should be a section, 'out of date apps', and each one has an upgrade button. Use that. If you uninstall it, you're probably going to lose all of the data.

When I upgraded to IPB4.x I had all the mods and applications still installed. Than when I went to the applications section, it showed all that were out of date and it just asked me if i wanted to remove them so I removed all of the applications. I didn't really have that many custom tags so I don't mind resetting them up. When I tried to upload the version 4.x of the advanced tags. That is when I was getting the error. 

Right now I just backed up the 3.x version of IPB and uninstalled all the mods, and applications.  The only thing left is the native ones. Going to upgrade to IPB4.x tonight and will try installing the advanced tags again. I will post if it works this time, this is the only thing that I could think of to solve the issue. If it was caused by the fact that I had the old apps still active.

It is most likely because I messed up something during the installation the 1st time that caused the issue, so getting the hosting provider to do the upgrade for me this time. Although not sure how I could have messed it up, it's pretty straight forward process. Well anyway hope it works haha

Edited by imightbluff
Link to comment
Share on other sites

15 hours ago, Ryan H. said:

For your sake, me too! Let me know.

It appears that if you don't uninstall advanced prefixed before the upgrade, it  will cause the error if you uninstall it as IPB4.x.

I just installed it on ipb4.x after doing a clean wipe in ipb3 and it works fine without any errors :)

Edited by imightbluff
Link to comment
Share on other sites

10 minutes ago, imightbluff said:

Yea but this way is really annoying lol I have to go through bunch of forums and manually set 1 prefix across like 5 forums lol and I have like 30+ prefixes of 3rd party sites we promote lol I liked the old way was just so easy to select everything

If no one has suggested an option to add tags or prefixes to multiple forums at a time, I think it's a good idea. What say you, @Ryan H.:smile:

Link to comment
Share on other sites

5 hours ago, imightbluff said:

There is no functionality to select what forums for the tags to be used in?

I recall in IPB3.x version you were able to just select all the forums easily. 

I didn't include that because it's very specific to forums, and I'm trying to avoid that kind of thing in this version. Ultimately, I plan to extend those same forum settings to all content types, in which case setting where it's available from the prefix isn't very feasible anymore.

Nice prefix setup. I like that.

Edited by Ryan H.
Link to comment
Share on other sites

  • 3 weeks later...
3 minutes ago, Yurri said:

Create screen with prefs for ip pages, please, or send me try app?

There is no screen of preferences for IP.Pages. As I said, to my knowledge IP.Pages doesn't support tags and prefixes at all out of box. This app does not add them.

I don't offer a trial or refund period. What you see on the details page is what you get.

Link to comment
Share on other sites

  • 2 weeks later...

I just pushed up a new version. This is the culmination of everything I've wanted to do for the past, oh, years.

Settings should now work for all tag-enabled apps, not just forums, and there's a new Tag Cloud widget.

The generic node support should work out-of-box, but I only had two applications to actually test it with. It's fine for Forums and Calendar. I can't guarantee compatibility with all possible third-party applications, but let me know if you run into problems.

 

What's New in Version 3.1.0

  • Added ability to use custom tag/prefix settings with all tag-enabled content types.
  • Added a highly configurable Tag Cloud widget.
  • Added min/max tags settings overrides.
  • Changed prefix behavior to store separate from predefined tags. The closed tags list does not have to include prefixes anymore.
  • Fixed a possible error on search results.
Edited by Ryan H.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...