Jump to content

Community

Advanced Tags & Prefixes - IPS 4.x


Recommended Posts

  • Replies 1.2k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Good news, everyone: @Kevin Carwile will be taking over Advanced Tags & Prefixes going forward, including ongoing support and maintenance. Don't go too hard on him. I can't speak to what he h

I don't know if you found a temporary fix at this time but for anyone else that may have this problem until a patch is published: This is due to a constant that doesn't exists anymore in IPS 4.4

Update is out. @jair101: It turns out my copy had some fixes for special chars on tag management from some months back. They're included. Notes of caution on this update: Clubs: Club

Posted Images

my site has global open tag system in IPS settings.

In open tag system i want to be able to have some categories with drop down list of tag suggestions, which they can select a suggestion and also add anymore tags they like, is this possible? 

Edited by jp
Link to post
Share on other sites

i clicked on the rebuild cache button and it did it, but now when in the topic list it doesnt show the prefix or tags. when i click to go into the topic the prefix and tag are still there but when viewing the topic list it looks like none of the topics are tagged or have any prefixes. how do i fix?

And yes in settings i have it set to display tags and prefixes

Edited by jp
Link to post
Share on other sites
22 hours ago, jp said:

my site has global open tag system in IPS settings.

In open tag system i want to be able to have some categories with drop down list of tag suggestions, which they can select a suggestion and also add anymore tags they like, is this possible? 

I think it's all or nothing with predefined tags--so no.

20 hours ago, jp said:

i clicked on the rebuild cache button and it did it, but now when in the topic list it doesnt show the prefix or tags. when i click to go into the topic the prefix and tag are still there but when viewing the topic list it looks like none of the topics are tagged or have any prefixes. how do i fix?

And yes in settings i have it set to display tags and prefixes

It sounds like the tag cache didn't actually rebuild properly. What version of IPB and AT&P?

19 hours ago, Joel R said:

@Ryan H.

IPS 4.2.2 and Advanced Tags v3.1.9

Tags show up on topic view, but not the coloring

Coloring, tags? You mean prefixes? Screenshot?

Link to post
Share on other sites

i'm running IPS 4.2.2 and AT&P 3.19

yes it seems like rebuilding cache doesnt work properly. If i go into each topic individually and click on + sign to edit tags and then click save, then the prefix works in the topic list view.

but this isn't feasible to do for thousands of topics.

Link to post
Share on other sites
7 hours ago, jp said:

i'm running IPS 4.2.2 and AT&P 3.19

yes it seems like rebuilding cache doesnt work properly. If i go into each topic individually and click on + sign to edit tags and then click save, then the prefix works in the topic list view.

but this isn't feasible to do for thousands of topics.

Try rebuilding the cache again.  I think this solved the issue for me.

Link to post
Share on other sites
  • 2 weeks later...
2 hours ago, Unlucky said:

Updated to latest version of IPS today

I have created a new forum and tried to add prefixes to it but for some reason it is now only saving 1 prefix

Is this an issue with latest version of IPS?

Can you take a screenshot or two to show what you mean?

Link to post
Share on other sites

I think I found a bug.

If you have a forum, and you set some prefixes and default tags and others.

Then you change that forum's name and editing the tags & prefixes just doesn't work as it should. Instead of saving all prefixes added, it saves just the first one. And sometimes saving doesn't actually save.

Link to post
Share on other sites
28 minutes ago, David.. said:

I think I found a bug.

If you have a forum, and you set some prefixes and default tags and others.

Then you change that forum's name and editing the tags & prefixes just doesn't work as it should. Instead of saving all prefixes added, it saves just the first one. And sometimes saving doesn't actually save.

Unlucky just said the same thing.

I'll look into it.

Link to post
Share on other sites

37 pages to sift through, so apologies if this was submitted already.

When you're mass adding prefixes to forums, if a topic already has the tag that you're prefixing with, that topic will be skipped instead of promoting that tag to the prefix like you're probably wanting. :( 

Link to post
Share on other sites
21 minutes ago, ZackL said:

37 pages to sift through, so apologies if this was submitted already.

When you're mass adding prefixes to forums, if a topic already has the tag that you're prefixing with, that topic will be skipped instead of promoting that tag to the prefix like you're probably wanting. :( 

Sounds like a plausible issue. I'll look into it.

Link to post
Share on other sites
On 8/29/2017 at 3:12 PM, Unlucky said:

Hi,

Well I add 8 prefixes and click save but when i go back to edit forum only 1 is showing as saved

Therefore when i go to add a new topic - only 1 prefix is in the list of available prefixes

bit difficult to screenshot this one

Having the same issue now and I'm on IPS 4.3

Link to post
Share on other sites
On 9/2/2017 at 5:13 AM, Michel_72 said:

Hi Ryan,

Any progress on the "one prefix" bug?

I have many forums with multiple prefixes where the use of a prefix is mandentory and since the members can only select 1 prefix, I am getting manny Posts wih the wrong prefixes.

it's extremely timeconsuming to correct those afterwards.

Kind regards,

Michel

No progress. I can't provide any timeline at this point.

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy