Jump to content

Advanced Tags & Prefixes - IPS 4.x


Ryan H.

Recommended Posts

9 hours ago, ResPecT My Authoritah said:

Yo my man... I just asked the ips support why my articles where not saving in  column forum and i couldnt save the options.. and they said it was with your app.. and they said that your plugin had the same problem before .. and you fixed it.. well in the newest version of ips its messing up again.. can you update your app so it works again.

They're slightly mistaken, in that I never changed anything. My impression is it broke in one IPS update, and got fixed in another. If it's broken again, what IPS version are you running?

Link to comment
Share on other sites

I'm using IPS 4.1.16.1 and when make a tag with a space in the mass tagging tool, it's doing this:

 

Screenshot - 10_22_2016 , 12_37_49 PM.png

 

On the front end, the tags appear but don't all come up when searched. I made a few tags before I noticed, so now I have over a thousand pages of tags like this or blanks. Any idea what's going on here?

Link to comment
Share on other sites

24 minutes ago, Hezeber said:

I'm using IPS 4.1.16.1 and when make a tag with a space in the mass tagging tool, it's doing this:

 

Screenshot - 10_22_2016 , 12_37_49 PM.png

 

On the front end, the tags appear but don't all come up when searched. I made a few tags before I noticed, so now I have over a thousand pages of tags like this or blanks. Any idea what's going on here?

Looks like the tag is getting reencoded with each loop. space = %2B; % = %25. It shouldn't do that, but I'll have to look into why. Thanks for the report.

For what it's worth, your actual number is probably far less than 1000 pages. Most of those will be blank. IPS bug.

Link to comment
Share on other sites

On 10/22/2016 at 6:16 PM, Hezeber said:

No.

Didn't realize that until you asked. Similar to edit, they look like they delete when I push the button. When I run the search, they're still there.

Under Advanced Tools, there's a 'recache tags' tool. You may need to run that. There's also a separate 'rebuild search index' feature in core IPS that you could try running.

4 hours ago, Janyour said:

Hello,

Is this version compatible with the latest IPB version ? latest update is in july!

we purchased the version for IPS 3.x, should we purchase the 4v again ?

Yes, it is compatible with the latest IPB version. Applications don't have to be updated for every single release.

Yes, you will have to purchase separately for IPS 4.

Link to comment
Share on other sites

32 minutes ago, Ryan H. said:

Under Advanced Tools, there's a 'recache tags' tool. You may need to run that. There's also a separate 'rebuild search index' feature in core IPS that you could try running.

I already ran both of those tools since experiencing these problems and it still hasn't cleared up. :/

Link to comment
Share on other sites

  • 2 weeks later...

Hi @Ryan H.,

I wanted to bring to your attention that there's a problem between Advanced Tags & Prefixes and attempting to save the Articles template in IP.Pages database. 

I have an IP.Pages database named "db_frontpage".  In the database settings, I cannot save a new Articles template to change from "Category Articles" to "Category 2 Column Image Featured."  Everytime I save it, I get the "saved" confirmation and it takes me to the list of IP.Pages databases, but the page template doesn't actually change.  I've tried this twice.

Steps to Reproduce

  1. Navigate to ACP > Pages > Databases
  2. Click on "Edit" for Frontpage
  3. Within the Homepage Options grouping, change "Articles template" to "Category 2 Column Image Featured" 
  4. Click Save at the bottom.

 

And the helpful IPS staff response:

Quote

the issue is caused by the "Advanced Tags and Prefixes" application. Once you disable it, you'll see that you can save this form again :)

 

Link to comment
Share on other sites

On 11/3/2016 at 5:04 PM, Harrison Martes said:

How do I members use the prefix? They can put it, but it does not appear in the title of the post.

I'm sorry, I don't understand your issue. Could you provide screenshots? Can you try it with the default IPS theme? Does it work there?

On 11/4/2016 at 8:03 PM, Joel R said:

Hi @Ryan H.,

I wanted to bring to your attention that there's a problem between Advanced Tags & Prefixes and attempting to save the Articles template in IP.Pages database. 

I'm aware of the issue, it was first brought up some months ago, but I do not own Pages, and I have never been able to chase it down to actually find and fix it. Every person who brings it up either disappears or is on the cloud or apparently stops having the problem for unknown and unexplained reasons. Maybe you should be wary.

On 11/5/2016 at 6:43 AM, Jujuwar said:

I can confirm the bug reported by @Joel R

If needed, I can provide a test site with access

Yes, please. I'd appreciate ACP and S/FTP to an environment where you can reliably reproduce it. Please PM any creds via https://privnote.com/ .

Link to comment
Share on other sites

32 minutes ago, island55 said:

is there a smaller or separate version for specifically prefixes? my forum doesn't use tags since we're not a large forum but i could make use of the prefixes for server/forum/community feedback or support. thanks!

No, the app is all-inclusive. It could be some other dev is willing to make a more targeted plugin for that purpose.

Link to comment
Share on other sites

Not sure if anyone asked before, but have you considered integrating it with Rules App? Possible uses:

- automatic tagging/prefixing based on number of replies - similar to the HOT feature, but much more flexible

- automatic tagging/prefixing based on members taking part in the conversation. Lets say "elite topic" for topics where X participants are from Elite group.

- automatic tagging/prefixing based on number of people currently reading a topic. 

Etc. My examples might sound stupid, but I am just try to communicate the idea. Integration with Rules could be very powerful. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...