Jump to content

Advanced Tags & Prefixes - IPS 4.x


Ryan H.

Recommended Posts

7 hours ago, raza ali said:

you can see i have many perfixes but at forum only show 5 can you help me how to solve this issue please before 1 week its working well and all prefixes are show but now only 5 showing when i create new topic at forum

No, I can't see. What do you mean "forum only show 5"? Did you edit the forum settings?

7 hours ago, raza ali said:

http://prntscr.com/bciemb

why this box showing red

Because the forum is set to require a prefix, and you didn't pick one.

Link to comment
Share on other sites

Hey Ryan,

I have a question in terms of managing my community's tags: I notice that the same tag will be listed in the ACP > Manage  Tags for 2 different apps.  Does the app save tags independently for each app (eg. tag A for forums, tag A for gallery)?

Also, can you think about making the Tag list exportable?  Trying to manage my 48 pages of tags through the ACP is very difficult when I need to go back and forth to see what tags were created before, how they're named, etc.  

 

Link to comment
Share on other sites

3 hours ago, Joel R said:

Hey Ryan,

I have a question in terms of managing my community's tags: I notice that the same tag will be listed in the ACP > Manage  Tags for 2 different apps.  Does the app save tags independently for each app (eg. tag A for forums, tag A for gallery)?

No, they're all stored together, but IPS keeps track of where each instance belongs (it has to). I separate them out simply because that could conceivably be useful.

3 hours ago, Joel R said:

Also, can you think about making the Tag list exportable?  Trying to manage my 48 pages of tags through the ACP is very difficult when I need to go back and forth to see what tags were created before, how they're named, etc.

Will consider it, not sure how easy IPS would make that. But fair idea.

Link to comment
Share on other sites

1 hour ago, Ryan H. said:

No, they're all stored together, but IPS keeps track of where each instance belongs (it has to). I separate them out simply because that could conceivably be useful.

Okay.

I'm genuinely curious as to how you think listing one tag for multiple apps on the "Manage Tags" page would be useful, or if you've seen use cases?  From my personal use, I can investigate where the tag is used by clicking on Search which should reveal how and where it's used.  My main purpose when managing tags is to get an overarching perspective on duplicate / erroneous tags ... knowing in what app the tag is used isn't even on my priority list.  But I would be curious as to how other admins utilize the tag's app-usage.

1 hour ago, Ryan H. said:

Will consider it, not sure how easy IPS would make that. But fair idea.

Maybe an immediate workaround is when I edit a tag, I am taken back to the page with the tag (eg. Page 5), instead of starting from Page 1 again.  That, by itself, would be a huge pick-up in terms of admin efficiency.  

I have 48 pages of tags and you're killing me here @Ryan H. ;) 

 

 

Link to comment
Share on other sites

I'm trying to find a way to convert the old IPB Topic Descriptions into tags since that's basically what we used that for.  But if I ever do, I'll need to find a way to then change those into multiple tags from single tags since we didn't use commas.  I tested splitting a single tag into two tags in your "Manage Tags" tool by adding a comma but it didn't work.  Is there a way to add this functionality easily-ish?

Thank you! ^_^

Link to comment
Share on other sites

I am not sure if this has been mentioned before as I don't really have time to look back through this thread as I am at work. I was doing some debugging on my forums as I have been having issues with the "Pages" application. My issue was certain database settings were not saving when I saved them and after disabling and trying one application at a time I found that "Advanced Tags & Prefixes" is the application that is causing the problem.

More indepth with the issue I was having: I would create a database, select a custom key, and change how the database is displayed "categories or not etc" When I would save the database, it would use the old database key, and the display settings would not save, every time I tried to change the settings the outcome was the same. After disabling the prefix app, it works fine now.

I hope you are able to resolve this issue as I have plans to use this application but my databases working correctly is more important atm.

Link to comment
Share on other sites

On 6/6/2016 at 1:12 AM, Computer Candy said:

I'm trying to find a way to convert the old IPB Topic Descriptions into tags since that's basically what we used that for.  But if I ever do, I'll need to find a way to then change those into multiple tags from single tags since we didn't use commas.  I tested splitting a single tag into two tags in your "Manage Tags" tool by adding a comma but it didn't work.  Is there a way to add this functionality easily-ish?

Thank you! ^_^

I can look into that for a future release, but it's not currently a feature. It would probably be quite a bit more involved than it sounds.

On 6/6/2016 at 1:22 PM, RDxZen said:

I am not sure if this has been mentioned before as I don't really have time to look back through this thread as I am at work. I was doing some debugging on my forums as I have been having issues with the "Pages" application. My issue was certain database settings were not saving when I saved them and after disabling and trying one application at a time I found that "Advanced Tags & Prefixes" is the application that is causing the problem.

More indepth with the issue I was having: I would create a database, select a custom key, and change how the database is displayed "categories or not etc" When I would save the database, it would use the old database key, and the display settings would not save, every time I tried to change the settings the outcome was the same. After disabling the prefix app, it works fine now.

I hope you are able to resolve this issue as I have plans to use this application but my databases working correctly is more important atm.

Thanks for the rundown. A couple others have reported the same issue. I haven't solved it yet. Until I do, I recommend disabling AT&P temporarily while you need to edit your databases.

Link to comment
Share on other sites

On 6/7/2016 at 7:04 PM, Ryan H. said:

I can look into that for a future release, but it's not currently a feature. It would probably be quite a bit more involved than it sounds.

That would be amazing. It looks like I have found someone willing to help me get the old Topic Descriptions converted to Tags but it'll be a mess without an easy way to divide them into separate tags afterwards. Thank you!

In the mean time, can you think of any easy-ish alternative ways to accomplish this?

Edited by Computer Candy
Link to comment
Share on other sites

33 minutes ago, Computer Candy said:

That would be amazing. It looks like I have found someone willing to help me get the old Topic Descriptions converted to Tags but it'll be a mess without an easy way to divide them into separate tags afterwards. Thank you!

In the mean time, can you think of any easy-ish alternative ways to accomplish this?

Unless you can search for some common text in them with the mass-add tool, no.

Link to comment
Share on other sites

47 minutes ago, Ryan H. said:

Unless you can search for some common text in them with the mass-add tool, no.

Some tags we used with the old Topic Descriptions were pretty common, so many of the most common ones I could do that way. Can you use the mass-add tool with text searches of Topic Descriptions, though?

Link to comment
Share on other sites

1 hour ago, Computer Candy said:

Some tags we used with the old Topic Descriptions were pretty common, so many of the most common ones I could do that way. Can you use the mass-add tool with text searches of Topic Descriptions, though?

Topic descriptions aren't officially a thing anymore, so no.

Link to comment
Share on other sites

1 hour ago, Sull5 said:

Hi Ryan, 

When Advanced Tags & Prefixes is enabled you cannot change the database key on a pages database. 

Can we get a fix for this please ?

Thanks

Working on it. Others have brought it up too. For now, disable AT&P temporarily to make any Pages changes.

Link to comment
Share on other sites

18 hours ago, Pedro Ibáñez said:

Hi Ryan, I have and issue. Some prefixes are not showed in the tab when I want to apply to a topic... Please help!

Are the prefixes assigned to the forum you're posting in? Does your group have access to use them?

8 hours ago, Maniutek said:

Hello! And if you can have two prefixes? One who is such a topic, and the other templates moderation?

No, this app does not support multiple prefixes per topic.

Link to comment
Share on other sites

Hi,

Getting this error - can you please advise how to resolve it?

ErrorException: Division by zero (2)
#0 /usr/www/virtual/website.com/applications/advancedtagsprefixes/widgets/tagCloud.php(219): IPS\IPS::errorHandler(2, 'Division by zer...', '/usr/www/virtua...', 219, Array)
#1 /usr/www/virtual/ website.com /system/Widget/Widget.php(755): IPS\advancedtagsprefixes\widgets\_tagCloud->render()
#2 /usr/www/virtual/ website.com /system/Theme/Theme.php(718) : eval()'d code(13345): IPS\_Widget->__toString()
#3 [internal function]: IPS\Theme\class_core_front_global->widgetContainer('footer', 'horizontal')
#4 /usr/www/virtual/ website.com /system/Theme/SandboxedTemplate.php(57): call_user_func_array(Array, Array)
#5 /usr/www/virtual website.com /system/Theme/Theme.php(718) : eval()'d code(5134): IPS\Theme\_SandboxedTemplate->__call('widgetContainer', Array)
#6 /usr/www/virtual/ website.com /system/Theme/Theme.php(718) : eval()'d code(5134): IPS\Theme\SandboxedTemplate->widgetContainer('footer', 'horizontal')
#7 [internal function]: IPS\Theme\class_core_front_global->globalTemplate('ce241fdcd276bc3...', '\n\n\n<div class='...', Array)
#8 /usr/www/virtual/ website.com /system/Theme/SandboxedTemplate.php(57): call_user_func_array(Array, Array)
#9 /usr/www/virtual/ website.com /system/Dispatcher/Dispatcher.php(149): IPS\Theme\_SandboxedTemplate->__call('globalTemplate', Array)
#10 /usr/www/virtual/ website.com /system/Dispatcher/Dispatcher.php(149): IPS\Theme\SandboxedTemplate->globalTemplate('ce241fdcd276bc3...', '\n\n\n<div class='...', Array)
#11 /usr/www/virtual/ website.com /init.php(434) : eval()'d code(35): IPS\_Dispatcher->finish()
#12 /usr/www/virtual/ website.com /system/Dispatcher/Standard.php(101): IPS\easypopup_hook_showPopup->finish()
#13 /usr/www/virtual website.com /system/Dispatcher/Front.php(499): IPS\Dispatcher\_Standard->finish()
#14 /usr/www/virtual/ website.com /init.php(434) : eval()'d code(57): IPS\Dispatcher\_Front->finish()
#15 /usr/www/virtual/ website.com /system/Dispatcher/Dispatcher.php(131): IPS\Dispatcher\chat_hook_tabNewWindow->finish()
#16 /usr/www/virtual/ website.com /index.php(13): IPS\_Dispatcher->run()
#17 {main}

Link to comment
Share on other sites

When i move topics that have been tagged to another forum category, all of the tags of the topics that have been moved disappear. Is this supposed to happen or is it a bug?

If it is supposed to happen it should be fixed as it isn't a very good method. I have thousands of topics tagged and I want to move these into some different categories but now this means i can't.

I've made sure the category has the tags of the topics i am moving as well. 

need help please as i want to recategorise a large portion of my website urgently. thanks

Edited by jp
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...