Jump to content

Community

Ryan H.

Advanced Tags & Prefixes - IPS 4.x

Recommended Posts

13 minutes ago, Ryan H. said:

No. The app removes the open prefix option, you have to set each one up in the admin panel (Manage Prefixes) and then assign them to content containers (forums, etc.). Then you'll see those prefixes as a separate dropdown above the tag input. See the app screenshots and such.

Wow. Thanks! Awesome app :thumbsup:

Share this post


Link to post
Share on other sites
4 minutes ago, Oprime said:

work with Videobox?

If whatever that is already supports tags and prefixes, then it should. If not, no. It does not add tag/prefix support to any app that does not already have it.

Share this post


Link to post
Share on other sites

Hi ryan,

I have just bought this, but I'm having issues on my site.

 

i am trying to run a bulk task to add a prefix to all topics within a category, but i get:

 

A configuration or server error has occurred

EX2 Something went wrong. Please try again.

Share this post


Link to post
Share on other sites

1. also is there a user manual as I'm having trouble trying to work out how to use this.

2. do i need to create all the same tags in IPS ACP, as i have created in your prefix area?

3. if i add a prefix then click on it, it searches for all items with that tag but returns zero results even though there is a whole category full of topics that i assigned the same prefix. bug or am i not using it properly?

4. can i add tags in your system or do you only add them in ACP?

 

5. when i try to run the bulk prefix assignment tool, it ran and then said there was an issue. i looked and it only did about half the topics. after this then i get the error above EX2.

my site is cloud hosted with IPS,so the settings would be their settings.

6. how do you bulk remove prefixes from topics? ok i worked out that when your app adds prefixes they show up as tags in the Tags section of your app. so i can delete the tag from here and it deletes all of the prefixes.

Edited by jp

Share this post


Link to post
Share on other sites

Hi Ryan,

Thank you for such a great app!

I have a question related to searching. Since we run a product support forum, we change our prefixes frequently to indicate the status of a topic, such as Customer Review, Resolved, Tier 2 Review (for higher level staff). However, for example when Tier 2 staff want to check for topics marked with Tier 2 Review, and they click on the Tier 2 Review tag, all topics that are or were tagged with Tier 2 Review come back in the search (such as a topic now marked Resolved, but were Tier 2 Review prior). 

Is this something related to the Tags & Prefixes app that I (or you) can fix, to somehow remove the old tag/prefix data? Or is this related to how IP Board handles things?

Let me know if you need more info.

Share this post


Link to post
Share on other sites
On 11/29/2015, 6:09:33, jp said:

1. also is there a user manual as I'm having trouble trying to work out how to use this.

No, sorry. I try to keep everything intuitive and give description instructions otherwise. If you have any specific questions, ask away. The worst part is probably creating and assigning prefixes to forums (etc).

On 11/29/2015, 6:09:33, jp said:

2. do i need to create all the same tags in IPS ACP, as i have created in your prefix area?

I don't understand what you mean.

On 11/29/2015, 6:09:33, jp said:

3. if i add a prefix then click on it, it searches for all items with that tag but returns zero results even though there is a whole category full of topics that i assigned the same prefix. bug or am i not using it properly?

I can't tell from your description. There could be other search constraints (a particular app or forum) that is preventing it from returning other results. Or maybe it's an outdated cache/search index.

On 11/29/2015, 6:09:33, jp said:

4. can i add tags in your system or do you only add them in ACP?

Again, sorry, I don't understand the question.

On 11/29/2015, 6:09:33, jp said:

5. when i try to run the bulk prefix assignment tool, it ran and then said there was an issue. i looked and it only did about half the topics. after this then i get the error above EX2.

Please go in FTP to uploads/logs/ to find your error logs, download 2015_11_29.php, and PM it to me. That should tell me what the actual error is.

21 hours ago, PookyMacMan said:

Hi Ryan,

Thank you for such a great app!

I have a question related to searching. Since we run a product support forum, we change our prefixes frequently to indicate the status of a topic, such as Customer Review, Resolved, Tier 2 Review (for higher level staff). However, for example when Tier 2 staff want to check for topics marked with Tier 2 Review, and they click on the Tier 2 Review tag, all topics that are or were tagged with Tier 2 Review come back in the search (such as a topic now marked Resolved, but were Tier 2 Review prior). 

Is this something related to the Tags & Prefixes app that I (or you) can fix, to somehow remove the old tag/prefix data? Or is this related to how IP Board handles things?

Let me know if you need more info.

Do those results that don't have the prefix anymore still have it as a tag? IPB won't let you search for a prefix specifically, just a generic tag/prefix search. So any that don't have it as a prefix probably still have it as a tag. Depending on how you changed the prefix, if they are still there as tags, that may or may not be a bug. Otherwise, if no tags, could be an outdated tag cache--try recaching from this app's tools.

Share this post


Link to post
Share on other sites

1. ok

2. so i have a forum category called Forum Help. I want to instead just 'tag' or 'prefix' these posts as 'help' and put put them in a large category with other posts. So i have created the prefix 'help' in AdminCP > Community > Advanced Tags > Prefixes. My question is do i need to also create the tag 'help' in AdminCP > System > Posting > Tags?

3. So i created a prefix 'help' as above. I see the forum posts now have a prefix called 'help' in front of the title. If i click on this prefix i get taken to a search page that shows 0 results. When i know there is definitely 4 posts with that prefix. If i go to AdminCP > Community > Advanced Tags > Manage Tags I can see the tag 'help' and it says 4 uses. So why don't these show in the frontend when someone searches by the prefix? ------ further testing reveals that it works for newly created prefixes, but not on existing topics that i have bulk assigned prefixes too.

4. So you have an area in AdminCP > Community > Advanced Tags > Tags. This seems to show the IPS tags created in AdminCP > System > Posting > Tags. So my question is is that the only place where tags can be created? i.e your system just leverages the in built tag system.

5. i have checked the logs and don't see any issues in there relating to Advanced Tags. I have noticed this error when trying to view banned members in AdminCP as well so i have logged a support ticket with IPS. maybe its related. if not i will get back in touch  ok I don't think this tag problem was related, as the member issue was fixed by the patch below and the tag issue still persists. 

 

5a. When i try to do a bulk tag or prefix of an existing category, it does the first 50 it seems then fails and displays error: 'Invalid request, please try again later, but better'

So a category called 'Pets' has 80 topics and 1005 posts. I click to add a tag 'pets' to each of these topics/posts. It runs the first pass of 50 then fails, no topics end up getting tagged though.

7. i have added a tag called 'Forum Help' in AdminCP > System > Posting > Tags. Now when i try to create a topic on the fronted and choose the tag from the dropdown, and then click submit it doesnt save the tag to the topic. is this your app conflicting with the IPS core? or is it a bug with IPS Core?

Ok so my main goal of using your app is to merge several categories into one. So if i have separate categories called Fish, Dogs, Cats, Birds and now only want one category called Animals, and in here move all the topics from Fish, Dogs, Cats, Birds. So I want to 'tag' or 'prefix' (not sure which is the best method) all the respective topics (so all Fish topics get a 'fish' tag or prefix) so that a user can view all the topics from all 4 categories in one go, but drill down to just 'fish' topics if they click on the tag or prefix. Does that make sense?

8. What would be the best way to do this? do i add tags or prefixes?.... ok I'm thinking of leaning towards tags.

9. If i have 100 categories currently and want to merge these down to be only 10 categories that means i would need around 90 tags. is there a way so that when a user creates a new topic they don't have to choose from 90 different tags, but instead limit it so that only the certain tags for each category.... ok i think i found out how to do this in each forum category. 

Edited by jp
updated text

Share this post


Link to post
Share on other sites
On 12/1/2015, 8:11:11, jp said:

2. so i have a forum category called Forum Help. I want to instead just 'tag' or 'prefix' these posts as 'help' and put put them in a large category with other posts. So i have created the prefix 'help' in AdminCP > Community > Advanced Tags > Prefixes. My question is do i need to also create the tag 'help' in AdminCP > System > Posting > Tags?

No. All you need is to create the prefix, and enable it for that forum (edit forum, Tags & Prefixes tab).

On 12/1/2015, 8:11:11, jp said:

3. So i created a prefix 'help' as above. I see the forum posts now have a prefix called 'help' in front of the title. If i click on this prefix i get taken to a search page that shows 0 results. When i know there is definitely 4 posts with that prefix. If i go to AdminCP > Community > Advanced Tags > Manage Tags I can see the tag 'help' and it says 4 uses. So why don't these show in the frontend when someone searches by the prefix? ------ further testing reveals that it works for newly created prefixes, but not on existing topics that i have bulk assigned prefixes too.

I don't know why that would be. Try rebuilding the tag cache, under tools.

On 12/1/2015, 8:11:11, jp said:

4. So you have an area in AdminCP > Community > Advanced Tags > Tags. This seems to show the IPS tags created in AdminCP > System > Posting > Tags. So my question is is that the only place where tags can be created? i.e your system just leverages the in built tag system.

My system leverages the built-in tag system, yes. But there's more to it than that. The Tags page you were looking at shows all uses of tags and prefixes across the entire nsuite, and lets you edit or delete those in bulk. You don't create tags on that page. You can also allow open tags (users can set their own), in which case those tags will not be under the Posting > Tags settings, but their usage will be shown on my Tags page. Hope that makes sense.

On 12/1/2015, 8:11:11, jp said:

5. i have checked the logs and don't see any issues in there relating to Advanced Tags. I have noticed this error when trying to view banned members in AdminCP as well so i have logged a support ticket with IPS. maybe its related. if not i will get back in touch  ok I don't think this tag problem was related, as the member issue was fixed by the patch below and the tag issue still persists.

Okay, well, I need a log of it so I have something to go by. Try this: Make the error happen, then go to that uploads/logs folder and find the most recently modified file(s). Please send those to me.

On 12/1/2015, 8:11:11, jp said:

7. i have added a tag called 'Forum Help' in AdminCP > System > Posting > Tags. Now when i try to create a topic on the fronted and choose the tag from the dropdown, and then click submit it doesnt save the tag to the topic. is this your app conflicting with the IPS core? or is it a bug with IPS Core?

I haven't seen such an issue. Nothing should prevent you from applying tags to a topic. If you can send me forum details to investigate, though, I'll see what I can figure out.

On 12/1/2015, 8:11:11, jp said:

Ok so my main goal of using your app is to merge several categories into one. So if i have separate categories called Fish, Dogs, Cats, Birds and now only want one category called Animals, and in here move all the topics from Fish, Dogs, Cats, Birds. So I want to 'tag' or 'prefix' (not sure which is the best method) all the respective topics (so all Fish topics get a 'fish' tag or prefix) so that a user can view all the topics from all 4 categories in one go, but drill down to just 'fish' topics if they click on the tag or prefix. Does that make sense?

8. What would be the best way to do this? do i add tags or prefixes?.... ok I'm thinking of leaning towards tags.

Prefixes would seem most appropriate--that would make it show up before/in the title everywhere, whereas tags don't always display. I would create those four prefixes, use the bulk add tool (not working for you, I know; I need more info) or a saved action to apply those prefixes to all topics in their respective forums, then move them all into your new unified forum. Then set up the new forum so that all four prefixes are active, and users are required to select one.

On 12/1/2015, 8:11:11, jp said:

9. If i have 100 categories currently and want to merge these down to be only 10 categories that means i would need around 90 tags. is there a way so that when a user creates a new topic they don't have to choose from 90 different tags, but instead limit it so that only the certain tags for each category.... ok i think i found out how to do this in each forum category. 

Yes. Each forum has its own setting for allowed tags and prefixes. Sounds like you found that though,

Share this post


Link to post
Share on other sites
On 3 December 2015 at 12:46:34 PM, Ryan H. said:

Prefixes would seem most appropriate--that would make it show up before/in the title everywhere, whereas tags don't always display. I would create those four prefixes, use the bulk add tool (not working for you, I know; I need more info) or a saved action to apply those prefixes to all topics in their respective forums, then move them all into your new unified forum. Then set up the new forum so that all four prefixes are active, and users are required to select one.

I think i will decide to use tags instead. Having a prefix to thousands of topics is a bit heavy on the eyes

 

 

 

Share this post


Link to post
Share on other sites
On 12/10/2015 at 7:16 PM, nook86 said:

hello, any chances to do in a template like on images:

http://www.mediafire.com/view/cg5p3vxpatbeqdg/scrn-5668c3bd.png

http://www.mediafire.com/view/x30h8o86syws2j4/scrn-5668c3ed.png

so i would like to put prefixes also to forums descriptions ? any chances to do it in template? would be awesome...

That's not currently a feature. It could probably be done with some customization, but I can't help you with that.

2 hours ago, openfire said:

Hi Ryan, quick question... Does this work with Pages?

Unless Pages supports tags/prefixes out of box (which I don't think it does), no. This app enhances tag/prefix functionality, it doesn't add them anywhere they weren't already.

Share this post


Link to post
Share on other sites
13 hours ago, Ryan H. said:

Unless Pages supports tags/prefixes out of box (which I don't think it does), no. This app enhances tag/prefix functionality, it doesn't add them anywhere they weren't already.

Pages -> Edit Database-> Options:

tags.jpg.bdb346249684c1349a7e09bfecc1f6e

Share this post


Link to post
Share on other sites
1 hour ago, PrettyPixels said:

I'd love to see the option for members to follow tags. They would receive an alert (or email) when new content for certain tags is posted.

Would you consider including this in a future version?

Just a suggestion. Make an Activity Stream of the actual Tag - and use RSS to feed it by email. Should be possible....

Share this post


Link to post
Share on other sites
29 minutes ago, nook86 said:

hello, 

any chances to display prefixes below forums like here 

http://www.mediafire.com/view/cg5p3vxpatbeqdg/scrn-5668c3bd.png 

http://www.mediafire.com/view/x30h8o86syws2j4/scrn-5668c3ed.png

what code to put in template ?:) i just need to display they same thing but in forum description area

->

On 12/12/2015 at 2:45 PM, Ryan H. said:

That's not currently a feature. It could probably be done with some customization, but I can't help you with that.

 

Share this post


Link to post
Share on other sites

http://www.terrarium.pl/forum/142-warany/ but here is a chance when i click on random prefix to add to for example

http://www.terrarium.pl/tags/forums/%C5%BCywienie/

http://www.terrarium.pl/tags/forums/%C5%BCywienie/?search_app_filters[forums][forums][]=142

so you know just to show prefixed topics from that forum ? [btw if i turned off special chars in urls, prefixes should also respect that:P ]

Edited by nook86

Share this post


Link to post
Share on other sites
4 hours ago, nook86 said:

http://www.terrarium.pl/forum/142-warany/ but here is a chance when i click on random prefix to add to for example

http://www.terrarium.pl/tags/forums/%C5%BCywienie/

http://www.terrarium.pl/tags/forums/%C5%BCywienie/?search_app_filters[forums][forums][]=142

so you know just to show prefixed topics from that forum ? [btw if i turned off special chars in urls, prefixes should also respect that:P ]

I have no idea what you're asking. And I've already explained that the forum description prefix list is not a current feature. Really, I heard your request the first three times. I get it.

Respecting the special char in URL setting for tags/prefixes is not possible on account of what it's doing. That's like asking for user search queries to respect it too. The only way IPB knows what tag you're talking about is by that text, and if the text doesn't match the tag anymore...you're not going to get any results.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

√ó
√ó
  • Create New...