Jump to content

Delete My Account


Adriano Faria

Recommended Posts

  • 1 month later...
  • 3 weeks later...
  • 2 months later...
  • 1 month later...
On 17.6.2015 at 8:59 PM, Police Community said:

Hi @Adriano Faria 

I like the idea of this plugin but rather than Delete My Account I would love to see the option to Close my account, this would effectively leave all posts and content attributed to a particular member so it would not show as Guest

This would be very nice if the contents would still be linked to this certain member. You could do that by generating a new account with the membername plus a given Suffix and transferring all content to that new Account. Therefore all account data would be gone and all content would be preserved and still linked to one certain member.

Example: "mike" would be "mike_deleted" after deletion of the original account.

 

Right now, all content of deleted members merge up in the guest account, which is not very nice.

 

And i got a bug:

After requesting a deletion, the Info boxes end up empty all the time:

Unbenannt.PNG

 

Link to comment
Share on other sites

21 minutes ago, MaNiAc LRSC said:

Right now, all content of deleted members merge up in the guest account, which is not very nice.

The account deletion itself is handled by the framework and has exactly the same behaviour when you delete an account on ACP. I won't change that.

23 minutes ago, MaNiAc LRSC said:

And i got a bug:

After requesting a deletion, the Info boxes end up empty all the time:

I will retest it.

Link to comment
Share on other sites

4 hours ago, Adam_S said:

I'm also getting a bug.  When a user requests to delete their account, this error is being displayed to the user.  The request still proceeds to the admins, but the user is seeing this message.  Can you advise?

2016-07-11 15_59_30-A configuration or server error has occurred.jpg

This error (EX0) should never happen. What is the content for this log ?

Link to comment
Share on other sites

5 hours ago, Adam_S said:

I'm also getting a bug.  When a user requests to delete their account, this error is being displayed to the user.  The request still proceeds to the admins, but the user is seeing this message.  Can you advise?

2016-07-11 15_59_30-A configuration or server error has occurred.jpg

Just tested and works fine for me: http://www.screencast.com/t/SXlhYcDQx7o9

I have a new version to release which fix the issue on template reported by @MaNiAc LRSC and will also add a new button on ModCP: Cancel All Requests; so I'm waiting for your reply to go on.

Link to comment
Share on other sites

13 hours ago, Adriano Faria said:

This error (EX0) should never happen. What is the content for this log ?

Hi @Adriano Faria

This happens immediately after the user clicks on Save once they have ticked the tickbox saying they understand about the account deletion.  

Here is the extract from the System logs (I think thats what you are asking for?):

UnderflowException:  (0)
#0 /home4/hrmnycom/public_html/omorashi.online/system/Email/Email.php(619): IPS\Db\_Select->first()
#1 /home4/hrmnycom/public_html/omorashi.online/system/Email/Email.php(263): IPS\_Email::template('core', 'notification_de...', 'html', Array)
#2 /home4/hrmnycom/public_html/omorashi.online/system/Email/Outgoing/SparkPost.php(250): IPS\_Email->compileContent('html', false, Object(IPS\Lang))
#3 /home4/hrmnycom/public_html/omorashi.online/system/Notification/Notification.php(484): IPS\Email\Outgoing\_SparkPost->mergeAndSend(Array, NULL, NULL, Array, Object(IPS\Lang))
#4 /home4/hrmnycom/public_html/omorashi.online/system/Notification/Notification.php(465): IPS\_Notification->sendEmails(Array, Array)
#5 /home4/hrmnycom/public_html/omorashi.online/init.php(434) : eval()'d code(50): IPS\_Notification->send()
#6 [internal function]: IPS\core\modules\front\system\hook449->_deletemyaccount()
#7 /home4/hrmnycom/public_html/omorashi.online/applications/core/modules/front/system/settings.php(55): call_user_func(Array)
#8 /home4/hrmnycom/public_html/omorashi.online/system/Dispatcher/Controller.php(96): IPS\core\modules\front\system\_settings->manage()
#9 /home4/hrmnycom/public_html/omorashi.online/applications/core/modules/front/system/settings.php(35): IPS\Dispatcher\_Controller->execute()
#10 /home4/hrmnycom/public_html/omorashi.online/system/Dispatcher/Dispatcher.php(129): IPS\core\modules\front\system\_settings->execute()
#11 /home4/hrmnycom/public_html/omorashi.online/index.php(13): IPS\_Dispatcher->run()
#12 {main}

 

BACKTRACE:

#0 /home4/hrmnycom/public_html/omorashi.online/init.php(498): IPS\_Log::log('UnderflowExcept...', 'uncaught_except...')
#1 [internal function]: IPS\IPS::exceptionHandler(Object(UnderflowException))
#2 {main}

 

Link to comment
Share on other sites

 

On 04/07/2016 at 4:13 PM, Adam_S said:

@Adriano Faria can I make two suggestions?

1) Perhaps the option where admins can enforce a reason, rather than it just being optional

2) An option where it transfers all the users' content across to another dummy account (one that we create ourselves) so it doesn't show up as a guest that posted the content

 

Can i also make another suggestion.  Would it be possible to have it so it triggers a rule in Automation Rules? 

This would allow me to perform some additional actions, such as automate the account deletion after x days, and send an email to the user indicating that they have requested to delete the account but they have x days to cancel it, etc, etc. 

 

Link to comment
Share on other sites

  • 2 weeks later...
7 hours ago, Luis Barragan said:

Just purchased but doesn't seem to work on the latest version. Shows a white box.

Screen Shot 2016-07-21 at 7.44.57 PM.png

I've the same problem after translating strings, nothing appears now. And i'ts impossible to translate live this plugin (not working).

Area appears with content for 1 second and disappear, plugin disabled until fixed.

Thanks you for your work !

Edited by JiigSaaw
Link to comment
Share on other sites

On 11/07/2016 at 9:19 PM, Adam_S said:

This happens immediately after the user clicks on Save once they have ticked the tickbox saying they understand about the account deletion.

I will need to invistigate this with you (version of IPS4, PHP, MySql, etc.). It is working fine on my tests and with others, I guess, as I don't any other complain in this matter. I'll send you a PM.

8 hours ago, Luis Barragan said:

Just purchased but doesn't seem to work on the latest version. Shows a white box.

 

1 hour ago, JiigSaaw said:

Area appears with content for 1 second and disappear, plugin disabled until fixed.

Template issue fixed on 2.0.3: http://www.screencast.com/t/omLnJgCH. Plugin was working fine... the issue happened after submit the form, at least on my install.

1 hour ago, JiigSaaw said:

And i'ts impossible to translate live this plugin (not working).

I can reproduce it and I have absolutelly no idea why. This plugins uses the language system as any another plugin out there. I'll take a look with IPS devs and will update the file when it's done.

Link to comment
Share on other sites

On 7/12/2016 at 1:19 AM, Adam_S said:

Hi @Adriano Faria

This happens immediately after the user clicks on Save once they have ticked the tickbox saying they understand about the account deletion.  

Here is the extract from the System logs (I think thats what you are asking for?):

UnderflowException:  (0)
#0 /home4/hrmnycom/public_html/omorashi.online/system/Email/Email.php(619): IPS\Db\_Select->first()
#1 /home4/hrmnycom/public_html/omorashi.online/system/Email/Email.php(263): IPS\_Email::template('core', 'notification_de...', 'html', Array)
#2 /home4/hrmnycom/public_html/omorashi.online/system/Email/Outgoing/SparkPost.php(250): IPS\_Email->compileContent('html', false, Object(IPS\Lang))
#3 /home4/hrmnycom/public_html/omorashi.online/system/Notification/Notification.php(484): IPS\Email\Outgoing\_SparkPost->mergeAndSend(Array, NULL, NULL, Array, Object(IPS\Lang))
#4 /home4/hrmnycom/public_html/omorashi.online/system/Notification/Notification.php(465): IPS\_Notification->sendEmails(Array, Array)
#5 /home4/hrmnycom/public_html/omorashi.online/init.php(434) : eval()'d code(50): IPS\_Notification->send()
#6 [internal function]: IPS\core\modules\front\system\hook449->_deletemyaccount()
#7 /home4/hrmnycom/public_html/omorashi.online/applications/core/modules/front/system/settings.php(55): call_user_func(Array)
#8 /home4/hrmnycom/public_html/omorashi.online/system/Dispatcher/Controller.php(96): IPS\core\modules\front\system\_settings->manage()
#9 /home4/hrmnycom/public_html/omorashi.online/applications/core/modules/front/system/settings.php(35): IPS\Dispatcher\_Controller->execute()
#10 /home4/hrmnycom/public_html/omorashi.online/system/Dispatcher/Dispatcher.php(129): IPS\core\modules\front\system\_settings->execute()
#11 /home4/hrmnycom/public_html/omorashi.online/index.php(13): IPS\_Dispatcher->run()
#12 {main}

 

BACKTRACE:

#0 /home4/hrmnycom/public_html/omorashi.online/init.php(498): IPS\_Log::log('UnderflowExcept...', 'uncaught_except...')
#1 [internal function]: IPS\IPS::exceptionHandler(Object(UnderflowException))
#2 {main}

 

We are getting the same error after a user makes the request.  We turned off 'email' in the notification options and the error went away so it's an email..perhaps Sparkpost related issue.  We did have Sparkpost issues with the early IPS API option but these all seem fixed now and we don't have any other site issues with email, just this plugin.

Edited by Gravi5tar
Link to comment
Share on other sites

On 11/07/2016 at 9:19 PM, Adam_S said:

Hi @Adriano Faria

This happens immediately after the user clicks on Save once they have ticked the tickbox saying they understand about the account deletion.  

Here is the extract from the System logs (I think thats what you are asking for?):

UnderflowException:  (0)
#0 /home4/hrmnycom/public_html/omorashi.online/system/Email/Email.php(619): IPS\Db\_Select->first()
#1 /home4/hrmnycom/public_html/omorashi.online/system/Email/Email.php(263): IPS\_Email::template('core', 'notification_de...', 'html', Array)
#2 /home4/hrmnycom/public_html/omorashi.online/system/Email/Outgoing/SparkPost.php(250): IPS\_Email->compileContent('html', false, Object(IPS\Lang))
#3 /home4/hrmnycom/public_html/omorashi.online/system/Notification/Notification.php(484): IPS\Email\Outgoing\_SparkPost->mergeAndSend(Array, NULL, NULL, Array, Object(IPS\Lang))
#4 /home4/hrmnycom/public_html/omorashi.online/system/Notification/Notification.php(465): IPS\_Notification->sendEmails(Array, Array)
#5 /home4/hrmnycom/public_html/omorashi.online/init.php(434) : eval()'d code(50): IPS\_Notification->send()
#6 [internal function]: IPS\core\modules\front\system\hook449->_deletemyaccount()
#7 /home4/hrmnycom/public_html/omorashi.online/applications/core/modules/front/system/settings.php(55): call_user_func(Array)
#8 /home4/hrmnycom/public_html/omorashi.online/system/Dispatcher/Controller.php(96): IPS\core\modules\front\system\_settings->manage()
#9 /home4/hrmnycom/public_html/omorashi.online/applications/core/modules/front/system/settings.php(35): IPS\Dispatcher\_Controller->execute()
#10 /home4/hrmnycom/public_html/omorashi.online/system/Dispatcher/Dispatcher.php(129): IPS\core\modules\front\system\_settings->execute()
#11 /home4/hrmnycom/public_html/omorashi.online/index.php(13): IPS\_Dispatcher->run()
#12 {main}

 

BACKTRACE:

#0 /home4/hrmnycom/public_html/omorashi.online/init.php(498): IPS\_Log::log('UnderflowExcept...', 'uncaught_except...')
#1 [internal function]: IPS\IPS::exceptionHandler(Object(UnderflowException))
#2 {main}

 

 

Just now, Gravi5tar said:

We are getting the same error after a user makes the request.  We turned off 'email' in the notification options and the error went away so it's an email..perhaps Sparkpost related issue.  We did have Sparkpost issues with the early IPS API option but these all seem fixed now and we don't have any other site eissues with email, just this plugin.

The error is about missing email template. It's funny, because it works for some.

This plugin will have to be converted to an app. :(

I will need some days to make it. I think a week is fine.

 

Link to comment
Share on other sites

On 22/07/2016 at 9:26 PM, Adriano Faria said:

I will need to invistigate this with you (version of IPS4, PHP, MySql, etc.). It is working fine on my tests and with others, I guess, as I don't any other complain in this matter. I'll send you a PM.

 

Template issue fixed on 2.0.3: http://www.screencast.com/t/omLnJgCH. Plugin was working fine... the issue happened after submit the form, at least on my install.

I can reproduce it and I have absolutelly no idea why. This plugins uses the language system as any another plugin out there. I'll take a look with IPS devs and will update the file when it's done.

Ok, thanks Adriano.  Appreciate your hard work.  Will we need to purchase it again if you convert it to an app?

 

In the mean time, i'll disable email notification for the extension after @Gravi5tar was able to identify the issue

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...