Jump to content

FAQ System (IPS v4)


HeadStand

Recommended Posts

9 hours ago, Phil7789 said:

Another problem I stumbled across is the breadcrumb navigation: When you click on a question to open it (not the anchor in the list which scrolls the site down to question itself) the name of the question is doubled (Questionname -> Questionname). The first of the two names is then set some pixels down so its basically under the actual breadcrum navigation.

I noticed some breadcrumb issues a little while back and mentioned it to her - she's very conscientious so I'm sure she'll deal with it soon.

 

9 hours ago, Phil7789 said:

Edit: Just remembered that the questions opened as a popup in the old version, so the above behaviour is not wanted or are there no popups anymore?

I asked her this as well - you need to add the questions into a widget in order for them to present as popups.  Apparently there were a lot of votes to remove popups from full-page FAQ pages.

Hope this helps!

Link to comment
Share on other sites

A new version has been uploaded to the Marketplace. Changes include:

  • Bread Crumbs were duplicated on the question page. Fixed.
  • HTML in the title/description broke some meta tags. Fixed.
  • Search-related language strings were missing. Fixed.
  • Search Index is automatically rebuilt on upgrade (previous version did not index existing questions, causing them to be omitted from search).
  • New setting in the ACP (under Community -> FAQ -> Settings) to determine whether answers should show in a popup or as a separate page.

Thanks @Phil7789 and @liquidfractal for pointing out these issues.

Link to comment
Share on other sites

On 23/10/2017 at 2:22 PM, HeadStand said:

A new version has been uploaded to the Marketplace. Changes include:

  • Bread Crumbs were duplicated on the question page. Fixed.
  • HTML in the title/description broke some meta tags. Fixed.
  • Search-related language strings were missing. Fixed.
  • Search Index is automatically rebuilt on upgrade (previous version did not index existing questions, causing them to be omitted from search).
  • New setting in the ACP (under Community -> FAQ -> Settings) to determine whether answers should show in a popup or as a separate page.

Thanks @Phil7789 and @liquidfractal for pointing out these issues.

Ignore the PM I sent last week as well as my post, then. Because this is exactly what I brought up as well.

But er, thanks for the patch, Headstand. It seems to be working perfectly again. :) 

Edited by Tripp★
Link to comment
Share on other sites

Thinking about the idea of a FAQ system, it occurs to me that it would be nice to be able to create sub-questions within a FAQ question for questions related to the main question, but which for one reason or another don't merit a separate FAQ entry.  Basically, the ability to create multiple grey-heading questions (as per the above screenshot) within one FAQ question.  This might also finesse what can be a somewhat repetitive structure where you have the question in large font at the top of the FAQ window, followed by a repetition of the same question in the grey field.

Link to comment
Share on other sites

  • 3 weeks later...

Re: the searchability of FAQ questions:

This might be reaching, but I was wondering if there was a way to redirect search results to the actual page in which the FAQ group for that question is included?

I ask because if, for example, you visit my site as a guest, enter a search term that shows up in the FAQs then click that FAQ result, you're taken to the full-page FAQ listing which a) doesn't have lightbox windows, and b) doesn't have the other information which might be on a page associated with that FAQ.  It doesn't look nearly as appealing as the default FAQ page which has the FAQ widget/s.  But I'm not sure if anything can be done about this.

What's more, the searchability of FAQ questions seems to bypass FAQ question permissions: I made a collection Admin-only, but when I visit my site as a Guest and search for a relevant keyword I can get to the questions.

Ideally, there could be a way to toggle this searchability on/off...?

Edited by liquidfractal
Link to comment
Share on other sites

  • 4 months later...

Hi, got a strange bug after the upgrade to 4.2.8 recently (also upgraded FAQ to the latest version)

in the profile user have the broken link

image.thumb.png.fff1e85b2702448fe352bc990a6c249b.png

and if I click it

Sorry, there is a problem

Something went wrong. Please try again.

Error code: EX1064

SELECT COUNT(*) as cnt FROM `ibf_faq_questions` AS `faq_questions` WHERE faq_questions.=37805 AND faq_questions.approved < 2 AND faq_questions.approved!=-2
IPS\Db\Exception: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '=? AND faq_questions.approved < 2 AND faq_questions.approved!=-2' at line 1 (1064)
#0 /home/landcruiser/html/system/Db/Select.php(378): IPS\_Db->preparedQuery('/*IPS\\Content\\_...', Array, true)
#1 /home/landcruiser/html/system/Db/Select.php(440): IPS\Db\_Select->runQuery()
#2 /home/landcruiser/html/system/Db/Select.php(361): IPS\Db\_Select->rewind()
#3 /home/landcruiser/html/system/Content/Item.php(2585): IPS\Db\_Select->first()
#4 /home/landcruiser/html/system/Helpers/Table/Content.php(283): IPS\Content\_Item::getItemsWithPermission(Array, ' desc', NULL, 'read', false, 0, NULL, false, false, false, true, Array, false, true, true, true, false)
#5 /home/landcruiser/html/system/Helpers/Table/Table.php(480): IPS\Helpers\Table\_Content->getRows(Array)
#6 /home/landcruiser/html/applications/core/modules/front/members/profile.php(581): IPS\Helpers\Table\_Table->__toString()
#7 /home/landcruiser/html/system/Dispatcher/Controller.php(85): IPS\core\modules\front\members\_profile->content()
#8 /home/landcruiser/html/applications/core/modules/front/members/profile.php(64): IPS\Dispatcher\_Controller->execute()
#9 /home/landcruiser/html/system/Dispatcher/Dispatcher.php(146): IPS\core\modules\front\members\_profile->execute()
#10 /home/landcruiser/html/index.php(12): IPS\_Dispatcher->run()
#11 {main}

 

Link to comment
Share on other sites

  • 3 weeks later...

Can someone advise what the permissions that are available for this?

I purchased the other FAQ system and found that I as Admin has to add all the Q&A's into it in the ACP however I has a user on my site who will be looking after all the FAQ's and Support so I just want to given him permissions to manage it...thanks

Link to comment
Share on other sites

9 hours ago, ibaker said:

Can someone advise what the permissions that are available for this?

I purchased the other FAQ system and found that I as Admin has to add all the Q&A's into it in the ACP however I has a user on my site who will be looking after all the FAQ's and Support so I just want to given him permissions to manage it...thanks

Users (with permission) can add questions on the public side as well.

Link to comment
Share on other sites

  • 5 weeks later...
On 6/7/2018 at 10:01 AM, micronx said:

1º ok, thanks 

2º the collections are  drag and drop, but not the questions

The questions are sortable within a collection. The questions on their own are never displayed; they're always listed grouped by collection. Therefore, it makes sense to have the sequencing be done within the collection and not as a whole.

Question 1 may be in position 1 for Collection 1, but might be in position 5 for Collection 2.

image.thumb.png.ccc9328f81645201739b35d283edd839.png

In the ACP, go to Community -> FAQ -> Manage Collections. Choose "Collection Questions" from the dropdown menu on the right. You'll see that you can rearrange the questions here by using the draghandles on the left.

Link to comment
Share on other sites

23 hours ago, HeadStand said:

The questions are sortable within a collection. The questions on their own are never displayed; they're always listed grouped by collection. Therefore, it makes sense to have the sequencing be done within the collection and not as a whole.

Question 1 may be in position 1 for Collection 1, but might be in position 5 for Collection 2.

image.thumb.png.ccc9328f81645201739b35d283edd839.png

In the ACP, go to Community -> FAQ -> Manage Collections. Choose "Collection Questions" from the dropdown menu on the right. You'll see that you can rearrange the questions here by using the draghandles on the left.

Thanks, i didn't see that.

 

1º - In the FAQ system homepage, can you add a option to put the  "list all available Collections" as widget sidebar ?

about this any news ??

Link to comment
Share on other sites

  • 1 month later...

We are very interested in buying this one. Just a simple question. From what i understand after reading liquidfractal's comment, there is an option to limit the visibility of questions &/or collections using IPS permissioning. Is this correct? Our members are divided into 3 main groups and we would like each group to have their own Questions not visible by the other groups.

On this note, does the issue reported by liquidfractal still exist?

On 11/13/2017 at 2:25 AM, liquidfractal said:

What's more, the searchability of FAQ questions seems to bypass FAQ question permissions: I made a collection Admin-only, but when I visit my site as a Guest and search for a relevant keyword I can get to the questions.

 

Link to comment
Share on other sites

A new version has been uploaded to the Marketplace. Changes include:

  • New widget to display a list of available collections
  • Question permissions were not being updated in the search after a question was assigned to a collection. Fixed.
8 hours ago, GNet said:

We are very interested in buying this one. Just a simple question. From what i understand after reading liquidfractal's comment, there is an option to limit the visibility of questions &/or collections using IPS permissioning. Is this correct? Our members are divided into 3 main groups and we would like each group to have their own Questions not visible by the other groups.

That's correct.

8 hours ago, GNet said:

 On this note, does the issue reported by liquidfractal still exist?

On 11/12/2017 at 7:25 PM, liquidfractal said:

I honestly don't even remember seeing that issue. I've fixed it just now.

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...