Jump to content

Messages Support


Michael.J
 Share

Recommended Posts

  • 3 weeks later...

@Mike John

There is a bug - on the field "Days Joined" within a message settings. The value for this field is defaulted to 5, if I enter 0 to disable this filed it does disable it however if I go back into that message and edit the text the message disappears, that is because when I check the message settings it has defaulted back to 5 again. If I change this value to 20 and save it applies that change and displays correctly but on re-editing the message in the future, the field value has again defaulted back to 5 so that is what is saved if you forget each time to go in and change it. Its not pulling the value from the database on edit despite the correct value being saved, it is defaulting to 5.

 

Also @Mike John What is the difference between "Normal Block" and "Info Message" please?

Link to comment
Share on other sites

@Mike John

There is a bug - on the field "Days Joined" within a message settings. The value for this field is defaulted to 5, if I enter 0 to disable this filed it does disable it however if I go back into that message and edit the text the message disappears, that is because when I check the message settings it has defaulted back to 5 again. If I change this value to 20 and save it applies that change and displays correctly but on re-editing the message in the future, the field value has again defaulted back to 5 so that is what is saved if you forget each time to go in and change it. Its not pulling the value from the database on edit despite the correct value being saved, it is defaulting to 5.

 

Also @Mike John What is the difference between "Normal Block" and "Info Message" please?

Thanks for reporting, I've logged a bug for that.

The only difference is the css style used to display the message, nothing else.

@Mike John - Also if I try to get the message to just show in a specific forum utilising the global hook it just shows everywhere and not in the forums specified? 

Plus a language bug when adding Administration Permissions to the application

And that's still with the forum permissions being set when setting up the message?

Thanks for reporting, logged a bug report.

Link to comment
Share on other sites

  • 2 weeks later...

Thanks for reporting, I've logged a bug for that.

The only difference is the css style used to display the message, nothing else.

And that's still with the forum permissions being set when setting up the message?

Thanks for reporting, logged a bug report.

Any update on a fix for these issues please? @Mike John

Link to comment
Share on other sites

I'm working through some more IPB4 bug fixes now, Messages app shouldn't be much longer.

You didn't get back to me about the forum permissions, if that's still an issue I'll need confirmation before I log a bug report.

Yes it is - if I select the Global Hook option to on in settings and then under the message configure it to only appear in a couple of forum areas, it just appears everywhere. Its as if its global and ignores the setting.

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...
  • 1 month later...
3 hours ago, Joey_M said:

@Mike JohnDoes this display messages after each other or on rotation?

If not, would you consider adding the ability to display messages after each other and for allowing messages to hidden? Looks a brilliant application and something I am keen to add to my site.

Widgets only display 1 message at a time but if your using the central hook that appears at the top of the forums, you can choose between displaying messages in rotation or by position (with drag and drop position supported in the acp).

No, hide support is currently not included. But you'll see a post above that it is something that is on my radar and if not included in the next version will be something I'm looking at soon after. If you need a demo, let me know and can setup one for you.

Link to comment
Share on other sites

  • 3 weeks later...
9 hours ago, Police Community said:

@Mike John

No message any longer displays without using widgets - if I switch on the global hook and remove all widgets it never displays. Even if I create a default new theme with no logo customisation or anything I still get no message displaying using the global hook.

What version of IPB 4 are you using? Assume you've got no restrictions in place that might stop it from showing in the global hook?

Link to comment
Share on other sites

Mike, is it possible to include in an update the ability to allow selected messages to show in rotation via the widget?

At the moment I can only choose between one or the other, plus with my skin seeming to be missing the hook point - I don't have any other way around this. If it could be possible that upon refreshing/reloading the messages changes between a selected group, I would appreciate it.

Link to comment
Share on other sites

On 15/10/2015 3:58:05, Joey_M said:

Mike, is it possible to include in an update the ability to allow selected messages to show in rotation via the widget?

I believe so, should just be a matter of changing the node form to support multiple values. I'll log this and make sure it's included next version.

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...