Jump to content
You're invited! Join our 4.6 Live Event on ZOOM 6/24 ×

Community

Videos Support


Michael.J

Recommended Posts

4.1 Bug report. Video section works BUT?

For admin the content i posted streams throws a blank page, i refreshed a ton and got this error finally to show.

Fatal error: Access to undeclared static property: IPS\videos\Video::$urlBase in /home/****/****/system/Content/Item.php on line 957

Disabling video plugin makes it work.

Link to comment
Share on other sites

On 23/10/2015 10:22:14, Ilya Kirilenko said:

Prompt please, what that setting might not notice.
I put a limit on the width of the media in a forum post, as full-screen video, hinder reading. And this limitation raspostranen on video in an application. Now they're little. Is it possible to remove this restriction only for the application?

Please advice the exact setting you changed and I will take a look if anything is possible.

9 hours ago, xtech said:

For some reason, i cannot get Dailymotion videos to work.

But i still get the error " Problem generating embed code. "

Just tried without issue, both embed and thumbnail generates fine. I'm going to need ftp/acp login details to troubleshoot this on your end as can't reproduce this.

Link to comment
Share on other sites

On 14/11/2015, 2:09:28, Durango said:

We are still on IPB 4.0 and didnt upgrade anything, it was working till yesterday, but today always got this error message

oEmbed is used to generate both the embed code and thumbnail so maybe possible downtime for Youtube's oEmbed service or your server not being able to access for some reason. If it still happens again tomorrow, I'll need ftp/acp login details to troubleshoot this further and see if it's masking some kind of error when connecting to oEmbed.

Link to comment
Share on other sites

On 19/11/2015, 10:01:56, Ilya Kirilenko said:

One more question. Tell me please, is intended to support online broadcasts with Twitch, hitbox and other services? To mark was Live or offline + chat built from the service when he online

I used the internal IPB4 embed template to generate my Youtube embed, so any setting you have for video embeds would apply within topics as well as videos.

If the service supports oEmbed than it will auto embed the live streams but no tracking of live sites is included. I've had this one suggested to me already here but not very likely until next year now. I'm still working through bug fixes.

Link to comment
Share on other sites

  • 3 weeks later...

@Mike John

Would it be possible for me to make the video dimensions full width without changing my forum max settings. Reason being. in forum posts videos should be small. But in the video app i think since the focus is on the video it should be filling the space it is given. As it is i get white space down one side.

Could you provide me some advice to achieve this?

Link to comment
Share on other sites

11 hours ago, Netherlord said:

Could you provide me some advice to achieve this?

The embed template is handled by IPB and cached in the database, so the best option would probably to remove any video limitation on display. Open theme editor > videos > front > global > video

Find:

{$video->embed|raw}

Add ABOVE:

{{$video->embed = str_replace('ipsEmbeddedVideo_limited', '', $video->embed );}}

See how that goes.

Link to comment
Share on other sites

7 hours ago, Mike John said:

The embed template is handled by IPB and cached in the database, so the best option would probably to remove any video limitation on display. Open theme editor > videos > front > global > video

Find:


{$video->embed|raw}

Add ABOVE:


{{$video->embed = str_replace('ipsEmbeddedVideo_limited', '', $video->embed );}}

See how that goes.

thanks that seems to work great. Might i suggest this edit be added to the plugin on a toggle setting? might be useful for others.

Link to comment
Share on other sites

5 hours ago, Mike John said:

Currently looking into this now. Are you using v4.1.5.2 by the way?

I am yes.

The setting seems to be on currently. But i dont know how. At the time i hit to turn it on I got the error. Tried again. Same error. Refreshed. and it was shown as toggled off. I exited and went back to check and make sure an hour later and it was still off. But its somehow now switched on. So i have no idea about this.

Link to comment
Share on other sites

On 14/12/2015 at 7:32 PM, Netherlord said:

I am yes.

The setting seems to be on currently. But i dont know how. At the time i hit to turn it on I got the error. Tried again. Same error. Refreshed. and it was shown as toggled off. I exited and went back to check and make sure an hour later and it was still off. But its somehow now switched on. So i have no idea about this.

Sorry just to be clear, the error is on the settings page nor in the front end? I've gotten a few reports of this but can't seem to reproduce this yet. I'll either need acp access or a complete set of screenshots of your video settings.

Link to comment
Share on other sites

  • 4 weeks later...

I noticed that in my forums... If i go to the sort by options i for some reason get the option to sort my video title? im guessing this is a bug since it does nothing in a forum?

And if im using a custom database i get the video title and an extra views sort option.

Edited by Netherlord
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy