Jump to content

Community

Videos Support


Michael.J

Recommended Posts

On 10/6/2016 at 10:28 PM, Mike John said:

Are you referring to something like the "Insert other media > existing attachment" area?

You can in ACP > System tab > Advanced Configuration > Friendly URLS tab (If you need help with a few examples, let me know). Although you might want to hold off as there is currently a bug affecting furls.

 

So how can I simplify the url to just www.ohiocannabis.com/videos?

I want to drop the Forum out of the URL

And is this a bug within your video plugin for FURL, or within the IPS suite?

Edited by TheGreyWizard
Link to comment
Share on other sites

On 10/10/2016 at 6:56 PM, TheGreyWizard said:

So how can I simplify the url to just www.ohiocannabis.com/videos?

And is this a bug within your video plugin for FURL, or within the IPS suite?

I don't believe you can. The url would be {yourforumurl/videos and start from there.

The bug is an IPS bug and seems to be affecting all apps at this stage. Hopefully IPB 4.1.16 fixes it.

On 10/10/2016 at 10:45 PM, TheGreyWizard said:

And yes I'd like to add video to blogs & articles etc.  But the "Insert other media" only seems to do images, not videos?

I don't have access to the Gallery app so not entirely familiar with it's approach. Would you mind taking a screenshot?

Link to comment
Share on other sites

32 minutes ago, Chris59 said:

Add new videos stop working now . not sure its because I update to 4.1.16 or i integrate collaboration with it ... tried also add a new video in ordinary category without success ....

2016-10-18_06-28-11.jpg
2016-10-18_06-28-44.jpg

 

We've been having problems with submitting Videos since integrating Collaboration App as well.

I've talked with @Mike John a few times about it, and he said he should have it fixed soon :) 

Link to comment
Share on other sites

I am also having trouble with videos not playing in Facebook after I share them using the Facebook button at the bottom. I thought it might be an issue with guest permissions. When I went to fix the guest permissions, I saw this:

video-permissions.png

It is the same with all groups--there are no permissions being displayed for me to set. Just the statement "There are no rows to show yet."

Link to comment
Share on other sites

On 01/11/2016 at 3:24 AM, Bendensin said:

I am also having trouble with videos not playing in Facebook after I share them using the Facebook button at the bottom. I thought it might be an issue with guest permissions. When I went to fix the guest permissions, I saw this:

It is the same with all groups--there are no permissions being displayed for me to set. Just the statement "There are no rows to show yet."

I'll have to log this and take a look again. If your site is available for testing, please let me know and I can send through some test code when I've got something.

Link to comment
Share on other sites

On 12/09/2016 at 4:34 AM, Mike John said:

Noted for next version.

Noted.

If I'm understanding this right. Then no I don't believe it would work as there is no current Pages integration like you need.

I'll save it for a future version but won't be possible until the next major version is released.

Did you make any progress with pulling from RSS. I think it would be really useful for my community!

Edited by Netherlord
Link to comment
Share on other sites

On 02/11/2016 at 1:06 AM, Mike John said:

I'll have to log this and take a look again. If your site is available for testing, please let me know and I can send through some test code when I've got something.

I get the same. Additionally everytime i share a video now the description is also replaced with meta data from the donations page.

Link to comment
Share on other sites

On 10/11/2016 at 11:43 PM, Netherlord said:

I get the same. Additionally everytime i share a video now the description is also replaced with meta data from the donations page.

Seems to be only videos without descriptions. Any way to add a piece of text if no description is added? So it wont pick a random site meta description!

Link to comment
Share on other sites

On 10/11/2016 at 3:15 AM, Netherlord said:

Did you make any progress with pulling from RSS. I think it would be really useful for my community!

Major new features might be some time away.

On 11/11/2016 at 10:43 AM, Netherlord said:

I get the same. Additionally everytime i share a video now the description is also replaced with meta data from the donations page.

I'm working on a test patch here.

Link to comment
Share on other sites

1 hour ago, Mike John said:

Major new features might be some time away.

I'm working on a test patch here.

Edit: Looks like that did not fix the fb share issue! still plays blank white video when clicked!

Also my meta tag issue! If a video has a description it includes it in the meta tags when sharing but if no description is added then when i share it the description reverts to text from the donations app. So when i post videos without a description it looks like i am begging for money :) not a good position.

Any idea's?

Edited by Netherlord
Link to comment
Share on other sites

On 14/11/2016 at 2:36 PM, Netherlord said:

Edit: Looks like that did not fix the fb share issue! still plays blank white video when clicked!

Were you trying the same video as before? I believe Facebook does cache share data, just test another video to make sure.

On 14/11/2016 at 2:36 PM, Netherlord said:

Also my meta tag issue! If a video has a description it includes it in the meta tags when sharing but if no description is added then when i share it the description reverts to text from the donations app. So when i post videos without a description it looks like i am begging for money :) not a good position.

Yeah I understand, if you haven't added a description it's gotta use something. Any suggestions and can include a file edit to use some other video data?

Link to comment
Share on other sites

Hi Mike,

I have a member who posts great YouTube and Vimeo videos into to a long running topic and I'd love for the videos to also appear in the Videos System which sadly isn't used much by my members. Is there an option available in Videos System that I could use quickly post selected videos in existing topics as videos in Videos System? I don't want to have to recreate them manually from scratch when the data needed already exists in the topic posts (name of video, contributor' video URL etc etc). Something like Post/Share As Video, which would add the video to a category in my Videos System?

Many thanks.

Link to comment
Share on other sites

9 hours ago, Mike John said:

Yeah I understand, if you haven't added a description it's gotta use something. Any suggestions and can include a file edit to use some other video data?

Could always just add "no description" string? if no description is added!

9 hours ago, Mike John said:

Were you trying the same video as before? I believe Facebook does cache share data, just test another video to make sure

I tried a few. New and old and i re-cached using the facebook debugger. I messed around for a little while. sadly the same.

-- I'm not sure but would i be right in suggesting that youtube videos should fake a video look in fb share. (that might be easier?) have it display the thumbnail image and title. And when clicked just jump to the video viewing page.

Just seems like it might fix this issue?

Edited by Netherlord
Link to comment
Share on other sites

On 15/11/2016 at 7:24 PM, The Old Man said:

I have a member who posts great YouTube and Vimeo videos into to a long running topic and I'd love for the videos to also appear in the Videos System which sadly isn't used much by my members. Is there an option available in Videos System that I could use quickly post selected videos in existing topics as videos in Videos System? I don't want to have to recreate them manually from scratch when the data needed already exists in the topic posts (name of video, contributor' video URL etc etc). Something like Post/Share As Video, which would add the video to a category in my Videos System?

Not currently but it was a feature of IPB 3 and something I'm looking to re-add as soon as I can free up some time to start on new features again.

On 15/11/2016 at 11:15 PM, Netherlord said:

-- I'm not sure but would i be right in suggesting that youtube videos should fake a video look in fb share. (that might be easier?) have it display the thumbnail image and title. And when clicked just jump to the video viewing page.

Well my testing produced that affect. At this stage, if the debugging is not showing changes I would double check your edits were applied and view the source code itself to make sure as well.

Link to comment
Share on other sites

On 18/11/2016 at 4:25 AM, Mike John said:

Not currently but it was a feature of IPB 3 and something I'm looking to re-add as soon as I can free up some time to start on new features again.

Well my testing produced that affect. At this stage, if the debugging is not showing changes I would double check your edits were applied and view the source code itself to make sure as well.

I checked again fully! Went through edits again to make sure nothing was wrong. When you paste a link it is an image that when clicked takes you to the video page. This happens in the debugger and in the embed as you post in editor on facebook. BUT once the share is posted. It no longer follows that and reverts to playing a white video.

This seems to have fixed it for me.

/* Add thumbnail to meta */
			if( $video->thumbnail )
			{
				\IPS\Output::i()->metaTags['og:image'] = \IPS\File::get( 'videos_Thumbs', $video->thumbnail )->url;
\IPS\Output::i()->metaTags['meta_imagesrc'] = \IPS\File::get( 'videos_Thumbs', $video->thumbnail )->url;
\IPS\Output::i()->metaTags['og:image:width'] = "398";
\IPS\Output::i()->metaTags['og:image:height'] = "224";
			}

if( $video->video_type == 'media_url' OR !$video->video_type )
{
\IPS\Output::i()->metaTags['medium'] = "video";
}

 

Edited by Netherlord
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy