Jump to content

Community

Videos Support


Michael.J

Recommended Posts

On 18/08/2016 at 5:56 AM, zheck said:

I've messaged Mike about how that option is confusing the members of my website as well.

In case I missed this, I logged it again and should be able to squeeze it in the upcoming update.

On 18/08/2016 at 6:02 AM, ToeJam said:

Even if I go back as admin to edit that out, nothing changes

Can you try adding a new video this time and report how that goes?

Link to comment
Share on other sites

  • 2 weeks later...

I basically have ONE need and only ONE need: To be able to upload videos such as mp4, mpg and avi while creating a new article post in IP.Content. Once uploaded and the post is published, allow the users to be able to see the video displayed inline such as when you paste a YT link into a post and the user can simply play it within the post. In other words, play the video inline and not by clicking a link and opening another page or app to play the video.

Is this possible with this Videos application? 98% of my users are on mobile, so this needs to work in mobile and tablet browsers.

Looking forward to a response!

Link to comment
Share on other sites

@Mike John Would you please enable a feature that would ineffectively pull videos from an RSS, then que them up to be finalized either manually or automatically? YouTube has an RSS feed for channels, I would like avoid manually adding one's for my fan site to save time (also if possible to have a auto description which is the same that would be very handy).

It would be nice if we could replace the thumbnail for the discussion to automatically embed the video instead.

You'd be surprised by how much of an impact this can have on the videos views. Inside the video section, you attract x but in the discussion people are not only inclined to comment but also view it.

Edited by Joey_M
Link to comment
Share on other sites

On 02/09/2016 at 5:58 AM, Michael R said:

When members click on "Unread Content" it says this at the top:

Noted for next version.

On 08/09/2016 at 2:11 AM, Netherlord said:

I'm not sure if i mentioned this before but could it be made so that the Videos tab in profiles is hidden if a user has not posted a video.

Noted.

On 11/09/2016 at 4:55 AM, LDDG said:

Is this possible with this Videos application? 98% of my users are on mobile, so this needs to work in mobile and tablet browsers.

If I'm understanding this right. Then no I don't believe it would work as there is no current Pages integration like you need.

1 hour ago, Joey_M said:

Would you please enable a feature that would ineffectively pull videos from an RSS, then que them up to be finalized either manually or automatically? YouTube has an RSS feed for channels, I would like avoid manually adding one's for my fan site to save time (also if possible to have a auto description which is the same that would be very handy).

I'll save it for a future version but won't be possible until the next major version is released.

Link to comment
Share on other sites

1 hour ago, Mike John said:

I have noticed this on a few sites now. I'll note a bug and see how this can be improved.

I've got two other mentions also. Nothing serious but i noticed it.

Issue 1: LOCATION: Viewing a video entry as a guest - The  Sign in to follow this  text section seems to be massive in comparison to the same text on a thread. also sometimes it seemed to affect the follow button css next to it on a video page also.

Issue 2: Meta tag related! If i share a video page from my site, and the video is a youtube. It will embed as a image on all sites but facebook and twitter. On twitter it embeds as a youtube video. But on facebook it embeds as youtube video with blank video content. so when people click to play the video i linked it just plays white screen and nothing more. No redirect to the site etc. Not sure if this is a fb issue though.

Edited by Netherlord
Link to comment
Share on other sites

  • 2 weeks later...
3 hours ago, Mike John said:

The next bug fixing update should be released within a week or two max. If there is any particular bug your waiting on, please let me know and I'll see if I can provide a temp patch.

 

OK ^_^

Well most of my members receive an Error when submitting a Video. The video still gets posted it just shows an Error every time making them think it was not posted and then they send me messages saying it's broken. Now this doesn't happen for Administrators, but for all the other Members Groups it shows the Error.

 

Also the same members groups receive this configuration Error when trying to see click the (Videos) Tab on any of the profile pages on the website.

Not really sure why, but Admins do not have this issue. Only everyone else on the website.

video error 2.jpg

 

I sent you the full Error in a PM message ^_^  

Link to comment
Share on other sites

20 hours ago, zheck said:

Well most of my members receive an Error when submitting a Video. The video still gets posted it just shows an Error every time making them think it was not posted and then they send me messages saying it's broken. Now this doesn't happen for Administrators, but for all the other Members Groups it shows the Error.

Could I have more details or a screenshot of the error their getting?

20 hours ago, zheck said:

I sent you the full Error in a PM message ^_^  

Reply sent, I think there might be a conflict with another app.

Link to comment
Share on other sites

On 28/09/2016 at 11:32 AM, TheGreyWizard said:

Does this plugin also work with Vimeo or only Youtube?

Both. A quick way to see if the Videos app supports any particular video site is to paste it into a post and see if IPB4 turns it into an embed code automatically. If it does, then the Videos app supports that particular site. Here is a rough copy from the source code itself on the current oEmbed sites IPB4 supports.

			'youtube.com'					=> 'https://www.youtube.com/oembed',
			'm.youtube.com'					=> 'https://www.youtube.com/oembed',
			'youtu.be'						=> 'https://www.youtube.com/oembed',
			'flickr.com'					=> 'https://www.flickr.com/services/oembed/',
			'flic.kr'						=> 'https://www.flickr.com/services/oembed/',
			'hulu.com'						=> 'http://www.hulu.com/api/oembed.json',
			'vimeo.com'						=> 'https://vimeo.com/api/oembed.json',
			'collegehumor.com'				=> 'http://www.collegehumor.com/oembed.json',
			'twitter.com'					=> 'https://api.twitter.com/1/statuses/oembed.json',
			'instagr.am'					=> 'https://api.instagram.com/oembed',
			'instagram.com'					=> 'https://api.instagram.com/oembed',
			'soundcloud.com'				=> 'https://soundcloud.com/oembed',
			'open.spotify.com'				=> 'https://embed.spotify.com/oembed/',
			'play.spotify.com'				=> 'https://embed.spotify.com/oembed/',
			'ted.com'						=> 'https://www.ted.com/services/v1/oembed',
			'vine.co'						=> 'https://vine.co/oembed.json',
			'facebook.com'					=> array(
				'(\/.+?\/videos\/|video.php)'	=> 'https://www.facebook.com/plugins/video/oembed.json',
				0								=> 'https://www.facebook.com/plugins/post/oembed.json',
			),
			'gfycat.com'					=> 'https://api.gfycat.com/v1/oembed',
			'dailymotion.com'				=> 'http://www.dailymotion.com/services/oembed',

 

Link to comment
Share on other sites

14 hours ago, Michael R said:

Is there a way you can disallow the video's URL in the description field? I know this is stupid, but you would be surprised how many of my users add the URL there. They also tend to only put it there and wonder why they get an error when they don't add it to the URL field...

It might be possible to add some custom validation to the description field to check for any matches for the media url. I'd need to write up some custom code to do this, can you PM me about this in a few weeks to remind me when I've got more time?

Link to comment
Share on other sites

I'm having a hard time figuring out how to get this plugin installed, I just downloaded the file.

According to this read me:http://www.devfuse.com/forums/tutorials/article/162-install-application-guide/

It says I need to install a tar file through the AdminCP?

I just downloaded this zip file, unzipped it and the only thing inside is an Install Read Me, Upgrade from 3.x and another video zip file - but no tar file.

When I unzip the 2nd video zip file, I get a bunch of files, but still no tar.

So how do I install this plugin?

Edited by TheGreyWizard
Link to comment
Share on other sites

8 hours ago, TheGreyWizard said:

I'm having a hard time figuring out how to get this plugin installed, I just downloaded the file.

According to this read me:http://www.devfuse.com/forums/tutorials/article/162-install-application-guide/

It says I need to install a tar file through the AdminCP?

I just downloaded this zip file, unzipped it and the only thing inside is an Install Read Me, Upgrade from 3.x and another video zip file - but no tar file.

When I unzip the 2nd video zip file, I get a bunch of files, but still no tar.

So how do I install this plugin?

Nevermind it was my computer having winzip that was giving me the issue with not seeing the .tar file - it is successfully installed and all is well!

 

Is there any way to insert the video widget inside of say a blog or article, or attach the reel somehow like you can do with the gallery?

That would be really nice instead of having to copy and paste the youtube code in your blogs/articles

Is there anyway to change the URL from https://www.ohiocannabis.com/forums/videos/

to just OhioCannabis.com/videos

?

Edited by TheGreyWizard
Link to comment
Share on other sites

17 hours ago, TheGreyWizard said:

Is there any way to insert the video widget inside of say a blog or article, or attach the reel somehow like you can do with the gallery?

Are you referring to something like the "Insert other media > existing attachment" area?

17 hours ago, TheGreyWizard said:

Is there anyway to change the URL from https://www.ohiocannabis.com/forums/videos/

You can in ACP > System tab > Advanced Configuration > Friendly URLS tab (If you need help with a few examples, let me know). Although you might want to hold off as there is currently a bug affecting furls.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy