Jump to content

Videos Support


Michael.J

Recommended Posts

On 27/05/2016 at 0:35 PM, Mike John said:

Can I get the name of that theme or a site where it's currently installed to take a quick look? I've actually had this reported in a few custom themes, just working on a template edit that should cover most custom themes.

Videos must be HTML5 compatible (If you want me to double check a video is compatible, PM with me a copy). Adding media urls (YouTube, Vimeo, Vine and oEmbed supported sites) is the primary purpose.

Should already be in place, is it not showing for you when logged in?

Same as above, if you don't mind testing a template edit I can put something together for you?

The theme is called Dispersion and I currently use it on http://www.brendenplayz.com/forums

Link to comment
Share on other sites

On 02/06/2016 at 5:24 PM, RPG-support said:

May be you make mod permissions?

Yes it looks like I'm being forced into that direction. IPS haven't gotten back to me and I still believe this is a bug as I don't make use of "modPermissions". I could add the language strings for those fields if it helps? They wouldn't affect anything but at least would have strings present.

On 02/06/2016 at 5:55 PM, Brenden Scifleet said:

The theme is called Dispersion and I currently use it on http://www.brendenplayz.com/forums

I've made some further progress in the latest version but will adjust further if needed.

On 02/06/2016 at 9:27 PM, RPG-support said:

Again you are installing the dupliucated language strings. When will you stop to ruin my site?

Are those the 4 remaining duplicates you see?

Edited by Mike John
Link to comment
Share on other sites

12 hours ago, Mike John said:

Are those the 4 remaining duplicates you see?

Yes, they are. I already deleted them again by the sql requests you gave the last time.

I could add the language strings for those fields if it helps? They wouldn't affect anything but at least would have strings present.

I think you should continue to inform the IPS staff that the bug exists.

Link to comment
Share on other sites

On 07/06/2016 at 2:13 AM, RPG-support said:

Yes, they are. I already deleted them again by the sql requests you gave the last time.

I've noted this last 4 remaining ones and will have them fixed next release.

On 07/06/2016 at 2:13 AM, RPG-support said:

I think you should continue to inform the IPS staff that the bug exists.

I believe you have access to the Contributor forums? I'm going to open a topic there requesting more information as I can't seem to reply to my bug report.

 

Link to comment
Share on other sites

  • 4 weeks later...

I am running Videos version 3.1.11. When I upgraded to the latest version of IP Community (Version 4.1.13.2), during the upgrade, I got two error messages concerning Videos:
 

Table 'turkeyc_tcencom2.iBBS_videos_rate' doesn't exist
/home/turkeyc/public_html/applications/videos/setup/upg_10003/upgrade.php::24

Table 'turkeyc_tcencom2.iBBS_videos' doesn't exist
/home/turkeyc/public_html/applications/videos/setup/upg_10016/upgrade.php::24

All of my videos are now hidden (except for one I just unhid) and the category names are not showing, just category numbers:

videos.png

Can you assist?

Edited by Bendensin
Link to comment
Share on other sites

11 hours ago, Bendensin said:

I am running Videos version 3.1.11. When I upgraded to the latest version of IP Community (Version 4.1.13.2), during the upgrade, I got two error messages concerning Videos:

Was the Videos upgrade done concurrently with IPB or was this simply a IPB upgrade? If the upgrade failed for any reason, I'm most likely going to need board access to run the rest manually.

Edited by Mike John
Link to comment
Share on other sites

I am also having issues since the last upgrade, it fails when trying to add a new video.

INSERT INTO `videos_videos` ( `date`, `last_updated`, `author_id`, `cid`, `status`, `views`, `featured`, `num_comments`, `title`, `seo_title`, `description`, `video_type`, `thumbnail_type`, `video_data`, `embed`, `thumbnail`, `extra_videos` ) VALUES ( 1468359349, 1468359349, 1, 1, 1, 0, 0, 0, 'test', 'test', '<p>
	fgx
</p>', 'media_url', 0, 'https://vimeo.com/172245885', '
<div class=\'ipsEmbeddedVideo \' contenteditable="false"><div><iframe src="https://player.vimeo.com/video/172245885" width="640" height="360" frameborder="0" title="Martin Kopáček Modul2 video1" webkitallowfullscreen="true" mozallowfullscreen="true" allowfullscreen="true"></iframe></div></div>', IPS\File\FileSystem::__set_state(array(
   'temporaryFilePath' => NULL,
   'configuration' => 
  array (
    'dir' => '/home/emumovie/public_html/uploads/videos/thumbnails',
    'url' => 'uploads/videos/thumbnails',
  ),
   'configurationId' => 5,
   'storageExtension' => 'videos_Thumbs',
   'originalFilename' => 'videothumb_1468359350.thumb.png',
   'filename' => 'videothumb_1468359350.thumb.png.2e62e9d21554ead2b0bf92a5037f1820.png',
   'container' => 'monthly_2016_07',
   'contents' => 
  IPS\Image\Gd::__set_state(array(
     'image' => NULL,
     'hasBeenRotated' => false,
     'type' => 'jpeg',
     'width' => 400,
     'height' => 225,
     'isAnimatedGif' => false,
     'contents' => NULL,
     'exif' => 
    array (
    ),
  )),
   'url' => 
  IPS\Http\Url::__set_state(array(
     'url' => 'http://emumovies.com/uploads/videos/thumbnails/monthly_2016_07/videothumb_1468359350.thumb.png.2e62e9d21554ead2b0bf92a5037f1820.png',
     'data' => 
    array (
      'scheme' => 'http',
      'host' => 'emumovies.com',
      'path' => '/uploads/videos/thumbnails/monthly_2016_07/videothumb_1468359350.thumb.png.2e62e9d21554ead2b0bf92a5037f1820.png',
    ),
     'queryString' => 
    array (
    ),
     'isInternal' => true,
     'isFriendly' => true,
  )),
   'tempId' => NULL,
   'attachmentThumbnailUrl' => NULL,
   'thumbnailName' => NULL,
   'thumbnailContainer' => NULL,
)), NULL )
IPS\Db\Exception: Field 'members_seo_name' doesn't have a default value (1364)
#0 /home/emumovie/public_html/system/Db/Db.php(661): IPS\_Db->preparedQuery('INSERT INTO `vi...', Array)
#1 /home/emumovie/public_html/system/Patterns/ActiveRecord.php(441): IPS\_Db->insert('videos_videos', Array)
#2 /home/emumovie/public_html/system/Content/Item.php(450): IPS\Patterns\_ActiveRecord->save()
#3 /home/emumovie/public_html/applications/videos/sources/Video/Video.php(656): IPS\Content\_Item->processForm(Array)
#4 /home/emumovie/public_html/system/Content/Item.php(305): IPS\videos\_Video->processForm(Array)
#5 /home/emumovie/public_html/system/Content/Item.php(65): IPS\Content\_Item::createFromForm(Array, Object(IPS\videos\Category))
#6 /home/emumovie/public_html/applications/videos/modules/front/videos/submit.php(129): IPS\Content\_Item::create(Object(IPS\videos\Category))
#7 [internal function]: IPS\videos\modules\front\videos\_submit->submit()
#8 /home/emumovie/public_html/system/Dispatcher/Controller.php(85): call_user_func(Array)
#9 /home/emumovie/public_html/applications/videos/modules/front/videos/submit.php(31): IPS\Dispatcher\_Controller->execute()
#10 /home/emumovie/public_html/system/Dispatcher/Dispatcher.php(129): IPS\videos\modules\front\videos\_submit->execute()
#11 /home/emumovie/public_html/index.php(13): IPS\_Dispatcher->run()
#12 {main}

 

Link to comment
Share on other sites

4 hours ago, Circo said:

I am also having issues since the last upgrade, it fails when trying to add a new video.

I'll need either board access or a full copy of your most recent error logs in the uploads/logs/ folder. It's obviously failed at 1 point and has prevented the rest of the database changes to be made.

If you load ACP > System tab > Support > Something isn't working correctly. Do you see any errors mentioned for the videos database tables?

Link to comment
Share on other sites

13 hours ago, Mike John said:

I'll need either board access or a full copy of your most recent error logs in the uploads/logs/ folder. It's obviously failed at 1 point and has prevented the rest of the database changes to be made.

If you load ACP > System tab > Support > Something isn't working correctly. Do you see any errors mentioned for the videos database tables?

I'll pm you

Link to comment
Share on other sites

  • 3 weeks later...
5 hours ago, zheck said:

But I was wondering if it was possible to show the entire video on the Activity Feed when a Video is posted.

It might be possible with a template edit, just to confirm your talking about the stream view that would add a video row when a new video is added? i.e. Unless there was any changes in IPB4 recently, there should be a line break between fields already. Could you post a sceenshot of what your talking about? Not quite sure what's happening here.

Link to comment
Share on other sites

29 minutes ago, Mike John said:

It might be possible with a template edit, just to confirm your talking about the stream view that would add a video row when a new video is added? i.e. Unless there was any changes in IPB4 recently, there should be a line break between fields already. Could you post a sceenshot of what your talking about? Not quite sure what's happening here.

 

This is what pops up on the Activity Feed when someone post a video ^_^

Basically just the Title of the Video and the Section it was posted to.

 

video activity feed.jpg

 

I was wondering if it could show the Video itself, instead of just the Title and the Section.

Like the Example I've given below ^_^

 

video activity feed with video.jpg

Edited by zheck
Link to comment
Share on other sites

On 01/08/2016 at 0:01 PM, zheck said:

This is what pops up on the Activity Feed when someone post a video ^_^

From my brief look, I wasn't able to find a quick patch but I'll log this to be included in a future version.

On 03/08/2016 at 5:19 AM, zheck said:

Someone being able to add 50 Videos to the Website at one time.

Was this malicious in nature or just someone adding a lot of videos in 1 day?

Link to comment
Share on other sites

11 minutes ago, Mike John said:

From my brief look, I wasn't able to find a quick patch but I'll log this to be included in a future version.

Was this malicious in nature or just someone adding a lot of videos in 1 day?

 

I don't believe it was Malicious, but it definitely was an abuse of the system.

They totally covered the Main Page for a few hours, and I know as the website grows we will only get more people to compete for that "Latest Videos" spot.

So having the ability to CAP the members to only 3 - 4 videos a day would be awesome ^_^

Link to comment
Share on other sites

10 minutes ago, zheck said:

I don't believe it was Malicious, but it definitely was an abuse of the system.

If you don't mind a file edit, I should be able to put together some temporary code you could try and test now. Something with either a setting or group permission restriction for max daily videos would require a new version however.

Link to comment
Share on other sites

Just now, Mike John said:

If you don't mind a file edit, I should be able to put together some temporary code you could try and test now. Something with either a setting or group permission restriction for max daily videos would require a new version however.

 

I'm totally game for it! :D

Link to comment
Share on other sites

  • 2 weeks later...
4 hours ago, ToeJam said:

Having an issue where the video that someone posts is not showing up.

This happened to me a couple of times too, but everything seems to be entered correctly

 

 

Video 1.jpg

 

Video 2.jpg

Did I miss a setting somewhere?

 

This is because you picked Enter URL to Uploaded File.

You needed to choose the Enter Media URL ^_^

 

I've messaged Mike about how that option is confusing the members of my website as well.

And having the option to remove it completely.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...