Jump to content

Upgrading from 3.1.* > 4.0.*/Changing Forum Domain


Recommended Posts

Good Morning (in my timezone)...

Am looking at upgrading a 3.1 community to 4.0, as well as changing the current url structure from domain.com/forum to forum.domain.com, and moving to a complete new hosting environment (AWS).

I'm curious as in to what the best order to do things in? I also can't find any direct info on whether or not I can actually upgrade from 3.1 to 4.0, or if I have to go from 3.1 to 3.4 to 4.0.

For upgrade testing purposes I'm looking at:

  1. Upgrading to 4.0 on existing install
  2. Changing domain/url path on existing server
  3. Migrating to new server

Anything I'm particularly missing here?

Link to comment
Share on other sites

  • 3 weeks later...

So, I started testing this process yesterday, via two different paths, and have ended up with the same result. Effectively when I do the upgrade to 4.0.7, somehow it injects the OLD url into the path for including CSS/JS into the theme, which obviously ruins things.

Existing forum
URL: http://domain.co.nz/forum/

New forum - 
URL: https://forum.domain.co.nz

Upgrade Path 1

  1. tar.gz existing 3.1.4 install directory
  2. mysqldump existing database
  3. transfer to new server environment
  4. untar/gz into new web directory
  5. mysql < mysqldump
  6. configure new domain in config.php
  7. configure new uploads path in AdminCP
  8. Set IPB Theme as default, delete custom theme

At this stage, everything worked fine. I had successfully moved the forum to the new server environment and changed the url. Attachments, profile photos etc, everything was working no problems.

  1. unziped IPS4 install
  2. moved new files on top of old install
  3. ran upgrade process. First it did utf8, then restarted
  4. Had three erroneous database errors, which I continued
  5. Process finished successfully.

Now when I load the main page, or the admincp, it only loads basic text with a white background. A quick view source shows the issue:

<link rel='stylesheet' href='https://forum.domain.co.nz/https://domain.co.nz/forum/uploads/css_built_1/341e4a57816af3ba440d891ca87450ff_framework.css.27892aa737c146cc95bf127ad66a9a72.css?v=23e552198b' media='all'>
<link rel='stylesheet' href='https://forum.domain.co.nz/https://domain.co.nz/forum/uploads/css_built_1/05e81b71abe4f22d6eb8d1a929494829_responsive.css.f9b6a9acf703503783d39f9242e43032.css?v=23e552198b' media='all'>
<link rel='stylesheet' href='https://forum.domain.co.nz/https://domain.co.nz/forum/uploads/css_built_1/90eb5adf50a8c640f633d47fd7eb1778_core.css.0b072224c40886074f7843a9b6576c5e.css?v=23e552198b' media='all'>
<link rel='stylesheet' href='https://forum.domain.co.nz/https://domain.co.nz/forum/uploads/css_built_1/5a0da001ccc2200dc5625c3f3934497d_core_responsive.css.216bc3e7b64db5c475399e196ccc440d.css?v=23e552198b' media='all'>
<link rel='stylesheet' href='https://forum.domain.co.nz/https://domain.co.nz/forum/uploads/css_built_1/20446cf2d164adcc029377cb04d43d17_flags.css.6a0deb41ddb5505ad360bfee52c37c22.css?v=23e552198b' media='all'>
<link rel='stylesheet' href='https://forum.domain.co.nz/https://domain.co.nz/forum/uploads/css_built_1/62e269ced0fdab7e30e026f1d30ae516_forums.css.b79fe5d70d111c8aa0724bca4ae54a5a.css?v=23e552198b' media='all'>
<link rel='stylesheet' href='https://forum.domain.co.nz/https://domain.co.nz/forum/uploads/css_built_1/76e62c573090645fb99a15a363d8620e_forums_responsive.css.637a244071fd2efa54564545b154b1a0.css?v=23e552198b' media='all'>


<script type='text/javascript' src='https://forum.domain.co.nz/https://domain.co.nz/forum/uploads/javascript_global/root_library.js.d258cfe3bba484e11054d5f0dc3d0b17.js?v=23e552198b' data-ips></script>
<script type='text/javascript' src='https://forum.domain.co.nz/https://domain.co.nz/forum/uploads/javascript_global/root_js_lang_1.js.c4b0e0b0966a50d447281ea4fce1662c.js?v=23e552198b' data-ips></script>
<script type='text/javascript' src='https://forum.domain.co.nz/https://domain.co.nz/forum/uploads/javascript_global/root_framework.js.2ff549da82046ede328ed3175fe034e8.js?v=23e552198b' data-ips></script>
<script type='text/javascript' src='https://forum.domain.co.nz/https://domain.co.nz/forum/uploads/javascript_core/global_global_core.js.4c4891bc3bda0cbbcd509f4b268e46e8.js?v=23e552198b' data-ips></script>
<script type='text/javascript' src='https://forum.domain.co.nz/https://domain.co.nz/forum/uploads/javascript_global/root_front.js.810eed89be2bf7f1743ae7a0f64943b9.js?v=23e552198b' data-ips></script>
<script type='text/javascript' src='https://forum.domain.co.nz/https://domain.co.nz/forum/uploads/javascript_gallery/front_front_browse.js.ebdea652cab94b8df58ecf5e19cf12c0.js?v=23e552198b' data-ips></script>
<script type='text/javascript' src='https://forum.domain.co.nz/https://domain.co.nz/forum/uploads/javascript_forums/front_front_forum.js.8452ca8a8ea8bf77a6a2152784bb7e3c.js?v=23e552198b' data-ips></script>
<script type='text/javascript' src='https://forum.domain.co.nz/https://domain.co.nz/forum/uploads/javascript_global/root_map.js.9c8443e2c89cb5cf90d8ebd4092a7c58.js?v=23e552198b' data-ips></script>

Somehow even though I've removed all reference to the old forum path that I can see, something in the 4 upgrade process is bringing it back in for the themes. I assume I need to rebuild the theme files, but I can't navigate the AdminCP because no CSS/JS is loading. The only documentation I can find on how to do that points to the "look and feel" section, which doesn't appear to be in 4 anyway.

So, with that failing I tried several different upgrade paths:

Upgrade Path 2

  1. Starting with my existing 3.1.4 and database on new server, with new URL, on stock theme, all working.
  2. Delete all files except Upload directory and config file.
  3. Upload fresh 4.0.7 files (Net effect is you only have 4.0.7 files, and files in Upload)
  4. Ran upgrade process.
  5. End result exactly the same as Upgrade Path 1

Upgrade Path 3

  1. Starting with my existing 3.1.4 and database on new server, with new URL, on stock theme, all working.
  2. Copy 3.4.8 files on top of 3.1.4 install.
  3. Run upgrade process.
  4. Had a lot of "keysize" errors resulting in needing to manually change some tables to utf-8 to get it to work, and manually drop or create some columns in order for the upgrade process to complete.
  5. 3.4.8 process completed successfully. Tested forum, no issues at all.
  6. Copied 4.0.7 files on top of 3.4.8
  7. Ran upgrade process
  8. Had 20-30 database issues that I had to continue in order to get the upgrade process to work correctly.
  9. Eventually finished. End result exactly the same as Upgrade Path 1

Upgrade Path 4

  1. Starting with my existing 3.1.4 and database on new server, with new URL, on stock theme, all working.
  2. Delete all files except Upload directory and config file.
  3. Upload fresh 3.4.8 files
  4. Ran upgrade process.
  5. Same database errors as Upgrade Path 3
  6. 3.4.8 process completed successfully. Tested forum, no issues at all.
  7. Deleted all files except Upload directory and config file
  8. Upload fresh 4.0.7 files
  9. Ran upgrade process
  10. Same database errors as Upgrade Path 3.
  11. Eventually finished. End result exactly the same as Upgrade Path 1

So, I'm out of ideas in terms of doing the upgrade process. To me there appears to be something either hard coded in the database, or some cached theme file in the Upload directory that's being read and rewritten incorrectly during the 4 upgrade process?

I have a support ticket logged but I'm just putting the feelers out to see if anyone else has had the same issues upgrading? Are there any other options in relation to the theme cache that I could disable before I run any of the upgrade process? In what database tables would theme data have hard coded URLs? Any information at this stage would be good information.

Link to comment
Share on other sites

Managed to resolve this, and it's quite logical the reasons why.

Around the time of this blog post, I ran the utf8 converter in anticipation of upgrading to IPB4. Something happened and that failed, I didn't worry about it as I figured I'd just cross that bridge when I needed too with IPB4.

What appears to have happened is the converter had made all of the temporary tables that were required as part of the utf8 process, and they were sitting dormant in the same sql database as the real tables. When the 4.0.7 process ran, it appears to have used those tables as the production ones, which obviously included the old url.

Once I removed those tables, and did the upgrade from 3.1.4, to 3.4.8, to 4.0.7, I'm now away laughing.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...