Jump to content
Announcing Achievements! ×

Community

Compatibility issue of the old versions of hooks,addons etc.


Dreamlander
 Share

Recommended Posts

Can you resolve in future versions of your products the compatibility issue of the old hooks and addons?

This is the main reason I don't want to upgrade to the latest version of the your products.

I have lots of hooks/modifications some purchased,others free.Some of the hooks are not being developed/updated anymore and this will be a huge lost in my board functionality, not mentioning skins.

So,instead of developing new versions maybe you can think first for a system that can support also old versions of hooks/addons etc.

Kind regards!

Edited by Dreamlander
Link to comment
Share on other sites

Can you resolve in future versions of your products the compatibility issue of the old hooks and addons?

This is the main reason I don't want to upgrade to the latest version of the your products.

I have lots of hooks/modifications some purchased,others free.Some of the hooks are not being developed/updated anymore and this will be a huge lost in my board functionality, not mentioning skins.

So,instead of developing new versions maybe you can think first for a system that can support also old versions of hooks/addons etc.

Kind regards!

​The framework for IPS Suite 4 is a complete re-write and there is no way of the old hooks working. Im not sure it would even be possible to marry the old framework with the new, the changes are simply too significant. If upgrading isn't an option due to the add ons/modifications etc it may be worth contacting the developers for their eta on versions compatible with suite 4. Certainly the ones I have contacted have been very helpful.

In terms of IF it is possible to match the old framework with the new, I wouldn't be holding your breath. I simply think its impossible to do.

Link to comment
Share on other sites

Hypothetical scenario question for you, based on that idea:

  1. 'Person A' buys IPB 3.4.8
  2. 'Person B' develops a paid hook for 3.4.8
  3. 'Person A' buys that hook and installs it.
  4. 'Person A' upgrades to 4.0.x and hook no longer works.
  5. 'Person A' uses that tool to convert the hook for use on 4.0.x
  6. Hook doesn't work, and 'Person A' gets irate and seeks support.
  7. 'Person B' advises that hook hasn't been upgraded for use on 4.0.x yet.

Who provides the support? IPB as the developer of the conversion tool, 'Person B' as the developer of the hook, or 'Person A' as the converter of the hook.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy