Jump to content

4.0 Contact Us form. Where to setup the email address?


estan
 Share

Recommended Posts

Two issues:

1. I already tried that. Changed "Incoming email address" to my email and it did not work. I tried with yahoo email and gmail. In both cases I do not get emails. Any suggestions?
Should I open a support request?

2. It says "This is provided to users on error screens and for certain notifications if enabled. " I definitely do not want my email to be shown on error screens though. This is exactly the reason why I use a contact form like this, to prevent spam  and not to make my email public:). Should I create a suggestion request for this?

Thoughts?

Link to comment
Share on other sites

It did not work? Are your "Advanced Settings" under email settings correct? Or check the email error logs to see if there's anything in there.

Well you could suggest adding a separate contact form incoming email address, but I think the address it not shown at all, at least on not found error pages.

Edited by -FP
Link to comment
Share on other sites

Yes, Advanced Settings are correct. It is the default setting there. Mail Delivery Method: PHP. 
Email error logs on the server? Or somewhere inside the Suite?

So, you are pretty sure the email is not shown anywhere? Can I fill more than one email?

Link to comment
Share on other sites

Well I haven't seen it shown anywhere, but I only use Pages and Forums.

Try switching to SMTP settings? Just for a test.

(Email error logs is also in email settings at the top of the page, but I think it's only for SMTP errors not PHP mail).

Edited by -FP
Link to comment
Share on other sites

Under Email Settings you have "Test Settings" .. anything there that works ?

​Yes, that worked for me. I tried with my yahoo email and it worked. I got the test email correctly.
When I fill my yahoo email for 
Incoming email address though and info is sent via the form, I do not get any email.

Well I haven't seen it shown anywhere on error pages, but I only use Pages and Forums.

Try switching to SMTP settings? Just for a test.

​I will rather send a support request. Spent plenty of time already testing and trying to figure out what the issue is.

Update: Support Request sent. Ticket id: 914110

Edited by estan
Link to comment
Share on other sites

Please check the email error log and let us know what is in there. You can do this by going to ACP ->  System -> Settings -> Email Settings -> Email Error Logs (button)

​Did it before submitting support request. It is emtpy :)

Link to comment
Share on other sites

So, with help of support and some extra testing I did, it turned out that for some reason email sending does not work when logged in with my admin account only. Was not able to reproduce with other accounts. Very weird issue.
The guys will investigate further.

Thanks everyone for contributing in this topic!

Link to comment
Share on other sites

  • 1 month later...

So, with help of support and some extra testing I did, it turned out that for some reason email sending does not work when logged in with my admin account only. Was not able to reproduce with other accounts. Very weird issue.
The guys will investigate further.

Thanks everyone for contributing in this topic!

I think that I'm experiencing the exact same issue ...

@estan     Did anything get figured out here?  Or was your only work-around option to create a different admin account?

 

Link to comment
Share on other sites

Well, since this is not so important for our community, I stopped following this is fixed or not. I have no interest in sending emails to myself via the contact form :)

As far as I know that the form is working for others. Feel free to open support request though in case this is important for your community.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...