Jump to content

Nginx config for IPB4

Recommended Posts

I'm having trouble getting IPB work on my digital ocean droplet. I'm curious if there are people who got it to work and what configs they used?

The problem I have is that I get a blank page before install even starts. It does redirect to the install page tho so that works. I am also able to die and dump strings in the index file so HHVM also works. I'm still figuring out where it's going wrong. I have a feeling it has to do with my url arguments. But i want some feedback.

This is what my config currently looks like:

server {
    listen       80;
    server_name  forums.animekyun.com www.forums.animekyun.com;
    root         /home/forge/forums.animekyun.com;
    # Basic web server configuration.
    index        index.php
    client_max_body_size  8M;
    access_log off;
    error_log  /var/log/nginx/forums.animekyun.com-error.log error;
    # GZIP static content not processed by IPB.
    gzip  on;
    gzip_static on;
    gzip_http_version 1.1;
    gzip_vary on;
    gzip_comp_level 3;
    gzip_proxied any;
    gzip_types text/plain text/css application/json application/x-javascript application/xml application/xml+rss text/javascript application/javascript text/x-js;
    gzip_buffers 16 8k;
    gzip_disable "MSIE [1-6].(?!.*SV1)";
    # Set up rewrite rules.
    location / {
        try_files  $uri $uri/ /index.php;
    location ~^(/page/).*(.php)$ {
        try_files  $uri $uri/ /index.php;
    # Caching directives for static files.
    location ~^(/uploads/profile/).*.(jpg|jpeg|gif|png)$ {
        access_log off;
        expires    1d;
    location ~* ^.+.(jpg|jpeg|gif|css|png|js|ico|xml|htm|txt|swf|cur)$ {
        access_log off;
        expires    1w;
    # Pass PHP scripts to php-fpm
    location ~ .php$ {
        fastcgi_index  index.php;
        fastcgi_buffers 16 8k;
        fastcgi_buffer_size 16k;
        fastcgi_param  SCRIPT_FILENAME  $document_root$fastcgi_script_name;
        include        /etc/nginx/fastcgi_params;


Link to comment
Share on other sites

This is where it goes wrong:

 * @brief		Installer bootstrap
 * @author		<a href='http://www.invisionpower.com'>Invision Power Services, Inc.</a>
 * @copyright	(c) 2001 - SVN_YYYY Invision Power Services, Inc.
 * @license		http://www.invisionpower.com/legal/standards/
 * @package		IPS Social Suite
 * @since		2 Apr 2013

require_once '../../init.php';

// starting from here I can't dump out anything.

I never dove into the framework of IPB so I will have to dig a bit deeper but until then this is all I have

Link to comment
Share on other sites

  • 1 month later...

Did you resolve this as i'm running on Digital Ocean droplet without problems, 

my setup is digital ocean droplet unbuntu 14.04 x64 (cheapest $5 a month)

and using Server pilot (free option) as my cpanel.

mandrill for email - All seems fine so far (free 12,000 emails a month)

Link to comment
Share on other sites

I also tried it, but i ran into the same and many other error's :(

This is one of it. HHVM is so special but many functions are ported to it. So i hope that it would be possible in the future to run IPB 4 with HHVM :)

\nNotice: Use of undefined constant ENT_DISALLOWED - assumed 'ENT_DISALLOWED' in /var/www/forum/htdocs/ips4/init.php on line 96
\nFatal error: Uncaught exception 'ErrorException' with message 'htmlspecialchars() expects parameter 2 to be integer, string given' in /var/www/forum/htdocs/ips4/system/Theme/Theme.php(639) : eval()'d code:296\nStack trace:\n#0 (): IPS\\IPS::errorHandler()\n#1 /var/www/forum/htdocs/ips4/system/Theme/Theme.php(639) : eval()'d code(296): htmlspecialchars()\n#2 /var/www/forum/htdocs/ips4/system/Helpers/Form/Form.php(131): IPS\\Theme\\class_core_global_forms->button()\n#3 /var/www/forum/htdocs/ips4/system/Login/Login.php(247): IPS\\Helpers\\_Form->__construct()\n#4 /var/www/forum/htdocs/ips4/applications/core/modules/admin/system/login.php(43): IPS\\_Login->forms()\n#5 /var/www/forum/htdocs/ips4/system/Dispatcher/Controller.php(94): IPS\\core\\modules\\admin\\system\\_login->manage()\n#6 /var/www/forum/htdocs/ips4/system/Dispatcher/Dispatcher.php(129): IPS\\Dispatcher\\_Controller->execute()\n#7 /var/www/forum/htdocs/ips4/admin/index.php(13): IPS\\_Dispatcher->run()\n#8 {main}
\nFatal error: Uncaught exception 'BadMethodCallException' with message 'Call to a member function fetch_fields() on a non-object (boolean)' in :\nStack trace:\n#0 /var/www/forum/htdocs/ips4/system/Db/Db.php(391): mysqli_stmt->store_result()\n#1 /var/www/forum/htdocs/ips4/system/Db/Db.php(622): IPS\\_Db->preparedQuery()\n#2 /var/www/forum/htdocs/ips4/system/Session/Admin.php(115): IPS\\_Db->replace()\n#3 (): IPS\\Session\\_Admin->write()\n#4 (): call_user_func()\n#5 (): __SystemLib\\SessionForwardingHandler->write()\n#6 (): session_write_close()\n#7 {main}
Finished singleJitRequest 4


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...