Jump to content

Community

Auto Welcome Support


Michael.J

Recommended Posts

New version released that patches quite a few issues new and existing, recommend immediate upgrade.

Edit: Although not specifically tested for, I believe SSO (Facebook/Twitter) accounts should now work also. If anyone who has regular social media signups can confirm this for me. I tested several different validation scenarios but also seeking feedback to how the newest version goes here.

Edited by Mike John
Link to comment
Share on other sites

12 hours ago, Mike John said:

New version released that patches quite a few issues new and existing, recommend immediate upgrade.

Edit: Although not specifically tested for, I believe SSO (Facebook/Twitter) accounts should now work also. If anyone who has regular social media signups can confirm this for me. I tested several different validation scenarios but also seeking feedback to how the newest version goes here.

Does this have a setting for Validating vs Approved?

Link to comment
Share on other sites

12 hours ago, Mike John said:

New version released that patches quite a few issues new and existing, recommend immediate upgrade.

Edit: Although not specifically tested for, I believe SSO (Facebook/Twitter) accounts should now work also. If anyone who has regular social media signups can confirm this for me. I tested several different validation scenarios but also seeking feedback to how the newest version goes here.

Does this have a setting for Validating vs Approved?

Link to comment
Share on other sites

3 hours ago, Michael R said:

Does this have a setting for Validating vs Approved?

Not a setting but in the case of "email and admin validation", it will wait until the account is approved by the admin before sending out the welcome alert.

3 hours ago, Square Wheels said:

Any chance you could update the new member display to be a mention style instead of a link?  It would be great if you could hover over the new member.

Good idea, I assume would just be needed in the topic alert?

Link to comment
Share on other sites

Upgraded this hook as now on 4.1.8 - it gives a php cron error so i have disabled it 

Exception:
RuntimeException Object
(
   [message:protected] => Only subclasses of Dispatcher can be instantiated
   [string:Exception:private] => 
   [code:protected] => 0
   [file:protected] => /home/******/public_html/****/system/Dispatcher/Dispatcher.php
   [line:protected] => 55
   [trace:Exception:private] => Array
       (
           [0] => Array
               (
                   [file] => /home/******/public_html/****/init.php(434) : eval()'d code
                   [line] => 19
                   [function] => i
                   [class] => IPS\_Dispatcher
                   [type] => ::
                   [args] => Array
                       (
                       )

               )

           [1] => Array
               (
                   [function] => save
                   [class] => IPS\autowelcome_hook_validatehook
                   [type] => ->
                   [args] => Array
                       (
                       )

               )

           [2] => Array
               (
                   [file] => /home/******/public_html/****/init.php(434) : eval()'d code
                   [line] => 44
                   [function] => call_user_func_array
                   [args] => Array
                       (
                           [0] => parent::save
                           [1] => Array
                               (
                               )

                       )

               )

           [3] => Array
               (

 

Link to comment
Share on other sites

10 minutes ago, Cloud 9 said:

Upgraded this hook as now on 4.1.8 - it gives a php cron error so i have disabled it 


Exception:
RuntimeException Object
(
   [message:protected] => Only subclasses of Dispatcher can be instantiated
   [string:Exception:private] => 
   [code:protected] => 0
   [file:protected] => /home/******/public_html/****/system/Dispatcher/Dispatcher.php
   [line:protected] => 55
   [trace:Exception:private] => Array
       (
           [0] => Array
               (
                   [file] => /home/******/public_html/****/init.php(434) : eval()'d code
                   [line] => 19
                   [function] => i
                   [class] => IPS\_Dispatcher
                   [type] => ::
                   [args] => Array
                       (
                       )

               )

           [1] => Array
               (
                   [function] => save
                   [class] => IPS\autowelcome_hook_validatehook
                   [type] => ->
                   [args] => Array
                       (
                       )

               )

           [2] => Array
               (
                   [file] => /home/******/public_html/****/init.php(434) : eval()'d code
                   [line] => 44
                   [function] => call_user_func_array
                   [args] => Array
                       (
                           [0] => parent::save
                           [1] => Array
                               (
                               )

                       )

               )

           [3] => Array
               (

 

You could try to reinstall te app. 

Link to comment
Share on other sites

18 minutes ago, Cloud 9 said:

So an upgrade breaks it but a re-install will be ok then ?

I am running two forums on 4.1.8 and Auto welcome is running fine, so maybe there's something went wrong during the upgrade.

A re-install can work to solve this problem, use the new auto welcome 2.4.8

Edited by R-023
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy