Jump to content

Community

Auto Welcome Support


Michael.J

Recommended Posts

In my case, i reinstall again the auto welcome app and I have configured just to send a PM to new registers in the name of the administrator of my forum. I have created a new users in my forum to test it and it works, they received the PM, but when I logg in with my admin account and I enter in my private messages I see no new conversations with these new registers.

I enter in the database and I have even seen that one new user reply to the autowelcome PM but I cannot see this conversation in my account. The user is a normal one, not comming from FB or TW. Thank you.

Link to comment
Share on other sites

When running it I'm getting this error:

Table 'smartest_ipb.core_members' doesn't exist

Try including your database prefix, you'll see it before your other database tables.

In my case, i reinstall again the auto welcome app and I have configured just to send a PM to new registers in the name of the administrator of my forum. I have created a new users in my forum to test it and it works, they received the PM, but when I logg in with my admin account and I enter in my private messages I see no new conversations with these new registers.

I enter in the database and I have even seen that one new user reply to the autowelcome PM but I cannot see this conversation in my account. The user is a normal one, not comming from FB or TW. Thank you.

What do you currently have set as your PM sender? Have you changed that since installing?

Link to comment
Share on other sites

As PM sender I have my username, the administrator name. In fact the new user receive correctly the autowelcome message as sent by the administrator account.

I have been checking the database right now and what I see is:

  • in table "core_message_topic_user_map" there is a row for the new register user but there is not a row for the administrator user (so for that reason I see now message in my account)
  • in table "core_message_topics" the rows for autowelcome has a "1" in the column "mt_is_system" (the other "normal" message has a "0" in this column)

As I said, before it works fine and I received the messages in my administrator account, but now the message is just show in the new menber account. This is not a big issue, in fact is better because now I don't have in my account houndreds of messages "Welcome to the forum!", but the real problem is sometimes the new users reply to the autowelcome message asking me something and I do not receive this reply because I cannot see the conversation.

I am still using version 4.0.11, could it be the reason of this problem?

Edited by Subzero-mb
Link to comment
Share on other sites

As I said, before it works fine and I received the messages in my administrator account, but now the message is just show in the new menber account. This is not a big issue, in fact is better because now I don't have in my account houndreds of messages "Welcome to the forum!", but the real problem is sometimes the new users reply to the autowelcome message asking me something and I do not receive this reply because I cannot see the conversation.

This was probably changed for that reason, not to clutter the sending members inbox. But if you do want to track the message from your inbox, I could put together a file edit to do this? At least until I've added maybe a setting for a future version.

Link to comment
Share on other sites

That wil be great Mike, I have like 4 or 5 register per day so it is not so much and I prefer to see if someone is asking me some doubts. If you can give me this file to make it works I would appreciate.

Sorry I didn't get a chance to test this but let me know if you have any issues.

Open applications/autowelcome/sources/Alerts/Alerts.php

Find:

//$conversation->authorize( $pmSender );

Replace With:

$conversation->authorize( $pmSender );

Save

On email template page, template name emailtpl_welcomeEmail is not translated.

Could you clarify a bit more please? There's no fixed text as the message is sources from settings which does have translation support.

Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...
On 15/9/2015 11:06:06, broni said:

Cool :)

I'm on it.

Does it include fix for people signing through Facebook?

I'm sorry, I don't know how the hell I missed this reply. No SSO support yet, I haven't heard anything back from IPS about this.

On 11/10/2015 8:27:22, Morrigan said:

Hey @Mike John Do you plan to re-add the ability to post a status to new members?

I didn't but I will log this and make sure it's included in one of the next versions.

Link to comment
Share on other sites

5 hours ago, Mike John said:

I've just checked and unfortunately it doesn't look like the "on group change" option is available in IPB4 like it was with IPB 3.4. You can't just edit this app to do send on group changes anymore.

That's a shame, thanks for trying Mike.

Link to comment
Share on other sites

23 hours ago, Daniel F said:

@Mike John couldn't you hook IPS\Member::save and run your code there if member_group_id or mgroup_others changed?

@Daniel F Yeah I was thinking of hooking into there instead in the future but before there was a "onGroupChange" function that made switching out from new registrations to group changes a simple file edit. Is IPS likely to re-add some of these IPB 3.4 functions again? That along with "onCompleteAccount" which I've posted about here are quite handy.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy