Jump to content

Community

Mike John

Auto Welcome Support

Recommended Posts

4 hours ago, Mike John said:

Can you confirm the above issue with social media registrations as well?

I don’t get any welcome posts for members signing up using Twitter or Facebook.

Sometimes when a member registers it double posts, but not all the time, there was a difference of around 6 minutes between posts. Maybe a tasks issue?

Share this post


Link to post
Share on other sites
4 hours ago, Mike John said:

What do you have set for user validation? Email/admin etc...? Do you have ftp access to your files and are willing to test a few modifications?

 

CiC user, no FTP access, but i would still test the mods if you can write it for upload new version tool in acp>applications 

 

It's driving me nuts, cause it's only twitter, Facebook that is doing this (Twitter being our most used way to sign up)

 

4 hours ago, Mike John said:

What do you have set for user validation? Email/admin

Email for validation 

 

 

The double posting is only happening with social media sign up (twitter, Facebook) For me

Share this post


Link to post
Share on other sites

Hi @Mike John

Suggestions for the future:

  • Time delay add minutes - Add minutes.  I want to add minutes because the average bounce rate is within X minutes, so it's important to tighten up the posting while the user is still actively engaged.
  • Time delay different for message - Please add separate time delays for Personal Message, Email, Topic, Status Update.  The reason is that Personal Message and Status Update are posted onto the website, so those messages should hit when user is on the site.  In contrast, email should be dripped after he leaves the website, so it should be delayed significantly.  (The worst thing you can do is send an email while the user is still on the site, which redirects his attention away to email) 
  • Tags - add a %account_settings% tag for a user's Account Settings to adjust his security and notification preferences.

Share this post


Link to post
Share on other sites
On 5/21/2019 at 4:55 PM, The Old Man said:

Is there any way to add blacklist or more specifically turn off autowelcome for the automatically generated IPS Support account?

I don't think I've used it before. I assume it's just creating the account for you and then your deleting once your done? Is it always the exact same username and email? (Perhaps just adding an exclusion for the email or exact username would be easiest then.)

On 5/21/2019 at 9:18 PM, Dean_ said:

Sometimes when a member registers it double posts, but not all the time, there was a difference of around 6 minutes between posts. Maybe a tasks issue?

Just to confirm. Are you using the time delay feature or instant registration?

On 6/10/2019 at 4:35 AM, Joel R said:

Suggestions for the future:

Thanks, all noted. I want to clear up these double/social media issues first but afterwards will be looking at new features again.

Share this post


Link to post
Share on other sites
11 hours ago, Mike John said:

Just to confirm. Are you using the time delay feature or instant registration?

It's set too;
Send immediately after validation.

Share this post


Link to post
Share on other sites
11 hours ago, Mike John said:

I don't think I've used it before. I assume it's just creating the account for you and then your deleting once your done? Is it always the exact same username and email? (Perhaps just adding an exclusion for the email or exact username would be easiest then.)

Yes it is always the same name and email address that gets created for use by IPS tech support. Thank you!

 

Share this post


Link to post
Share on other sites
On 6/12/2019 at 2:08 AM, Dean_ said:

Send immediately after validation.

If your available for testing this patch as well, I'll include you in the PM round when I'm ready.

On 6/12/2019 at 2:57 AM, The Old Man said:

Yes it is always the same name and email address that gets created for use by IPS tech support. Thank you!

What was the email address?

Share this post


Link to post
Share on other sites
5 hours ago, Mike John said:

What was the email address?

Hi @Mike John

Located in applications/core/modules/admin/support/support.php, line 828 onwards

Confirmed the email address (and user names) as:

$supportAccount = \IPS\Member::load( 'nobody@invisionpower.com', 'email' );

$name = 'IPS Temp Admin';

$name = "IPS Temp Admin {$number}";

 

Perhaps you could add a similar filter to your Birthday Greeter app as well?

Many thanks.

Share this post


Link to post
Share on other sites
16 hours ago, Mike John said:

If your available for testing this patch as well, I'll include you in the PM round when I'm ready.

What was the email address?

Always happy to test any app anytime Michael.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...