Jump to content

Community

Mike John

Auto Welcome Support

Recommended Posts

To put it simply, it welcomes newly registered members. It will welcome them with an optional personal message, email or topic alert. From there you can further customize each pm, email or topic message, the subject / title and so on. It also has the ability to welcome members that are added manually through the Admin CP.

Share this post


Link to post
Share on other sites

Unfortunately it won't send any email or pm to newly registered members.

​After you setup the auto welcome settings, can you try adding a member account within the admin cp and see if that works?

Share this post


Link to post
Share on other sites

it works when adding a member from the admin cp and it does work, if the email-validation for new members is turned on.

I actually turned off email-validation for new members, then the auto welcome email will not be sent.

Thank you for your help, it's a great feature.

Share this post


Link to post
Share on other sites

it works when adding a member from the admin cp and it does work, if the email-validation for new members is turned on.

I actually turned off email-validation for new members, then the auto welcome email will not be sent.

Thank you for your help, it's a great feature.

​I think I know what's causing this. I'll put together another update and have it released as soon as I can.

When I install it goes to a white page and stops. No damage done, just cannot complete installation.

​Usually indicated a masked php error of some sort. Is there any error_log file or record of the error I can look at?

This is a fresh install of the app or did you have the app in IPB 3.4?

Share this post


Link to post
Share on other sites

I tried to install this but can't find the settings to set it up? Sorry I'm new to IPB.

​there is an installation guide in the zip file ...

Share this post


Link to post
Share on other sites

​there is an installation guide in the zip file ...

​That takes you to a page where you can see how it's installed on IPB but doesn't show you how you get to the settings to edit the stuff.

Share this post


Link to post
Share on other sites

​That takes you to a page where you can see how it's installed on IPB but doesn't show you how you get to the settings to edit the stuff.

​try in admin-cp: users => Auto Welcome => settings

Share this post


Link to post
Share on other sites

​try in admin-cp: users => Auto Welcome => settings

​I am blind haha Thanks mate, I didn't think about scrolling down on the members bit. 

Share this post


Link to post
Share on other sites

​Usually indicated a masked php error of some sort. Is there any error_log file or record of the error I can look at?

This is a fresh install of the app or did you have the app in IPB 3.4?

​I just upgraded to 4 and installed I was using it on 3.4. This is a great must have add-on.

 

Thanks for the quick reply!

Share this post


Link to post
Share on other sites

​I just upgraded to 4 and installed I was using it on 3.4. This is a great must have add-on.

​Can you check installing any other application? I just want to check if it's a generalized issue with installing apps or this app in particular. I will probably need admin access to troubleshoot this further.

Share this post


Link to post
Share on other sites

Hi,

I just installed this app' on my test forum and it works :)
I choose the PM notification and I would like to have the popup notification and the 1 message badge notification
So the new member can't miss it

Is it possible ?

Like that:

newpm.thumb.jpg.9c865f7ef002348eb23dc35aHi,

Edited by Cybero

Share this post


Link to post
Share on other sites

I just tried to install your auto welcome mod for IPB4. But when I try to install the .tar file in the ACP I get this error message:

 Fatal error: Class 'PharData' not found in /home/polemiken/polemiken.se/applications/core/modules/admin/applications/applications.php on line 1168

Any idea why?

Thanks, and keep up the good work!

Share this post


Link to post
Share on other sites

I just tried to install your auto welcome mod for IPB4. But when I try to install the .tar file in the ACP I get this error message:

​Can you check with another application and if you get the same problem then it's likely an issue on your end. Make sure your hosts supports the phar extension. (IPB4 uses it now to install apps.)

Share this post


Link to post
Share on other sites

I've just released an update that fixes alerts being sent on email validation and no alerts being sent when email validation is disabled.

I choose the PM notification and I would like to have the popup notification and the 1 message badge notification

​I'm sorry but I just couldn't find a solution for this right now. When I run the alerts manually it works but doesn't when run during registration. When I've got a bit more time after the IPB4 updates, I'll revisit this and see if I can find a solution.

Share this post


Link to post
Share on other sites

I keep getting an error when trying to install it:

 

We could not parse the application.json file for this application because it is missing or corrupt. Please contact the author for an updated copy of this application.

Share this post


Link to post
Share on other sites

We could not parse the application.json file for this application because it is missing or corrupt. Please contact the author for an updated copy of this application.

​Can you check with any other 3rd party app and see if you've got the same issue? I've had a few reports of this but so far I'm leaning towards this being an IPB4/host issue rather then anything specific to apps I've built.

hello, i installed it but when a user sign in- he doesn't have the +1 in the pm.. is it suppose to be like that?

​As above, this was looked into but no immediate solution found. i will revisit once things settle down with IPB4 upgrades and I've got a bit more time to look into this.

Share this post


Link to post
Share on other sites

@Mike John I've installed other 3rd party mods perfectly fine... then again, they were hooks and not actual application files.

​The application install routine is a little different to plugins. There doesn't appear to be many free apps in the marketplace but I've got one called "Portal" that you can try.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...