Jump to content

Community

IPS Rules Application


Kevin Carwile

Recommended Posts

Hi

I set a rule to send out an email when a member is inactive for a set time.  The email was delivered and it was very nice but someone pointed out that I should by law always have a way for people to unsubscribe from any emails.   Is anything can be done about this please?

Link to comment
Share on other sites

7 hours ago, kar3n2 said:

Hi

I set a rule to send out an email when a member is inactive for a set time.  The email was delivered and it was very nice but someone pointed out that I should by law always have a way for people to unsubscribe from any emails.   Is anything can be done about this please?

You could check the member's email preference from their settings before sending them the email....

Create a condition in the rule that you send the email out. Choose "Custom PHP Code" as the condition type. Enter the following:

return $member->allow_admin_emails;

Of course, the $member variable may be different depending on the event you are using to send your email.

Link to comment
Share on other sites

32 minutes ago, Kevin Carwile said:

You could check the member's email preference from their settings before sending them the email....

Create a condition in the rule that you send the email out. Choose "Custom PHP Code" as the condition type. Enter the following:


return $member->allow_admin_emails;

Of course, the $member variable may be different depending on the event you are using to send your email.

I did that and there is a little bit of code already there.... is this ok?

56608f7c709dc_addingphpcode.thumb.jpg.00

 

and just to add one more thing ( assuming the above is correct) it wont let me edit the email message ( it is just coloured in blue) and I cannot see  the original message or add any html etc

Edited by kar3n2
added a bit more
Link to comment
Share on other sites

Hi there.  I've already purchased Rules, the full version, and I'm trying to do something that seems like it should be simple, but it's just not working.  I could go into what I tried that didn't work, but I think it would be faster just to describe what I'd like to do and have you tell me how, hopefully? :)

After users register for my board and validate their email address, they're in one group that requires content approval.  After one item of content is approved, they are moved to another Approved group that gets more privileges.  That's all working just fine, but I did that via the Groups settings.

I'd just like to send another email telling the user they are now in the Approved group after that happens.  And, it's not a problem with sending email in general, other emails are going out, but not that one.  I tried with a few different email addresses, registration emails coming through, but nothing after that.

Help? :)

Link to comment
Share on other sites

29 minutes ago, Kevin Carwile said:

@raincat

I will help you in the new support forum linked from the product page in the marketplace. Please post your request there.

http://ipsguru.net/rules/support

Thank you.

I get it.... you are creating a rules cookbook  http://ipsguru.net/documentation/rules/cookbook/ based on what people ask you. That's really cool @Kevin Carwile     the support forum on here is getting hard to follow...  ( for me that is) ...   

Edited by kar3n2
Link to comment
Share on other sites

  • 4 weeks later...
3 hours ago, EmpireKickAss said:

I'm getting allot of errors with rules after the update to 41.4.5

4.1.6 appears to be the current release.

------------------------------------------------------------

I wanted to make a rule that basically did this:

  • When: a post is deleted.
  • What: recount that member's posts.

I can seemingly do the first, but not the latter. Any ideas?

 

 

P.S. What's the process to upgrade from Lite to Pro? How easy is it? Do you have to reset anything? Do you lose any of your existing Rules?

Link to comment
Share on other sites

  • 2 weeks later...
9 hours ago, Kjell Iver Johansen said:

The Rules aplication stopped working and moved 17000 members from one membergroup to another.

I notice that there is a new version now on the 10 of january and will try with that one. The version before was called 1.3.9, and the new version from 10 january is also 1.3.9.

Rules broke on the 4.1.6 core update, yes. The newest version fixes that. However, that would not cause rules to do anything that it was not already configured to do. Which rule moved your members? It may need some tweaks.

Link to comment
Share on other sites

37 minutes ago, Kevin Carwile said:

Rules broke on the 4.1.6 core update, yes. The newest version fixes that. However, that would not cause rules to do anything that it was not already configured to do. Which rule moved your members? It may need some tweaks.

I have rules I downloaded from your site that moves a member from Member to Inactive after a set period of time. Now all those Inactive Members was moved to Active members group. 

I have another admin that do all the work with Rules on my site - I can get him to explain further if needed.

Link to comment
Share on other sites

2 hours ago, vinegredz said:

I have a series of lessons within the databases in IPContent, and I need to restrict access to the records. The user starts to watch the first lesson, but can't watch the second and third until the first. How to make it work with this app?

Easiest way I can think of is to create progressive member groups with access to the appropriate lessons and add those secondary groups as appropriate. The question is... what event represents them completing the lesson. 

One way I can think of is to create a a questionare using the forms app by @Mike John and grant the next lesson group upon submission of a passing result.

Edited by Kevin Carwile
Link to comment
Share on other sites

@Kevin Carwile I just updated to the most recent release and have the following appear.


------------------------------------------------------------------------
Sat, 30 Jan 2016 12:11:33 +0000 (Severity: 2)
82.20.117.153 - http://www.callofdutyzombies.com/topic/181904-tank-isnt-his-first-name-so-what-is/
UnderflowException
0: lang_not_exists__rules_Content_event_content_created_
#0 /home/user/public_html/applications/rules/extensions/rules/Definitions/Content.php(354): IPS\_Lang->get('rules_Content_e...')
#1 /home/user/public_html/applications/rules/extensions/rules/Definitions/Content.php(255): IPS\rules\extensions\rules\Definitions\_Content->buildEvent(Array, 'content_created', Array)
#2 /home/user/public_html/applications/rules/extensions/rules/Definitions/Content.php(222): IPS\rules\extensions\rules\Definitions\_Content->buildEvents(Array, 'IPS\\core\\Status...', 'Status', 'Content: System', Array)
#3 /home/user/public_html/applications/rules/sources/Event/Event.php(124): IPS\rules\extensions\rules\Definitions\_Content->events()
#4 /home/user/public_html/applications/rules/sources/Event/Event.php(81): IPS\rules\_Event->__construct('rules', 'Content', 'content_updated')
#5 /home/user/public_html/init.php(434) : eval()'d code(176): IPS\rules\_Event::load('rules', 'Content', 'content_updated')
#6 /home/user/public_html/system/Content/Comment.php(171): IPS\rules_hook_ipsContent->save()
#7 [internal function]: IPS\Content\_Comment::create(Object(IPS\forums\Topic), '\n<blockquote cl...', false, NULL, NULL, NULL, NULL, NULL, NULL)
#8 /home/user/public_html/applications/forums/sources/Topic/Post.php(132): call_user_func_array('parent::create', Array)
#9 /home/user/public_html/init.php(434) : eval()'d code(21): IPS\forums\Topic\_Post::create(Object(IPS\forums\Topic), '\n<blockquote cl...', false, NULL, NULL, NULL, NULL, NULL, NULL)
#10 /home/user/public_html/system/Content/Item.php(3291): IPS\forums\Topic\cms_hook_Post::create(Object(IPS\forums\Topic), '\n<blockquote cl...', false, NULL)
#11 /home/user/public_html/system/Content/Item.php(3148): IPS\Content\_Item->processCommentForm(Array)
#12 /home/user/public_html/system/Theme/Theme.php(692) : eval()'d code(3155): IPS\Content\_Item->commentForm()
#13 [internal function]: IPS\Theme\class_forums_front_topics->topic(Object(IPS\forums\Topic), Array, NULL, Array, NULL, NULL, Array)
#14 /home/user/public_html/system/Theme/SandboxedTemplate.php(57): call_user_func_array(Array, Array)
#15 /home/user/public_html/applications/forums/modules/front/forums/topic.php(262): IPS\Theme\_SandboxedTemplate->__call('topic', Array)
#16 /home/user/public_html/applications/forums/modules/front/forums/topic.php(262): IPS\Theme\SandboxedTemplate->topic(Object(IPS\forums\Topic), Array, NULL, Array, NULL, NULL, Array)
#17 /home/user/public_html/system/Dispatcher/Controller.php(94): IPS\forums\modules\front\forums\_topic->manage()
#18 /home/user/public_html/system/Content/Controller.php(46): IPS\Dispatcher\_Controller->execute()
#19 /home/user/public_html/applications/forums/modules/front/forums/topic.php(40): IPS\Content\_Controller->execute()
#20 /home/user/public_html/system/Dispatcher/Dispatcher.php(129): IPS\forums\modules\front\forums\_topic->execute()
#21 /home/user/public_html/index.php(13): IPS\_Dispatcher->run()
#22 {main}
------------------------------------------------------------------------

If I access rules logs

EX0 Something went wrong. Please try again.

If I access manage rules and then select main category and expand I get the same.

EX0 Something went wrong. Please try again.

 

Link to comment
Share on other sites

Hey, so I have a rule setup so that members get a notification once their topic has been moved, which works great. However I want it to that they DON'T get a notification if it's in a certain forum.

I have this setup, but it's not working... I've tried putting * as a wildcard into the item name, as I want all topics, but It's not working.

 

edac423d85e28642649aea96a8d23b4b.png
https://gyazo.com/edac423d85e28642649aea96a8d23b4b

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy