Jump to content

Featured Content for IPS4.x+


onlyME

Recommended Posts

1 hour ago, Christforums said:

I'm a little confused. If there is no image in the topic shouldn't the slider be using the default image I uploaded?:

1426274173_defaultimage.thumb.jpg.9038fb17e0de14b246e0ac8b15050649.jpg

 

Yes, if topic has no image, the default image will be used. If you don't want the no-image topic, enable 'Ignore items if no image'

Link to comment
Share on other sites

  • 1 month later...
1 hour ago, sobrenome said:

Bug on slider CSS after the upgrade to the last version: https://fisiculturismo.com.br

The CSS have a 937px as padding-bottom that makes the image to ugly stretch.

Try REVERT all templates and css of Featured Content, and then run Get Support to clear cache. If it still doesn't work, give me acp access so I can test it.

Edited by onlyME
Link to comment
Share on other sites

  • 2 weeks later...

Bug report

If you use popup option and the download has more than 1 image, it breaks the popup.

I can pm screenshot if required

Also I have noticed when enabled it has an impact on page speed load.

Is there any recommendations on a configuration that enables it to load as fast as possible if it is picking content from a large content base.

Thanks

Link to comment
Share on other sites

16 hours ago, Unlucky said:

Hi,

Re this - Auto get contents from IPS applications: Pages, Forums, Gallery, Downloads, Clubs.

Where is the setting to get content from clubs and what image is used?

Thanks

In Categories selection http://prntscr.com/kqfqsk

13 minutes ago, Unlucky said:

Bug report

If you use popup option and the download has more than 1 image, it breaks the popup.

I can pm screenshot if required

Also I have noticed when enabled it has an impact on page speed load.

Is there any recommendations on a configuration that enables it to load as fast as possible if it is picking content from a large content base.

Thanks

Do you mean IP.Downloads images?

Enable this option doesn't have any effect to page speed because there are no more contents are loaded until you click on the link.

Link to comment
Share on other sites

  • 1 month later...

Would it be possible that you could move the JS and CSS Input code from the Hook to the Widget init() please?

Quote

 

        if ( !\IPS\Request::i()->isAjax() )
        {
            \IPS\Output::i()->jsFiles = array_merge( \IPS\Output::i()->jsFiles, \IPS\Output::i()->js( 'fc43.js', 'featuredcontent', 'interface' ) );
            \IPS\Output::i()->jsFiles = array_merge( \IPS\Output::i()->jsFiles, \IPS\Output::i()->js( 'jquery.easing.min.js', 'featuredcontent', 'interface' ) );
        }

        if ( !\IPS\Request::i()->isAjax() )
        {
            \IPS\Output::i()->cssFiles = array_merge( \IPS\Output::i()->cssFiles, \IPS\Theme::i()->css( 'slider.css', 'featuredcontent', 'front' ) );
        }

 

The current method means that the JavaScript code and CSS styles get loaded each time regardless if there are Featured Blocks on the page or not.

Thanks 🙂

Link to comment
Share on other sites

1 minute ago, TDBF said:

Would it be possible that you could move the JS and CSS Input code from the Hook to the Widget init() please?

The current method means that the JavaScript code and CSS styles get loaded each time regardless if there are Featured Blocks on the page or not.

Thanks 🙂

I will consider it.

Link to comment
Share on other sites

  • 1 month later...

Hi, another question. I would like to place the featured content between header and body layer (just above <main id='ipsLayout_body' class='ipsLayout_container'>). I edit the globalTemplate and add {fcontent="1"} at the place where featured content should be. Saved and then if I look on the site I see literally {fcontent="1"} there and not the slider. I thought it were a kind of template tag :unsure:

Link to comment
Share on other sites

8 minutes ago, Sonya* said:

Hi, another question. I would like to place the featured content between header and body layer (just above <main id='ipsLayout_body' class='ipsLayout_container'>). I edit the globalTemplate and add {fcontent="1"} at the place where featured content should be. Saved and then if I look on the site I see literally {fcontent="1"} there and not the slider. I thought it were a kind of template tag :unsure:

Bug, it will be fixed asap.

Link to comment
Share on other sites

  • 2 weeks later...

Hello,

Just purchased this app - looks very promising! 🙂

However, I'm a bit confused about some things.  I created a test slider and want to add all of its content manually.  I created it in the Slider Manager and configured it in the General, Slider, and Contents tabs.  I then tried to add it through the Block Manager, where I can configure the slider, where to show it, specific pages to show the slider on, etc.  But am I missing something really obvious?  If I don't want to add content from my board apps for this slider, exactly how to I manually add the content to this slider?  I can't seem to find a place to add links (YouTube) or specific URLs, etc.

PS I have allow_url_fopen enabled on my VPS.

Thanks!

Edited by liquidfractal
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...