Jump to content

Community

Featured Content for IPS4.x+


onlyME

Recommended Posts

4 hours ago, misfit76 said:

Installed the Plugin, It works great with Images and Articles, but seem to have a problem with forums

http://www.bmw2002faq.com/articles.html/faq-use/

At the bottom "Recent Classifieds"  The slider is there, but there are no images.

thanks for the help

steve k.

This is an issue of Topic Thumbnail, can you give me ACP access?

 

2 hours ago, Neej said:

It get images from Topic Thumbnail. :) 

Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...

Have been testing it and it is easy to use, for the most part. As usual, good work from @onlyME. :D

I have one area that I am struggling with -- resizing.

Without the "On-the-fly Image Resizing URL" there is no way for the images to resize, which means that images of different sizes to the dimensions set in the slider manager are stretched and don't look good. I need to make sure that I am correct with this observation?

Assuming I am correct, can you use "On-the-fly Image Resizing URL" with IPS cloud hosting? If so, can anybody point me to help with setting up something like Cimage or phpThumb, or any such service? Those services don't look as if they are simple to use.

Link to comment
Share on other sites

1 hour ago, Simon Woods said:

Have been testing it and it is easy to use, for the most part. As usual, good work from @onlyME. :D

I have one area that I am struggling with -- resizing.

Without the "On-the-fly Image Resizing URL" there is no way for the images to resize, which means that images of different sizes to the dimensions set in the slider manager are stretched and don't look good. I need to make sure that I am correct with this observation?

Assuming I am correct, can you use "On-the-fly Image Resizing URL" with IPS cloud hosting? If so, can anybody point me to help with setting up something like Cimage or phpThumb, or any such service? Those services don't look as if they are simple to use.

IPS cloud hosting does not support FTP so you can not upload cimage or phpThumb. You can setup cimage on other hosting. Try to download cimage

https://invisionpower.com/applications/core/interface/file/attachment.php?id=71715

After uploading to hosting, go to Fcontent setting and setup the url, eg

http://yourdomain/cimage /webroot/img.php?src={url}&w={width}&h={height}&cf&q=90

 

Link to comment
Share on other sites

On 3/9/2015 at 1:53 PM, onlyME said:

fcontent1.png.b5e5fd9748dd01a08982e6fcea3905e0.thumb.png.900075742389ef4317551bc221975355.png

Featured Content  for IPS4.x+

This is Featured Content for IPS 4.0. With this app, you can easy create beautiful sliders for your site:

  • Create multi sliders, fully responsive - will adapt to any device.
  • Flexible customization: horizontal/vertical layout, random mode, autoplay, speed, duration, button,...
  • Auto get contents from: Pages, Forums and RSS url
  • Easy to add a content to a slider, drag & drop to sort the contents.
  • The sliders was added as widgets, easy to drag and place them to your site.

Live Demo: http://zuzu.vn/page/featuredcontent4/

Marketplace: http://community.invisionpower.com/files/file/7290-bim40-featured-content/

the live demo do not show anything all it do is try to sell something

 

Link to comment
Share on other sites

On 10/12/2016 at 10:43 PM, onlyME said:

IPS cloud hosting does not support FTP so you can not upload cimage or phpThumb. You can setup cimage on other hosting. Try to download cimage

https://invisionpower.com/applications/core/interface/file/attachment.php?id=71715

After uploading to hosting, go to Fcontent setting and setup the url, eg


http://yourdomain/cimage /webroot/img.php?src={url}&w={width}&h={height}&cf&q=90

 

Thanks! These instructions are great!

Unfortunately it is displaying the images as broken. I ran check_system and everything is fine with cimage.

An example of an image not displaying is with this url: 

http://chroniclesofthedas.com/cimage/webroot/img.php?src=http://revolutions.chroniclesofthedas.com/uploads/monthly_2016_10/medium.580a8db7e4a05_anndr(47).jpg.dc8c9a7368ce8ece8655c899dd1b009d.jpg&w=310&h=220&cf&q=90

 

Link to comment
Share on other sites

2 hours ago, Simon Woods said:

Thanks! These instructions are great!

Unfortunately it is displaying the images as broken. I ran check_system and everything is fine with cimage.

An example of an image not displaying is with this url: 


http://chroniclesofthedas.com/cimage/webroot/img.php?src=http://revolutions.chroniclesofthedas.com/uploads/monthly_2016_10/medium.580a8db7e4a05_anndr(47).jpg.dc8c9a7368ce8ece8655c899dd1b009d.jpg&w=310&h=220&cf&q=90

I'm not sure the problem your cimage can not work with src parameter in url. But wait for the next version, I'm working for a better image cache that you don't need to use external php script.

Link to comment
Share on other sites

HI, I've just purchased this but cant figure out how to use it, some of the screens on your screenshots Im not sure how to get to? The edit/add content ones specifically. I have the application installed, but in Customization in the featured content section we only have Settings and Slide Manager, and from the Slide Manager i see now way to actually add slides, or upload images, thanks.

Link to comment
Share on other sites

6 minutes ago, OblivionNW said:

HI, I've just purchased this but cant figure out how to use it, some of the screens on your screenshots Im not sure how to get to? The edit/add content ones specifically. I have the application installed, but in Customization in the featured content section we only have Settings and Slide Manager, and from the Slide Manager i see now way to actually add slides, or upload images, thanks.

You need to go settings to turn it on first. After that, go to slider manage and create a new slider. In front site, click the float button on the left to open Block Manager, you will see Featured content widget, drag and and place the widget, then select the slidet that you created.

Link to comment
Share on other sites

Could you give some quick direction on where Id go to add another field to the form, I want to add a 'description' .. I've already migrated the database with a new column, im not new with invision and its templating engine and structure, im not where where id go to add another field to this dialog for a 'description field' ..

Link to comment
Share on other sites

1 minute ago, OblivionNW said:

Could you give some quick direction on where Id go to add another field to the form, I want to add a 'description' .. I've already migrated the database with a new column, im not new with invision and its templating engine and structure, im not where where id go to add another field to this dialog for a 'description field' ..

I don't understand, do you want to edit slider manually or getting contents automatically from other apps?

Link to comment
Share on other sites

Ok I got it. If you want to add new form, you need to read this post for Form Helper

And the code you need in \applications\featuredcontent\modules\front\slider\view.php

	protected function manageSlider()
    {	
		.....
		$form = new \IPS\Helpers\Form;
		$form->class = 'ipsPad ipsForm_vertical';
		.....
		if ( $values = $form->values() )
		{
			....
		}
	}

You also need to edit applications\featuredcontent\sources\Slider\Slider.php to return an array with your new db column before adding it to template.

protected function fromCustom()
{
	....
}

 

Link to comment
Share on other sites

Just now, OblivionNW said:

@onlyME Thanks so much! its working perfectly, the only thing I havent got working now is the form label. it still just says fcc_description (my new db column). The data is persisting and all that is working, just the label I dont know where to define it.. I added a line to the lang file but that didnt seem to help

 

 

Try this code

\IPS\Member::loggedIn()->language()->words['fcc_description'] = "Description";

 

Link to comment
Share on other sites

I will try but Im more interested in understanding where/how its pulling yours in? are the labels being passed into the constructors for the Helper classes on the form?

$form->add( new \IPS\Helpers\Form\Text( 'fcc_title', $item ? $item['fcc_title'] : NULL, FALSE, array(), NULL, NULL, NULL, 'fcc_title' ) );
$form->add( new \IPS\Helpers\Form\Text( 'fcc_title', $item ? $item['fcc_title'] : NULL, FALSE, array(), NULL, NULL, NULL, 'fcc_title' ) );

for example

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy