Jump to content

A lot of bugs in Internet Explorer browser


eden buganim
 Share

Recommended Posts

EVERYTHING we wrote in hebrew (forums names, display names ect), while browsing with IE, doesn't work. cant 'mark as read' furoms with hebrew names, cant watch mini-profile of a member with a hebrew display name, cant like this member status and so on.. in chrome everything (ofcourse!) is ok,  screenshots:
1. http://www.animes.co.il/test/uploads/monthly_2015_02/%D7%91%D7%90%D7%921.thumb.png.bde42e498a58892c6011261136bff90f.png
2. http://www.animes.co.il/test/uploads/monthly_2015_02/%D7%91%D7%90%D7%92_%D7%91%D7%9C%D7%99%D7%99%D7%A7.thumb.png.3b70d391b550b36a601f9678da4ddd1a.png

3. http://www.animes.co.il/test/uploads/monthly_2015_02/%D7%91%D7%90%D7%92_3.thumb.png.e9bbdcb0dfb7baa08ea8eab30af19ac7.png

4 - http://imgur.com/WZjITMs - when trying the "see other activities" option

5 - http://imgur.com/jQhse40 - when trying to edit a profile

6 - http://i.imgur.com/xYUR6Q9.png - when trying to 'mark a forum as read'

7.

When I try to respond the button "submit reply" loaded but nothing happens, And it also presents the Board in response.

This of course happen only in a IE browser - http://community.invisionpower.com/uploads/monthly_2015_02/ie.thumb.png.3849f2ec9793db71b5d579628883ebcb.png

Link to comment
Share on other sites

I tried different pages and links on your forum and everything was OK with my IE. Just as an experiment try to use other laptop and other internet connection.

I checked with my stuff and they have the same problem[in IE].

i try with my Desktop computer and with my laptop - same problem...

Link to comment
Share on other sites

HI Eden,

I primarily use IE11, I haven't seen any issues with it and IPS4.

What version of Internet Explorer are you using?

I too you use IE 11 as my primary browser but when I go to like posts I always get this error 95 percent of the time(It happens on 3.X). Sometimes I can like a post and then other times I can't. But if I refresh it usually shows up as liked despite giving me that error.

 

Note: I did the compatibility fix for IE 11 that IPS released awhile back and that fixed it on 3.x for me but I still notice it on IPB4 with IE
 

Link to comment
Share on other sites

Hello to IPS team,
We opened several problems regarding the IE-hebrew issue -

http://community.invisionpower.com/4bugtrack/rc3-ie-problem-with-hebrew-r3607/


and 1 week ago we were able to solve one of them, and we think the solution can solve the rest of them too. The problem is that when the user username is in Hebrew, you cannott see his mini-profile.

We notice the follow: When you enter to that user profile and copy the URL, the hebrew part stays the same in IE, while in chrome it encodes to ASCII.

For example, if we enter to the user מיכאל profile, if we copy the URL in IE we get that:

http://www.animes.co.il/test/index.php?/profile/4-%D7%9E%D7%99%D7%9B%D7%90%D7%9C/

But if we copy the url while we use chrome, we get that:

http://www.animes.co.il/test/index.php?/profile/4-מיכאל/

So we tried to encode to ASCII in the php itself to beginwith, and the problem was solved. We changed this file:

uploads/javascript_global/root_framework.js.4a67a2b829c33cbd24aa9cb3ae0c12e2.js

In that part:

ajaxObj=ips.getAjax()(encodeURI(target)).done(function(response){content=response;deferred.resolve();if(options.cache){ips.ui.hovercard.setCache(target,content);}}).fail(function(jqXHR,status,errorThrown){if(Debug.isEnabled()){if(status!='abort'){Debug.error("Ajax request failed ("+status+"): "+errorThrown);}else{Debug.warn("Ajax request aborted");}

we changed this:
 

ajaxObj=ips.getAjax()(target)


to this:
 

ajaxObj=ips.getAjax()(encodeURI(target))

And it worked. We hope it can help you solve the other problems. Thank you.

help us,
 

Link to comment
Share on other sites

Isn t Internet Explorer a bug by itself? This browser has been slowing down the expansion and progression of technology on the web since v 1.0

I just hope it would have died already but like a nasty STD it keeps going and going...

 

 Almost there. IE should be completely gone by 2020:

browser.thumb.png.65691701dc9d46b59e3ac8

Soon, my friend. Soon.

Link to comment
Share on other sites

Isn t Internet Explorer a bug by itself? This browser has been slowing down the expansion and progression of technology on the web since v 1.0

I just hope it would have died already but like a nasty STD it keeps going and going...

 Almost there. IE should be completely gone by 2020:

browser.thumb.png.65691701dc9d46b59e3ac8

Soon, my friend. Soon.

​LOL I always laugh when I see someone negative about IE 11 as there is nothing wrong with it and works great(Especially for those of us on touch laptops/tablets) :D Most people haven't even actually used it. Though I am looking forward to Spartan Browser with WIndows 10.

Besides I'd love to know what stats you're looking at because from what I can see.....

https://www.netmarketshare.com/browser-market-share.aspx?qprid=2&qpcustomd=0

http://www.neowin.net/news/internet-explorer-still-the-most-popular-browser-ie8-dominates

some news ips team? :|

​I think for me the only bugs I have are

1. Unable to always like a post

2. The mentions feature doesn't play well

Link to comment
Share on other sites

  • 2 weeks later...

line  :

<meta http-equiv=['\"]X-UA-Compatible['\"] content=['\"]IE=edge['\"] />

replace 

<meta http-equiv="X-UA-Compatible" content="IE=<if test="strpos($this->member->user_agent, 'Trident/7')!== FALSE">EmulateIE10<else />edge</if>" />

Or

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE10"/> 

 

   skin global template

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...