Jump to content

Admin login failure: Bug or config/upgrade problem ?


SeaTea
 Share

Recommended Posts

I have done a test-upgrade from 3.4.7 to  4RC2 and upgraded later to RC3 on a centminmod  Centos server with nginx and it worked normally for a while, but sometimes after I logged in to the admin panel I had no css, so only text in the browser, with an error message.  After a page refresh the normal admin screens appeared.  But on the moment I only see the 'text' version of the admin-screen and no further commands are accepted.  The user-website works fine, even when I login as admin, but as soon I choose AdminCP I have this error.

AdminCP opens the following url: 

http://mytestserver.com/admin/?adsess=bkdl0o16d53rdj8k33v21tefn2&#content

And the text version opens.  At that moment there is an error message in the php-fpm error log: 

[27-Feb-2015 19:15:04 UTC] PHP Fatal error:  Access to undeclared static property: IPS\_Db::$multitons in /home/nginx/domains/mytestserver.com/public/system/Db/Db.php on line 98

 

I could just re-import the database and redo the conversion from 3.4.7 but I like to know if this is a known issue just in case I will end up here again during the conversion of my live-site in a couple of weeks/months....

Link to comment
Share on other sites

I have done a test-upgrade from 3.4.7 to  4RC2 and upgraded later to RC3 on a centminmod  Centos server with nginx and it worked normally for a while, but sometimes after I logged in to the admin panel I had no css, so only text in the browser, with an error message.  After a page refresh the normal admin screens appeared.  But on the moment I only see the 'text' version of the admin-screen and no further commands are accepted.  The user-website works fine, even when I login as admin, but as soon I choose AdminCP I have this error.

AdminCP opens the following url: 

http://mytestserver.com/admin/?adsess=bkdl0o16d53rdj8k33v21tefn2&#content

And the text version opens.  At that moment there is an error message in the php-fpm error log: 

[27-Feb-2015 19:15:04 UTC] PHP Fatal error:  Access to undeclared static property: IPS\_Db::$multitons in /home/nginx/domains/mytestserver.com/public/system/Db/Db.php on line 98

 

I could just re-import the database and redo the conversion from 3.4.7 but I like to know if this is a known issue just in case I will end up here again during the conversion of my live-site in a couple of weeks/months....

​could be wrong but might best submit ticket if test site not local host ! or use bug tracker.

Link to comment
Share on other sites

  • 2 weeks later...

For readers with the same problem:

It took some time, but IPS support found the reason:  the default setting in centmin mod php-fpm "session.serialize_handler=igbinary" seems to be not compatible with IPS4. Changing this to "session.serialize_handler=php" solved it.  This setting is in /etc/centminmod/php.d/igbinary.ini

Link to comment
Share on other sites

  • 2 weeks later...

IPS has also solved the issue so igbinary can be used, When you change some database tables it will work with igbinary 'on' too. You need to make the core_sessions.data and the core_sys_cp_sessions.session_app_data columns BLOB rather than TEXT.  This will be done automatically in the next release according IPS support.  I do not know in what version it will be fixed.  RC5 did not have the change yet. Otherwise just change the database columns manually.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...