Jump to content

Community

Burning Loveee!!

Friendly url work good?

Recommended Posts

The reason is, that you can only have one root app for your IPS community suite and all other apps will get an app specific slug.

If you set your forum to be the root app it will be under / and your gallery will be under /gallery. If you set your gallery as root it will be under / and your forum will be under /forum.

At least that’s how I understood it and I think it makes sense. I haven’t tested myself yet. 

Share this post


Link to post
Share on other sites

This is not an IPS related issue forcing this, but an .htaccess issue for one and/or server settings for another. The .htaccess example I will show here, Server settings at a later time if needed.

1st, Your .htaccess example: has an issue.

<IfModule mod_rewrite.c>
Options -MultiViews
RewriteEngine On
RewriteBase /forum/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule \.(jpeg|jpg|gif|png)$ /forum/public/404.php [NC,L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /forum/index.php [L]
</IfModule>

Here you are pointing to "forum" twice.

The first in line 4 RewriteBase/forum/ (which is correct)

The 2nd in line 10 RewriteRule ./forum/index.php[L] (This is where you are getting the 2nd forum from)

Where you can use this example:

<IfModule mod_rewrite.c>
Options -MultiViews
RewriteEngine On
RewriteBase /forum/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule \.(jpeg|jpg|gif|png)$ /forum/public/404.php [NC,L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

This example will eliminate the 2nd forum issue.

As a precaution I would save your original to a clipboard just in case it turns out to be a server setting issue.

Share this post


Link to post
Share on other sites

The reason is, that you can only have one root app for your IPS community suite and all other apps will get an app specific slug.

If you set your forum to be the root app it will be under / and your gallery will be under /gallery. If you set your gallery as root it will be under / and your forum will be under /forum.

At least that’s how I understood it and I think it makes sense. I haven’t tested myself yet. 

IPS dev think same as you =))

I tested on localhost, with clean setup, that annoying /forum aspear too.

This is default link, look sux:

  • Category: http://localhost/ips/index.php?/forum/1-a-test-category/
  • Box/post: http://localhost/ips/index.php/forum/2-a-test-forum/

This is link with friend link ON: nothing change, same as above.

This is link with friend link ON and Use .htaccess mod_rewrite ON

  • http://localhost/ips/forum/1-a-test-category/
  • http://localhost/ips/forum/2-a-test-forum/

I dont known about coding, but as a client, i dont want to see that /forum every pages. I think we need a way for disable that.

My forum link is terible now: http://myforum.com/forum/forum/category/ <-- like this.

 

@Woodsman i tested, didn't work, /forum/forum still here.

 

Share this post


Link to post
Share on other sites

@Woodsman i tested, didn't work, /forum/forum still here.

Give this one a try. I think it will work better for you.

This should fix the double forum issue as well as hiding the index.php? from human view.

<IfModule mod_rewrite.c>
 Options -MultiViews
 RewriteEngine On
 RewriteBase /
 RewriteCond %{REQUEST_FILENAME} !-f
 RewriteRule \.(jpeg|jpg|gif|png)$ /public/404.php [NC,L]

 RewriteCond %{REQUEST_FILENAME} !-f
 RewriteCond %{REQUEST_FILENAME} !-d
 RewriteRule . /index.php [L]
 </IfModule>

 

 On a local host environment go to Search Engine Optimization and turn off Rewrite URL's this causes huge 404 page errors in a local environment. Especially if you are using Wamp's latest version like I am...

 

 

Share this post


Link to post
Share on other sites

I tested on localhost, with clean setup, that annoying /forum aspear too.

​I think you missed WHY it appears. What have you set here under “Default application"?

Bildschirmfoto_2014-12-10_um_06.56.21.th

If you set it to Forums, you will get the result you want. If you set it to anything other than Forums, you will end up with /forum/forum.

If you don’t want Forums to be your default app, then you need to move the 4.0 suite out of your manually set up /forums directory. The software will then add that /forums slug again and you don’t have it twice. 

So it’s totally up to you. You can remove the first /forum (by getting rid of that folder), the second /forum (by choosing Forums as default app) or even both. You choice. 

 

Edited by opentype

Share this post


Link to post
Share on other sites

​I think you missed WHY it appears. What have you set here under “Default application"?

Bildschirmfoto_2014-12-10_um_06.56.21.th

If you set it to Forums, you will get the result you want. If you set it to anything other than Forums, you will end up with /forum/forum.

If you don’t want Forums to be your default app, then you need to move the 4.0 suite out of your manually set up /forums directory. The software will then add that /forums slug again and you don’t have it twice. 

So it’s totally up to you. You can remove the first /forum (by getting rid of that folder), the second /forum (by choosing Forums as default app) or even both. You choice. 

 

This is the infomation im looking for, sad thing its come from another +client but not ipb staffs :(

Thank you.

Share this post


Link to post
Share on other sites

This is the infomation im looking for, sad thing its come from another +client but not ipb staffs :(

Thank you.

​I had the same problem as you. My solution was to go to the Admin CP > System > Advanced Configuration > Friendly URLs (Tab)

Scroll to the bottom, there are two that end with "/forum/id-??.xml" & "/forum/id-??.xml". You can edit out the "/forum/" and it should work fine. That was what i did in order to avoid moving everything.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...