Jump to content

Community

Incarnia

I can't be updated on Beta 3a

Recommended Posts

Did you run the upgrader ?

Check in both the forum directory and maybe inside the /admin (or renamed if appropriate) directory for an error_log file.

I did two upgrades, both from b2. The localhost one went without issue it seems, the "live" one blanked out with these two messages before I was able to get anywhere (ie no upgrader run)

 

⁣[07-Dec-2014 19:55:38 UTC] PHP Fatal error:  Call to undefined method IPS\Theme\class_core_global_forms::rowDesc() in /******/public_html/system/Helpers/Form/FormAbstract.php on line 249
[07-Dec-2014 19:55:38 UTC] PHP Fatal error:  Uncaught exception 'IPS\Db\Exception' with message 'Column 'member_id' cannot be null' in /******/public_html/system/Db/Db.php:374

I would (random guess) your error might be similar. Issue here is the ACP is inaccesible so an external tool might be needed (something along the lines of the 3x upgradefinish to do a quick build maybe) Take a look at the error_log file(s) if you have them present anyway.

I guess a new beta will be out soon though.

Share this post


Link to post
Share on other sites

Did you run the upgrader ?

Check in both the forum directory and maybe inside the /admin (or renamed if appropriate) directory for an error_log file.

I did two upgrades, both from b2. The localhost one went without issue it seems, the "live" one blanked out with these two messages before I was able to get anywhere (ie no upgrader run)

 

⁣[07-Dec-2014 19:55:38 UTC] PHP Fatal error:  Call to undefined method IPS\Theme\class_core_global_forms::rowDesc() in /******/public_html/system/Helpers/Form/FormAbstract.php on line 249
[07-Dec-2014 19:55:38 UTC] PHP Fatal error:  Uncaught exception 'IPS\Db\Exception' with message 'Column 'member_id' cannot be null' in /******/public_html/system/Db/Db.php:374

I would (random guess) your error might be similar. Issue here is the ACP is inaccesible so an external tool might be needed (something along the lines of the 3x upgradefinish to do a quick build maybe) Take a look at the error_log file(s) if you have them present anyway.

I guess a new beta will be out soon though.

​I found the solution, a hard reset of a forum :sad:

Share this post


Link to post
Share on other sites

​I found the solution, a hard reset of a forum :sad:

​That's a bit of a drastic (although highly likely to be successful) fix I would of thought.

I had to speculate with the OP's 'issue' as without the error log its difficult to say what is causing it.

I'll take a look at repairing my "live" installation later this week when I have time, tempting fate but if the localhost one had fell over it would of been easier as I could deal with that, having highly limited connectivity at the moment limits my time (patience, really I guess due to a temp dial up line) with a 'live' problem. :)

Share this post


Link to post
Share on other sites

I was finally able to update today. I took a fresh install of Beta 2 along with my updated install from 3.4.7 to beta 2 and had to copy/paste the members, topics, posts, etc into the fresh install. Then had to do a lot of cleaning up and finally was able to upgrade to 3a successfully.

A big PITA but on the other hand I now have my database nice and clean of all those old third party mods I've gathered over the years.

Share this post


Link to post
Share on other sites

But there is one more small problem

wp_ss_20141208_0001.png

​  That is exactly what I had.  After almost 10 tries I give up.  so I went to the IPS client site, downloaded the entire IPS 4.0 with beat 3 and uploaded a fresh copy of the entire thing.  Didn't try to upgrade nothing.  And it worked.....:sweat:   Finally.   I think, just me, that better step-by-step instructions need to be developed for Beta 4.  This upgrade from 2 to 3 was extremely difficult and I'm a semi-geek.  Imagine someone who is not.

Share this post


Link to post
Share on other sites

​  That is exactly what I had.  After almost 10 tries I give up.  so I went to the IPS client site, downloaded the entire IPS 4.0 with beat 3 and uploaded a fresh copy of the entire thing.  Didn't try to upgrade nothing.  And it worked.....:sweat:   Finally.   I think, just me, that better step-by-step instructions need to be developed for Beta 4.  This upgrade from 2 to 3 was extremely difficult and I'm a semi-geek.  Imagine someone who is not.

 


Well it's a beta. And Beta 3 had a rocky release. Beta 4 (or 5 since Beta 3a is called 4 in Applications) should hopefully make things a lot easier for most. But that's the risk we take with betas.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy