Jump to content

Being logged out issue with Xcache.


albn

Recommended Posts

Hi all

I'm in the process of optimising a somewhat large IPB forum, I've installed Xcache and enabled it within the IPB config file, but users keep on getting logged out every now and again

Disabling xcache and they're able to stay logged in

I had the same issue with an Xenforo forum and adding a line to the config file to disable caching of sessions fixed it

Any tips?

Edit- Bit more information

A friend of mine says it's because I have apache running as FastCGI as opposed to DSO

He suggested changing to mod_ruid2

Any thoughts?

Link to comment
Share on other sites

  • 2 weeks later...

If you want me to suggest a solution without going back and forth for a long time trying to find the issue...

configure ipb to not use any caching system. (do this first to avoid downtime)

uninstall xcache

install memcached (daemon) - Off memory, should be available under EPEL repo

install php-pecl-memcache (php plugin) - Off memory, should also be available under EPEL repo. make sure to get php-pecl-memcache, not php-pecl-memcached plugin.

install zend opcache (if php 5.5+ just turn it on from ini) - You can get it from: http://pecl.php.net/package/ZendOpcache there is only beta version.

restart php

configure ipb to use memcache instead.

---------

Edit: Realized I posted like a week+ too late.

Link to comment
Share on other sites

If you want me to suggest a solution without going back and forth for a long time trying to find the issue...

configure ipb to not use any caching system. (do this first to avoid downtime)

uninstall xcache

install memcached (daemon) - Off memory, should be available under EPEL repo

install php-pecl-memcache (php plugin) - Off memory, should also be available under EPEL repo. make sure to get php-pecl-memcache, not php-pecl-memcached plugin.

install zend opcache (if php 5.5+ just turn it on from ini) - You can get it from: http://pecl.php.net/package/ZendOpcache there is only beta version.

restart php

configure ipb to use memcache instead.

---------

Edit: Realized I posted like a week+ too late.

You are saying ti disable the cache system and enable memcache?

I have both enabled.

Link to comment
Share on other sites

  • 3 months later...

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...