Jump to content

help setting up local testing server

Recommended Posts

This is my first time trying to set up a local testing server, and I could really use some help! I already have a live site, but now I want to do some development without screwing it up.

Here's what I've been able to do so far:

  • installed Wamp Server 2.4, 32-bit, with Apache 2.4.4, PHP 5.4.16, and MySQL 5.6.12
  • installed ioncube (the installer chose the version for me)
  • on my live site, created backups of my home directory and sql databases
  • imported my sql database on my local server (localhost) using phpmyadmin
  • put a copy of my entire home directory at c:wampwwwmysite.org

That's where I get stuck.

In my browser, if i go to localhost/mysite.org/ I see "Index of /mysite.org" and this:


If I click on or type to go to localhost/mysite.org/public_html/ then i see a blank screen. Same if I go to localhost/mysite.org/public_html/forums/

If I add index.html to either of those addresses, i get an error "The requested URL /mysite.org/public_html/index.html was not found on this server."

Am I missing some critical step? Do I need to somehow install the IPS software, or was copying the site directory enough?

If it matters, my site is running IP.Content out of the root, so mysite.org/index.html is an IP.Content file, and my forums are at mysite.org/forums/

I know this is probably no-brainer stuff to many of you, but I would greatly appreciate any tips you could share. Thanks!

Link to comment
Share on other sites

I see you are running cpanel.

First, delete everything other than public_html.

Then move everything inside public_html to your current directory. Now delete the empty public_html directory.

You can keep the dir structure if you like... but they're pretty much junk to you without cpanel.


I'm not running wamp, so I'm not sure where it is, but whenever something goes wrong (like the blank page), look at your error log. Maybe something like wamp/log/error.log

You can also specify where to set error logs in your php.ini.

Make sure to correct your configuration in your forums/conf_global.php to your new db connection as well as your address.

Your new address should be like http://localhost/mysite.org/ (according to you).

You can setup vhosts or change the root of your localhost so it's just http://localhost/ or similar.

Link to comment
Share on other sites

Thanks for the suggestions so far.

I took Grump's advice and got rid of everything except the contents of public_html, so now my site is all at c:wampwwwmysite.org

Just to be safe, I also ran IPS's compatability checker and apparently passed everything (see attachment).

Also, after googling the problem and finding it to be a possible issue, I checked to make sure no other services were using port 80. None were.

Finally, I took a look at my conf_global.php which is now located at c:wampwwwmysite.orgforumsconf_global.php

I had not done this previously, so your suggestions that it was a database connection problem were probably accurate. I made the following changes:

$INFO['board_url'] = 'http://localhost/mysite.org/forums';
$INFO['sql_user'] = 'username';
$INFO['sql_pass'] = 'password';

where 'username' is the name of the user I created on my local installation of phpmyadmin and 'password' is the password for that user.

I restarted all services and tried again by going to localhost/mysite.org/ and localhost/mysite.org/forums/ and localhost/mysite.org/forums/admin/
All return the blank white screen.
I checked the error logs located at c:wamplogs
In access.log the last entries are: - - [05/Apr/2014:10:25:54 -0500] "GET /mysite.org/ HTTP/1.1" 200 - - - [05/Apr/2014:10:39:49 -0500] "GET /mysite.org/forums/ HTTP/1.1" 200 - - - [05/Apr/2014:10:39:52 -0500] "GET /mysite.org/forums/admin/ HTTP/1.1" 200 -

In apache_error.log the last entries, starting from when I restarted all services, are:

[Sat Apr 05 10:22:47.682403 2014] [mpm_winnt:notice] [pid 3384:tid 556] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Sat Apr 05 10:22:49.683517 2014] [mpm_winnt:notice] [pid 4912:tid 416] AH00364: Child: All worker threads have exited.
[Sat Apr 05 10:22:49.706519 2014] [mpm_winnt:notice] [pid 3384:tid 556] AH00430: Parent: Child process 4912 exited successfully.
[Sat Apr 05 10:23:23.861472 2014] [mpm_winnt:notice] [pid 6172:tid 556] AH00455: Apache/2.4.4 (Win32) PHP/5.4.16 configured -- resuming normal operations
[Sat Apr 05 10:23:23.861472 2014] [mpm_winnt:notice] [pid 6172:tid 556] AH00456: Server built: Feb 23 2013 13:07:34
[Sat Apr 05 10:23:23.861472 2014] [core:notice] [pid 6172:tid 556] AH00094: Command line: 'c:wampbinapacheapache2.4.4binhttpd.exe -d C:/wamp/bin/apache/Apache2.4.4'
[Sat Apr 05 10:23:23.862472 2014] [mpm_winnt:notice] [pid 6172:tid 556] AH00418: Parent: Created child process 6628
[Sat Apr 05 10:23:24.261495 2014] [mpm_winnt:notice] [pid 6628:tid 416] AH00354: Child: Starting 150 worker threads.
In mysql.log, starting from when I restarted all services, are:
2014-04-05 10:23:24 6196 [Note] Plugin 'FEDERATED' is disabled.
2014-04-05 10:23:24 6196 [Note] InnoDB: The InnoDB memory heap is disabled
2014-04-05 10:23:24 6196 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2014-04-05 10:23:24 6196 [Note] InnoDB: Compressed tables use zlib 1.2.3
2014-04-05 10:23:24 6196 [Note] InnoDB: Not using CPU crc32 instructions
2014-04-05 10:23:24 6196 [Note] InnoDB: Initializing buffer pool, size = 128.0M
2014-04-05 10:23:24 6196 [Note] InnoDB: Completed initialization of buffer pool
2014-04-05 10:23:24 6196 [Note] InnoDB: Highest supported file format is Barracuda.
2014-04-05 10:23:24 6196 [Note] InnoDB: 128 rollback segment(s) are active.
2014-04-05 10:23:24 6196 [Note] InnoDB: Waiting for purge to start
2014-04-05 10:23:24 6196 [Note] InnoDB: 5.6.12 started; log sequence number 1626057
2014-04-05 10:23:24 6196 [Note] Server hostname (bind-address): '*'; port: 3306
2014-04-05 10:23:24 6196 [Note] IPv6 is available.
2014-04-05 10:23:24 6196 [Note] - '::' resolves to '::';
2014-04-05 10:23:24 6196 [Note] Server socket created on IP: '::'.
2014-04-05 10:23:24 6196 [Note] Event Scheduler: Loaded 0 events
2014-04-05 10:23:24 6196 [Note] wampmysqld: ready for connections.
Version: '5.6.12-log' socket: '' port: 3306 MySQL Community Server (GPL)
There's also a file called log_dir which doesn't show anything except log_dir when I open it in notepad.
It does seem like some kind of configuration problem, possibly to do with connecting to the database. Here is my entire conf_global.php, in case it help:
$INFO['sql_driver']			=	'mysql';
$INFO['sql_host']			=	'localhost';
$INFO['sql_database']			=	'ornithol_ipb';
$INFO['sql_user']			=	'username';
$INFO['sql_pass']			=	'password';
$INFO['sql_tbl_prefix']			=	'';
$INFO['sql_debug']			=	'0';
$INFO['sql_charset']			=	'';
$INFO['board_start']			=	'1279799114';
$INFO['installed']			=	'1';
$INFO['php_ext']			=	'php';
$INFO['safe_mode']			=	'0';
$INFO['board_url']			=	'http://localhost/mysite.org/forums';
$INFO['banned_group']			=	'5';
$INFO['admin_group']			=	'4';
$INFO['guest_group']			=	'2';
$INFO['member_group']			=	'3';
$INFO['auth_group']			=	'1';
$INFO['use_friendly_urls']			=	'1';
$INFO['_jsDebug']			=	'0';
$INFO['mysql_tbl_type']			=	'MyISAM';

define('IN_DEV', 0);


The only things I changed above were the username and password and 'mysite' in the board_url

I've checked in phpmyadmin and the user i created has all privileges

I also tried using 'root' and '' for username and password, because I haven't altered the default setup on my local machine, but that didn't help.

So what should the username and password be set to? Are they for my pma user? Or is there some other username/password associated with mysql?

Thanks again for any help!


Link to comment
Share on other sites

you turn on error reporting to see whats actually happening?

on second line of initdata just under the <php put


to see what if any errors there are.

when done can just change it to


to disable reporting.

if its php error it should show, may help rule that out.

Link to comment
Share on other sites

you turn on error reporting to see whats actually happening?

on second line of initdata just under the <php put

to see what if any errors there are.

when done can just change it to

to disable reporting.

if its php error it should show, may help rule that out.

I tried that, but no errors show. Still a blank browser window. http:// localhost/ shows just fine, but http:// localhost/mysite.org/ is blank. However if I go to http://localhost/mysite.org/file-that-doesnt-exist.html I get a file not found error message.

Besides ini_set('display_errors',1); what other options can I turn on to help localize the error, and what error logs do I need to check? This is all new to me, so I really appreciate your help.

Link to comment
Share on other sites

As a final note, I really don't see why IPS can't do something for us hosted communities. At the rate I pay, they get more out of me as a hosted community than they would from a license, after the first year or so. Maybe for communities who've had a hosted community for a while they could offer a test install?

Link to comment
Share on other sites

So since you must buy a license, what's the best way to work "offline" with a local copy (where you on't affect your live site)?

Do all the things I listed in my original post. Then read the other links in this thread.

Link to comment
Share on other sites

Sorry I wasn't clear on what's wrong on my end. I have read the thread multiple times, plus the links. Nothing has covered my error, and I was trying to problem solve that.

I can see my board at localhost/MySite.com/forum/

However, I can't log in, When I click the "Sign In" Link, it just sits there. Doesn't do anything.

EDIT: went straight to the admin folder for log in. seems to be working.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...